Casio Z750 lens error / blurry fuzzy images

Discussion in 'Digital Photography' started by vuefoto, Sep 5, 2005.

  1. vuefoto

    vuefoto Guest

    I am a photographer and have just purchased the Casio ex-z750 camera.
    At first I was very pleased with the camera (still am when it works).
    But receintly I have been getting some blurry / fuzzy images. At first
    I thought this was just camera shake, and didn't think much of it. As
    it started happening more I ran some tests (tripod >= 1/250 sec), and
    I've determined that this isn't camera shake. I have gotten the "lens
    error" message a few times, but I'm not sure of these are related or
    not. I am seeing some other comments on the lens error, but nothing
    about blurry images.

    I have sent a email to Casio, and I hope to hear from them within the
    next few days. The unit was purchased from B&H Photo, I may try
    calling them and see if they could exchange it for another unit.

    Thanks in advance.
    Brent Edwards
     
    vuefoto, Sep 5, 2005
    #1
    1. Advertisements

  2. vuefoto

    RogBaker Guest

    This is caused by the camera accidently turning on in an enclosed space
    (pocket). The lens hits an obstruction and gears or something breaks. I
    think this camera has 3 different ways to turn it on. I think with the
    menus, you can turn off one or two was and only use the primary button.
    -Roger
     
    RogBaker, Sep 16, 2005
    #2
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.