Can't get trunk working between Catalyst 2960G and 4507R

Discussion in 'Cisco' started by Ned, Jan 10, 2007.

  1. Ned

    Ned Guest

    My network has a 4507R at the core with 3750G's and 3560G's configured
    for trunking using 802.1q. Trunking works on all switches except for a
    newly configured 2960G. I configured the 2960G exactly like my other
    switches with the exception of the encapsulation command for 802.1q
    because they only support 802.1q. If I go to my 4507 and do a "sh cdp
    nei det" I can see the 2960G but it shows that no IP addresses are
    configured. If I do the same command on the 2960G I can see the 4507
    but I cannot telnet to its IP address. The management vlan is 50 which
    shows as being up everywhere except for the 2960G. I am pasting parts
    of my config here in the hopes that I can get help. Also, the VTP mode
    on the 4507 is set to transparent.

    Thanks!

    CONFIG FROM WORKING 3560G

    interface GigabitEthernet0/52
    switchport trunk encapsulation dot1q
    switchport trunk native vlan 50
    switchport mode trunk
    !
    interface Vlan1
    no ip address
    shutdown
    !
    interface Vlan50
    ip address 192.168.8.15 255.255.248.0





    CONFIG FROM NON-WORKING 2960G
    inteface GigabitEthernet0/48
    switchport trunk native vlan 50
    switchport mode trunk
    !
    interface Vlan50
    ip address 192.168.8.25 255.255.248.0
    no ip route-cache



    RESULTS OF "SH CDP NEI DET" ON MY 4507 for non-working switch
    Device ID: HSB1
    Entry address(es):
    IP address: 0.0.0.0
    Platform: cisco WS-C2960G-48TC-L, Capabilities: Switch IGMP
    Interface: GigabitEthernet5/2, Port ID (outgoing port):
    GigabitEthernet0/48
    Holdtime : 137 sec

    Version :
    Cisco IOS Software, C2960 Software (C2960-LANBASE-M), Version
    12.2(25)SEE2, RELE
    ASE SOFTWARE (fc1)
    Copyright (c) 1986-2006 by Cisco Systems, Inc.
    Compiled Fri 28-Jul-06 04:33 by yenanh

    advertisement version: 2
    Protocol Hello: OUI=0x00000C, Protocol ID=0x0112; payload len=27,
    value=0000000
    0FFFFFFFF010221FF000000000000001A6C2FA280FF0000
    VTP Management Domain: 'MYNET'
    Native VLAN: 50
    Duplex: full
    Management address(es):
    IP address: 0.0.0.0
    Unidirectional Mode: off



    Thanks for your help
     
    Ned, Jan 10, 2007
    #1
    1. Advertisements

  2. interface Vlan50
    no shutdown

    ?

    just a guess
     
    Martin Bilgrav, Jan 10, 2007
    #2
    1. Advertisements

  3. Ned

    J Guest

    Check your VLAN table to make sure that the 2960 actually created vl50
    (sh vlan). This would be consistent with you not seeing vl50's IP in
    the CDP detail on the 4507.

    Crank up your buffered logging to debugging and see if anything useful
    is being logged.

    J
     
    J, Jan 10, 2007
    #3
  4. Ned

    Ned Guest

    Thanks, but I tried this and it did not work.

     
    Ned, Jan 11, 2007
    #4
  5. Ned

    Ned Guest

    It does not appear in the vlan table.
    I will check the logs too.
    I opened a case with Cisco but we played phone tag for most of the day
    and I finally ended up going home.
     
    Ned, Jan 11, 2007
    #5
  6. Ned

    BernieM Guest

    so what happens when you manually create it?
     
    BernieM, Jan 11, 2007
    #6
  7. Ned

    Bod43 Guest

    Does the 2950 need the

    #vlan database
    (vlan)#vlan 50
    (vlan)#exit
    #

    form?
     
    Bod43, Jan 11, 2007
    #7
  8. Ned

    Ned Guest

    Thanks. That was exactly what it needed.
    I just got off the phone with Cisco TAC and he had me key this in. Now
    the vlan works.

    Thanks for your help!
     
    Ned, Jan 11, 2007
    #8
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.