Can't get the internet from the client computer on an ad hoc netwo

Discussion in 'Wireless Networking' started by Harry, Jan 17, 2009.

  1. Harry

    Harry Guest

    I set up a wireless ad hoc network on 2 computers running XP Home, using the
    Windows wizard. The host computer has a broadband connection. Both computers
    connect with a strong signal. Under Network Connections the host computer
    shows both the broadband and wirelss network connections normally, as does
    the client computer. I can access the shared folders I set up from either
    computer. My broadband connections works normally from the host compter, but
    I cannot access the internet from the client computer (even though it shows
    the broadband connection).
    Windows Firewall is On for the host computer, Off for the client.
    I have disabled WEP (on advice I read elsewhere in this group)

    Can anyone suggest what is blocking my access to the internet from my client
    Harry, Jan 17, 2009
    1. Advertisements

  2. Harry

    Alister Guest

    You need to setup Internet Connection Sharing (ICS) on the Host

    Alister, Jan 17, 2009
    1. Advertisements

  3. Harry

    Harry Guest

    Alister - I had set up ICS according to the prompts in the original setup &
    the host computer shows that ICS is there.
    To get the internet from the client do I simply open Internet Explorer & go?
    Or is there something you have to configure first? When I try it simply says
    web page unavailable (& there is no activity indicated on the host's
    broadband modem i.e. nothing is being sent from the client to the host).
    Harry, Jan 18, 2009
  4. Harry

    Alister Guest

    Oh blimey, It's a long time since I did anything with ICS.

    Try setting up the Host following these instructions:

    and then set up the client by following these:

    If it still doesn't work, I will see if I can dredge anything else up.

    Alister, Jan 18, 2009
  5. Harry

    James Egan Guest

    With ics, the client (usually) gets its ip address and other
    configuration information from the host when it is started up. In
    order to do this the wireless network must be up and running otherwise
    dhcp will fail and the client will give itself an apipa address in the
    range You can check to see if it is doing this by
    typing ipconfig at a command prompt

    If so you can give the client alternative static settings as follows

    ip address
    subnet mask
    default gateway
    domain nameserver

    Then once you have joined the wireless network of the host everything
    else (like IE) should work okay without additional configuration.

    James Egan, Jan 18, 2009
  6. Harry

    Harry Guest

    Alister - thanks, I did what you said, but found it was what I had already
    done. Can't remember for sure, but its possible the only thing I did
    differently was, on the client, to choose the auto option rather than "Let me
    choose the connection to my network." Whatever, the tip from James Egan
    solved the blockage. My client computer showed the correct entries for
    everything in the IP addresses window except for preferred DNS which was
    blank. When I manually entered here I got IE to get the internet.
    But thanks for helping - I owe you a tube or two!
    Harry, Jan 19, 2009
  7. Harry

    Harry Guest

    Jim - you saved me from kicking my computer through Bill Gates' windows
    (dodgy pun, I know). Everything on the client computer was as it should be
    except that the DNS server window was blank. Entered the address you gave &
    it unblocked it. Amazes me that such a small deficiency (or ambiguity) in the
    wizard can totally foul up the works. Much obliged.
    Harry, Jan 19, 2009
  8. Harry

    James Egan Guest

    Tnx for the feedback.

    James Egan, Jan 19, 2009
  9. Harry

    Aaron Guest

    Same Problem, everything is cfg'd as described in these posts even before I
    logged on, client was provided w/DHCP / DNS of by
    the host cpu. Host is cfg'd w/ICS and shows connected, Shared. FW is off for
    the moment. the single client still cannot bring up a web page in IE / FF. I
    know its a DNS issue, but cannot figure out where. btw I can ping (, so i know I;m connected through, just cannot
    resolve - please help
    Aaron, Mar 11, 2009
  10. Harry

    Lem Guest

    Please don't post at the tail end of a 2-month-old closed thread. Start
    your own thread with a descriptive subject and include relevant details
    instead of "same problem." Be sure to include the malware status of
    your computer (and how you know).

    How to Ask a Question -
    How Not to Get Technical Help on Usenet -

    You might try running ipconfig /all *on the host computer* and then
    setting the client computer to use the reported IP address of your ISP's
    DNS server(s). Or see if these shots in the dark are applicable:
    Lem -- MS-MVP

    To the moon and back with 2K words of RAM and 36K words of ROM.
    Lem, Mar 11, 2009
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.