Cant get onboard Gigabit NIC to work in XP64

Discussion in 'Windows 64bit' started by Kevin J. Nielsen, Nov 26, 2006.

  1. I have an ASUS k8v motherboard with an AMD 64 3200+ 2GHz processor with 1.5
    GB ram. The motherboard has an onboard network adapter (3com Gigabit
    3c940) and I cannot install the drivers for it, nothing is accepted. I
    have downloaded all kinds of drivers for my NIC that claim to work with XP64
    but nothing works.

    Does anyone have any suggestions as to how I can get my NIC to work in XP64?

    I would sincerely appreciate any help anyone can give me with this matter.


    Thank You

    Kevin Nielsen
     
    Kevin J. Nielsen, Nov 26, 2006
    #1
    1. Advertisements

  2. Thank You Tony. I will look for a driver called IA64 (Itanium). My NIC is
    enabled otherwise I wouldnt be able to communicate with you now; I have a
    dual boot with XP home and XP64. My NIC works fine in XP home.

    Kevin Nielsen
     
    Kevin J. Nielsen, Nov 26, 2006
    #2
    1. Advertisements

  3. Not much can really go wrong. The chip may be faulty - it isn't enabled in
    the BIOS - and your driver is IA64 (Itanium), and not AMD64.

    Note, that even if you did enable the function in the BIOS, a system crash
    and re-boot may reset the BIOS to it's default. You may need to check every
    time this happens!


    Tony. . .
     
    Tony Sperling, Nov 26, 2006
    #3
  4. Oh, no! You misunderstand. I was suggesting, if the driver you installed was
    for 64bit Itanium -that would not work! Sorry!

    O.K. If it works, there really isn't much else, except the driver that I can
    think about - make sure the driver you install is for AMD64 platform, and XP
    x64 has a Firewall which 'Home' doesn't. You may have to check that - and do
    note that network parts of same make and number can have different chips -
    make sure you get the proper driver. This may be tricky information to
    uncover if you don't have the original manual.


    Tony. . .
     
    Tony Sperling, Nov 26, 2006
    #4
  5. Kevin J. Nielsen

    NuTCrAcKeR Guest


    Please share how you derrived that the driver was for IA64 and not X64 ? I
    am unable to discern how you could determine this based on the information
    provided by the OP.

    - NuTs
     
    NuTCrAcKeR, Nov 26, 2006
    #5
  6. I couldn't - I was recounting the most reasonable things to be the possible
    fault - Itanium drivers have trapped a few, here.

    Heck, I don't even know if any such thing exist for the product in question,
    just naming a few things that would be worth checking in this situation.


    Tony. . .
     
    Tony Sperling, Nov 27, 2006
    #6
  7. Kevin J. Nielsen

    Dshai Guest

    I'm running the A7V board with the same processor but my onboard NIC is a
    Marvel Yukon Gigabit, XP x64 had a native driver and Asus offers a 64bit
    driver on their site, however I see that the same isn't true of the3com on
    the K8V, it may be prudent to contact either Asus or 3com about this
    product, although even a search at driversguide.com produced no 64bit
    version of the driver for this NIC, perhaps this one will work:
    http://www.opendrivers.com/driver/2...s-1.00.00.0044-for-windows-free-download.html
    it lists Win All but that's not necessarily 64bit I've found.

    Dshai
     
    Dshai, Nov 27, 2006
    #7
  8. Kevin J. Nielsen

    Theo Guest

    Apparently the 3c940/3c2000 drivers and the Yukon are
    exactly the same.

    You can find 3Com drivers at:
    ftp://ftp.3com.com/pub/nic/3c2000-t/

    And Yukon drivers at: http://www.marvell.com/drivers/search.do

    In both instance the files are labeled as: yk51x64
     
    Theo, Nov 27, 2006
    #8
  9. Thank You for your time Dshai. I will try those drivers and let you know if
    they work.

    Kevin
     
    Kevin J. Nielsen, Nov 28, 2006
    #9
  10. I tried the drivers from the 3com link and they wouldnt work. I couldnt
    find any drivers at the marvell link, Maybe I wasnt typing in the correct
    search criteria.

    Thanks Anyway

    Kevin
     
    Kevin J. Nielsen, Nov 28, 2006
    #10
  11. The Marvel Yukon drivers may be on hold. My board has both the nVidia and
    MY NIC's and it was the MY that worked up through RC2 but with rtm Vista
    installed the nVidia driver and not the MY. An MY driver may be available
    through Microsoft Update by the time of Launch.
     
    Colin Barnhorst, Nov 28, 2006
    #11
  12. Kevin J. Nielsen

    Theo Guest

    You don't have to fill in all the options. If you just
    select Win XP x64 in the bottom slot, you'll get all the
    drivers for Win XP x64. If you want Vista x64, then select
    Vista x64.
     
    Theo, Nov 28, 2006
    #12
  13. Kevin J. Nielsen

    Dennis Pack Guest

    Kevin:
    The latest MY driver is "Yukon Windows x64 Win XP & Server 2003
    Driver Win XP x64, Server 2003 x64 11/2/06 8.61.2.3". Start at
    http://marvell.com/products/pcconn/yukon/index.jsp, click download drivers
    in the right column, use Yukon and Win XP x64 for key words. Also there are
    Vista drivers available using Vista x64 instead of Win XP x64.
     
    Dennis Pack, Nov 28, 2006
    #13
  14. Thank you for that. I was able to download the yukon drivers but
    unfortunately they didnt work.

    The strange thing is that I received a post from another newsgroup from a
    person who has the same motherboard as me. She was able to get her onboard
    nic to work with the drivers that she gave me the link to. I tried those
    drivers and they didnt work either. I am starting to think that I am
    missing something, like maybe some drivers for my motherboard that will
    allow the nic to be detected. I did find an ACPI driver on the ASUS site
    for Win64 but I dont know how to install it or what it is. Could it be
    that I need to install the ACPI driver before I can Install my nic?

    Thank You

    Keven Nielsen
     
    Kevin J. Nielsen, Nov 29, 2006
    #14
  15. Thank You Colin. I guess I didnt need it because I already have a Windows
    provided ACPI driver.

    Keven
     
    Kevin J. Nielsen, Nov 30, 2006
    #15
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.