Can't activate Wireless Zero Configuration service

Discussion in 'Wireless Networking' started by Dudi, Aug 30, 2007.

  1. Dudi

    Dudi Guest


    I use XP SP2, D-Link W/L USB card: DWL-120 (902.11b).

    All of a sudden, my PC stopped automatically connecting to my wireless
    network on power on. The only way I can force this connection to be set is
    by executing D-Link W/L utility.
    When I am trying to activate the WZC service it is failed and I'm prompted
    with an error message #1068. I referred to MS article ID: 871122 but looks
    like that something disappeared in the Network connection. Following that
    article, "....In Network Connections, click to select your wireless
    connection, and then click Change settings of this connection. On the
    Wireless Networks tab, click to select the Use Windows to configure my
    wireless network settings check box."
    I don't get this Wireless Networks tab option!!! How can I restore the WZC
    automatic activation ???

    Please advise
    Dudi, Aug 30, 2007
    1. Advertisements

  2. Hi
    Did the card worked before?
    The DWL-120 802.11b is an old card, some of the DWL-120 versions are not
    even Win XP compatible.
    I would try to uninstall the Utility and the card's driver, and reinstall
    them again.
    Or better of, given the low price of Wireless cards get a nice 802.11g card.
    Jack (MVP-Networking).
    Jack \(MVP-Networking\)., Aug 30, 2007
    1. Advertisements

  3. Dudi

    Dudi Guest

    It works fine for the last three years. Please note that even now, I manage
    to establish the W/L connection when I run the D-Link utility manually. The
    problem is that the WZC service stopped somehow to function. Since the card
    as well its drivers are all the same I believe that something went wrong
    with the OS.

    Dudi, Aug 30, 2007
  4. The DLink utility will take control away from WZC. You can not use
    both,..only one can be in control,...the other will remain disabled.

    I am not personally familar with DLink's tools, but there may be a place in
    it to tell it to let WZC control the Wireless Nic which will cause the tool
    to "get out of the way".

    For example, my laptop has a "Dell Wireless WLAN Card Utility" that manages
    the wireless networks. But if I want to use WZC then I have to go in the
    "Dell Wireless WLAN Card Utility" and uncheck the box that says "Let this
    tool manage your wireless networks" which will cause the tool to "back off"
    and let WZC manage the wireless networks.

    Phillip Windell

    The views expressed, are my own and not those of my employer, or Microsoft,
    or anyone else associated with me, including my cats.
    Phillip Windell, Aug 30, 2007
  5. Dudi

    Ramesh R Guest

    Just to add more to this info: Some of the Wireless Card utilities,
    when installed (interactively or forcefully) turn off the WZC in
    windows services. Go to control panel ->administrative tools ->
    services -> WZC & make sure that the service is enabled & set to
    automatic start.

    Ramesh R, Aug 31, 2007
  6. Dudi

    Guest Guest

    Yes. This was the comon practice before Microsoft published the API that
    allow disable WZC on a single adapter, thus avoiding killing the whole WZC
    ( Also, during the beta, some vendors had to use undocumented hacks )

    Guest, Aug 31, 2007
  7. Dudi

    Dudi Guest

    Let me describe in few words the D-Link Utility. The utility runs in two
    modes: Full control and "Status" mode. The Full control mode is more
    suitible to your comments below. As for "Status" mode it comes into effect
    when WZC is enabled.
    However, until few days ago, the utility ran in "Status" mode, showing
    signal level, channel number, etc. (does not enable any setting). All of a
    sudden, this mode was gone and now the utility runs in Full mode. As I
    described in my first post, when I try to enable the WZC it prompts back
    with error 1068. It happens also when the D-Link utility is off.

    Dudi, Sep 1, 2007
  8. Dudi

    Dudi Guest

    I also noticed that the WZC claims two dependencies - NDIS Usermode I/O
    protocol and Remote Procedure Call (RPC). Since RPC is started I guess that
    something got wrong with the NDIS service. I didn't locate the NDIS Usermode
    service in the services list. Is there any way to see what and how NDIS is
    functioning on my PC?

    Dudi, Sep 2, 2007
  9. Dudi

    Guest Guest

    Yes it was most helpful ,even for a novice like me. Thanks ,to you guys. Wash
    your car ..sure lol
    Guest, Oct 2, 2007
  10. Dudi

    Guest Guest

    pucca i have been playing about with this for months after my computer had to
    be wiped cos of a virus when i got it back the wireless didnt work error
    message wzc 871122 keeped coming up .after reading these messages i have
    cracked it!. thanks to you guys cheers.P.S WZC=wireless zero
    configuration(for those as thick as me lol)
    Guest, Oct 18, 2007
  11. I have done what you said , but I did not get any option to change to window.
    even reintalled but still not working and giving message WZC 871122 required.
    Ali Shooshtari, Feb 8, 2008
  12. Dudi

    Pavel A. Guest

    If you don't see the wireless tab, the wzc service is not runnng -
    check why.

    Pavel A., Feb 10, 2008
  13. I don`t find.... On the
    My case is following, my laptop Hp with windows 2002, when I turn on, it
    inmediatly make a connection with my wireless home and is very good, but when
    I put my laptop on Hibernate or Stand by and I re-use again, my laptop not
    connection again with my wireless home, I always need to restart or turn off
    my laptop. Can you help me. Thanks
    JOHN JARAMILLO, Apr 2, 2008
  14. Dudi

    Sam Canoly Guest

    Sounds like you need to try reinstalling the driver for your network
    adapter. If that doesn't work just try reloading Windows.
    Sam Canoly, Apr 3, 2008
  15. Dudi

    aaa Guest

    aaa, Apr 6, 2008
  16. I have been trying to fix my son's computer for months as his computer just
    stopped showing any wireless networks to view. I never would have figured
    this out.

    Thank you!
    frustrated mom, Apr 21, 2008
  17. Dudi

    lola Guest

    hi, i tried to follow all what you mentioned above. but i didn't get any
    change. it is still asking me to check the article 871122 on i
    have an intel proset/wireless which i tried to fix. and instead it disabled
    my wzc. what to do? [i am a student with very limited information]
    lola, Aug 17, 2008
  18. Hi
    Switch Off the Intel utility and read this,
    Jack (MS, MVP-Networking)

    Jack \(MVP-Networking\)., Aug 17, 2008
  19. Dudi

    nitesh Guest

    nitesh, Sep 29, 2008
  20. Dudi

    Ralph Guest

    The same happen to me, my wireless network config by windows was for some
    reason switch to Intel pro wireless alone.

    First make sure the WZC (Windows Zero Configuration) is Started.

    Ok, to get this issue resolve of the error massage 871122, all you have to
    do is

    Go to Start and all programs then choose Intel Pro Wireless, on this window
    click on Tools and choose to use Window client manager. or were you see use
    Win clientF10. and this should fix the issue. hope this helps.
    Ralph, Dec 5, 2008
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.