Canon S1 IS -- Incompatible w/ USB 2.0 under Win2K?

Discussion in 'Digital Photography' started by Rick, Apr 17, 2004.

  1. Rick

    Rick Guest

    We just went through Install Hell this morning, trying to get our
    new Canon S1 IS installed under Windows 2000. After hours
    of trial and error we discovered Canon's Win2000 Twain driver
    is incompatible with our USB 2.0 card (standard NEC controller),
    using Microsoft's standard USB 2.0 driver. The camera was not
    seen at all, even though all of our other USB/USB 2.0 devices
    work perfectly under this same configuration.

    Finally we tried using the onboard USB 1.1 ports on our system
    motherboard and the camera was immediately seen.

    This is just an FYI for anyone having a similar problem. I sure
    wish Canon would come up with a seamless driver similar to
    most other manufacturers, that simply associate a removeable
    drive letter with the camera.

    Rick
     
    Rick, Apr 17, 2004
    #1
    1. Advertisements

  2. The S1 IS is only a USB1 device, Canon are slack it should have been a USB2
    device.
     
    AngryofMayfair, Apr 17, 2004
    #2
    1. Advertisements

  3. Some of your assumptions are not right Rick.
    NEC never did make a "standard" USB 2.0 card.
    Microsoft's "standard" USB 2.0 driver does not always work. If, for example
    you have certain SIS chipsets, you have to install a BIOS patch before it
    works properly. Basically, USB is a problematical interface. If you have the
    alternative of firewire, use it because it is faster and more stable than
    USB.

    Otherwise, upgrade your 2k to Service Pack 4 and the 'new' Microsoft USB
    driver. You can't expect product vendors to make USB compatible products
    when Microsoft insist on keeping the source for the drivers secret and do
    not allow vendors to provide a driver for USB for either Win2k or XP.
    Microsoft keep altering the code and not informing anyone so how in Gods
    name can you blame Canon when it's Microsoft who have taken over the
    standard? It's worse that the Java fiasco.

    Douglas
     
    Douglas MacDonald, Apr 17, 2004
    #3
  4. Rick

    Rick Guest

    Not a card. However they do make the most popular (and
    most widely supported) USB 2.0 *controller*. In fact,
    Microsoft's initial USB 2.0 driver supported only the NEC
    controller.
    Basic Intel BX system here, nothing special.
    I agree. However, for some reason most digital still camera
    manufacturers have opted for USB 2.0 instead of firewire.
    SP4 and the latest USB driver are installed. One of the many
    things we tried was reverting back to SP3 -- same problem.
    That's not true. Our USB 2.0 card (from ADS Tech) included
    its own Win2K driver. However, we didn't see 2.0 speed with
    our 2.0 devices until we installed MS's driver.
    Then someone needs to explain why our half dozen other USB
    devices (both 1.1 and 2.0) work perfectly with the same
    NEC-based card. Sony F717 camera, keyboard, mouse,
    scanner etc. I'd also like to know why Sony, Minolta, Oly etc
    were able to write Win2K drivers that simply add their cameras
    as a removeable drive while Canon insists on making people
    load cruddy software such as ZoomBrowser to gain access to
    their cameras.

    Rick
     
    Rick, Apr 17, 2004
    #4
  5. Rick

    Rick Guest

    USB 2.0 is backward compatible with 1.1 devices, or at
    least it's supposed to be. But I agree with your point.

    Rick
     
    Rick, Apr 17, 2004
    #5
  6. Rick

    T K P Guest

    Actually ZoomBrowser and all that crap are optional. You can install only a
    driver and see your Canon just as a removable drive or use Photoshop to get
    pictures from your camera. I use this method on my corporate laptop since we
    are not suppose to install anything on those. :)
    Good luck,
    - Tommi

    PS: Some data: tested on Win 2k pro and Win XP pro with Canon EOS-10D
     
    T K P, Apr 17, 2004
    #6
  7. Rick

    Rick Guest

    Not under Windows 2000 you can't. You're thinking of either
    WinXP or WinME.

    Rick
     
    Rick, Apr 17, 2004
    #7
  8. Agreed. The S1 works fine on a USB2 port but only at USB1 speed, the
    limiting factor is the S1's USB1 design.
     
    AngryofMayfair, Apr 18, 2004
    #8
  9. Rick

    Rick Guest

    No it doesn't, at least with our ADS Tech USB2.0 card, as
    I explained in the original post. The S1 isn't recognized at all.

    Which USB 2.0 card (and/or controller) are you using?

    Rick
     
    Rick, Apr 18, 2004
    #9
  10. Rick

    Rick Guest

    Update: We enabled one of the two USB Root Hubs for the
    onboard USB 1.1 controller (the onboard controller itself is
    still disabled), and now the S1 is seen on the USB 2.0 card.

    Strange, but at least it works.

    Rick
     
    Rick, Apr 18, 2004
    #10
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.