Canon Powershot S80 can no longer read 2gb SD after using 4gb SD

Discussion in 'Digital Photography' started by charlie.eng, Nov 29, 2006.

  1. charlie.eng

    charlie.eng Guest

    In reference to the use of a Canon Powershot S80:

    Has anyone see a problem of not being able to read or write to a
    smaller SD card after using a bigger one? I just bought a 4gb RiData
    SD card and used it for a week while on vacation, photos and movie
    clips were fine, but when I ran out of room I switched over to the
    smaller previous used 2Gb SD (SanDisk) and the camera report "no memory
    card".

    Thanks in advance for any replies,
    Charlie
     
    charlie.eng, Nov 29, 2006
    #1
    1. Advertisements

  2. charlie.eng

    Bob Williams Guest

    That is a weird one Charlie.
    Perhaps it is just coincidence.
    Try another SD card to see if it too, cannot be read.
    Does the 2GB card work in a card reader?
    Bob Williams
     
    Bob Williams, Nov 29, 2006
    #2
    1. Advertisements

  3. charlie.eng

    tomm42 Guest

    have you tried to format the card in the camera? Do you have access to
    a PC (if you are still on vacation) that can format the Sandisk card,
    then format it in the camera.

    Good Luck

    Tom
     
    tomm42, Nov 29, 2006
    #3
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.