Canon 20D + 580EX is consistently 2 stop underexposed

Discussion in 'Digital Photography' started by chris, Jan 23, 2005.

  1. chris

    chris Guest

    I set the flash to FEC +2 and everything is getting close to optimal.
    What's the deal? It's abviously Canon does know about it because it's
    been the same since 300D day and possibly eariler. What is the logic
    behind this phenomenon?
     
    chris, Jan 23, 2005
    #1
    1. Advertisements

  2. chris

    Drifter Guest

    If it's consistent then why worry? I have a 10D that runs 1/2 stop
    over but it's so regular about it I just automatically set the
    compensation and don't worry about it.


    Drifter
    "I've been here, I've been there..."
     
    Drifter, Jan 23, 2005
    #2
    1. Advertisements

  3. chris

    JPS Guest

    In message <09EId.7782$>,
    Maybe it's the result of a lot of complaints about blown JPEG
    highlights?
    --
     
    JPS, Jan 23, 2005
    #3
  4. chris

    JPS Guest

    In message <>,
    Because you no longer have room to do a +2 compensation, because it is
    already at +2.

    It is amazing that they don't include global offset preferences in a
    digital camera, which is trivial to implement.


    --
     
    JPS, Jan 23, 2005
    #4
  5. chris

    Drifter Guest

    Yes, good point.

    Drifter
    "I've been here, I've been there..."
     
    Drifter, Jan 23, 2005
    #5
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.