Cannot See Shared Folders on Network

Discussion in 'Wireless Networking' started by Dave McCreath, Jun 18, 2006.

  1. Hi

    I've looked around and found several people with the same problem but to
    date no solution. I have 2 PCs and a laptop, all on the same network. My
    PC can see the other two and all their shared files, however, they can both
    see my PC when you try to map a network drive but cannot see any of my
    shared folders. I've checked permissions, they are all OK, Simple File
    Sharing is turned on. I've tried booting into SAFE mode (with networking)
    and not enabling Norton, same problem. Windows Firewall is off (on all
    machines). I've obviously got something checked somewhere that is denying
    the other PCs access to my files. Laptop and other PC can see and share
    each other's folders. All PCs are XP Pro Sp2.

    Any advice gratefully welcomed.

    Dave
     
    Dave McCreath, Jun 18, 2006
    #1
    1. Advertisements

  2. Dave McCreath

    Malke Guest

    You didn't say in what directories the files are located. Disable Simple
    Sharing, make sure the folders' Permissions are set to Everyone, and
    create identical user accounts/passwords on each machine. Do not
    disable your firewall. If you are using a third-party firewall,
    configure it to allow lan traffic as trusted.

    Now try and let us know if you can see the files.

    Malke
     
    Malke, Jun 18, 2006
    #2
    1. Advertisements

  3. Dave McCreath

    Guest Guest

    Dave:

    I got things working stable on my networks now, but it wasn't always like
    that, and I had cases of one PC seeing the others in the network, and then
    some of the others does not see it, or the others.

    Read up on the problem, and here's what worked for me:

    - Sometimes it's there, but doesn't show up, and since I need to work on it,
    I go to "network places", top item, "add a network place" by browsing.
    Something like mapping, but makes it show up on "network places".

    -Check the settings. In Control Panel", "Network Connections", right click
    on connection, then"properties", then TCP/IP, then "Properties" again, and
    "Advanced" within it. I made sure its got "NetBios over TCP/IP" set. This is
    how each PC tells the others. Read up on the other settings and know what
    they mean and can do here.

    - Use DOS based command (open the DOS window) called NBTSTAT that you can
    study by "NBTSTAT /?" and its associated switches. I'm not going to pretend I
    know all of what you find on there, but it can show you not only the "IP
    addresses", but the names of each PC identifying itself to all the others in
    the system. Each PC when set up right broadcasts its name, and IP address to
    all others within the network and is shown here. If its not listed, you'll
    have a problem. This is additon the the "Ipconfigure" command to check things
    out in each unit.

    - Assumiing all is done right, you might have to wait maybe 20 to 30 minutes
    sometimes for all of the names to show up on all the machines. It's like
    everyone setting down in class in the morning and it takes time to take
    attendance.

    When things went "stable" on me, I found that I got each location coming up
    twice in "Network places" once because I manually added it in, and the other
    time when the system works itself up to putting it there. Because of this,
    when I add it in myself, I call it something a little different (put an X in
    front?) so when I "delete" a duplicate name, I'm not deleting the one that
    the system puts in.

    But better having it come up twice than "not at all".
     
    Guest, Jun 18, 2006
    #3
  4. Malke

    Disabled Simple File Sharing and set up similar accounts and passwords
    across all three machines, checked permissions, all OK. But still cannot
    see any of my shared folders on the other two machines. The folder in
    question is a D: drive, an additional HD that I use for Music et al.

    Firewall is configured the same on each of the three machines (other two can
    see each others shared directories/folders fine).

    Tried to manually connect by setting up a New Network Place in My Network
    Places, again, failed.

    Dave
     
    Dave McCreath, Jun 18, 2006
    #4
  5. Dave McCreath

    Malke Guest

    Do you have the beta IE7 installed on any of the machines? IIRC, there
    was some issue with folders not being seen in that case. If you do have
    this situation, then do a Google Groups Advanced Search for the issue
    in the IE7 beta newsgroup:

    microsoft.public.internetexplorer.general

    If this isn't your case, then check the Permissions on the shares. Add
    "Everyone" with full permissions if it isn't there already.

    Malke
     
    Malke, Jun 18, 2006
    #5
  6. Malke

    Thanks for the info, I did try to install IE7 Beta about (coincidently about
    the same time I noticed this fault). Look in the newsgroup and the best I
    could find to remedy the issue was to use system restore to roll-back to a
    point in time before the Beta install. I've done that - still the same
    problem.

    All permissions are set for everyone.

    Dave
     
    Dave McCreath, Jun 18, 2006
    #6
  7. Dave McCreath

    Malke Guest

    Then I suggest that you make a new post with all pertinent details in
    the IE7 beta newsgroup. I don't use beta software on production
    machines so don't have any experience with IE7 in XP. I'm sorry, but I
    wouldn't know what damage IE7 does to sharing.

    You could try unsharing everything and then setting up your network
    anew.

    Good luck,

    Malke
     
    Malke, Jun 18, 2006
    #7
  8. Malke

    Thanks for your time, I'll have a dig around and see if I can find
    anything else out .

    Dave
     
    dave.mccreath, Jun 18, 2006
    #8
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.