Cannot see one of my laptop in Workgroup Computers

Discussion in 'Wireless Networking' started by Mike, Aug 14, 2006.

  1. Mike

    Mike Guest

    I have the following home network configuration :

    a.. a Netgear wireless router
    b.. a desktop connected to the router via an Ethernet cable
    c.. two laptops connected to the router via wireless cards
    Internet works fine on all of them, but :

    first laptop sees the desktop but not the second laptop and viceversa ( when I click on "view workgroup computers" ). In other words, the second laptop is not recognized.

    the second laptop sees only the shared folder of the first one, but not the one on the desktop.

    Pinging the second laptop gives a positive result, in fact both the desktop and first laptop can see the shared folder of the second laptop, when clicking "my network places".

    What's going on ? What shall I do ?? I suspect this is due to the fact that the desktop is hardwired to to the router, whereas the laptops are connected wirelessly. Also, if I run the command "ipconfig /all", the node type is listed as "unknown" on the desktop and 1st laptop, "mixed" on 2nd laptop.

    Please help me, this issue is getting on my nerves. Thanks !!

    Mike
     
    Mike, Aug 14, 2006
    #1
    1. Advertisements

  2. Mike

    Malke Guest

    No, it doesn't have anything to do with that some computers connect
    wirelessly and some don't. The Node Type is also fine to be "unknown". You
    didn't mention the operating systems and Service Pack levels if XP, so here
    is some general information:

    Check your firewalls. Run the Network Setup Wizard on all computers, making
    sure to enable File & Printer Sharing, and reboot. The only "gotcha" is
    that this will turn on the XPSP2 Windows Firewall. If you aren't running a
    third-party firewall or have an antivirus with "Internet Worm
    Protection" (like Norton 2005/06) which acts as a firewall, then you're
    fine. If you have third-party firewall software, configure it to allow the
    Local Area Network traffic as trusted. I usually do this with my firewalls
    with an IP range. Ex. would be 192.168.1.0-192.168.1.254. Obviously you
    would substitute your correct subnet.

    If one or more of the computers is XP Pro:

    a. If you need Pro's ability to set fine-grained permissions, turn off
    Simple File Sharing (Folder Options>View tab) and create identical user
    accounts/passwords on all computers.

    b. If you don't care about using Pro's advanced features, leave the Simple
    File Sharing enabled.

    Simple File Sharing means that Guest (network) is enabled. This means that
    anyone without a user account on the target system can use its resources.
    This is a security hole but only you can decide if it matters in your
    situation.

    Then create shares as desired. XP Home does not permit sharing of users'
    home directories (My Documents) or Program Files, but you can share folders
    inside those directories. A better choice is to simply use the Shared
    Documents folder.

    If that doesn't work for you, here is an excellent network troubleshooter by
    MVP Hans-Georg Michna. Take the time to go through it and it will usually
    pinpoint the problem area(s) - http://winhlp.com/wxnet.htm

    Malke
     
    Malke, Aug 14, 2006
    #2
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.