Cannot connect to router (DI-524)

Discussion in 'Wireless Networking' started by The Alchemist, May 25, 2006.

  1. Hello all,

    I have a very weird problem when trying to connect to the internet
    through my D-LINK DI-524 router (Revision D).

    The internet connection at my place is provided by the university
    through their DSL modem. I configured my DI-524 router so that I can
    also have wireless in the house. It was working fine until last night
    when all of a sudden my computer indicated that the network connection
    was lost. Thereafter:

    1. The router had ALL (even on unused ports) its lights on but not
    blinking. So I figured may be it has hung so switched it off and then
    back on. But the problem persisted.
    2. Connected my computer directly through the university modem; the
    internet works.
    3. Reset my router and things should be back to normal, right?
    4. No. In fact now not only am I unable to connect to the internet via
    the router but I cannot even locate my router anymore (the generic gives me the message "the page cannot be
    5. I tried pinging the IP address but to no effect.
    6. The TCP/IP settings on my computer are currently set to be DHCP
    enabled. Should I switch to static? If so, then what should be the
    Gateway address? Will it be the one that the ISP uses?
    7. I tried running the setup wizard (the cd that came wtih the router)
    but when it checks for the network adapter on the current computer it
    cannot locate anything whereas the LAN connection light is blinking on
    the DSL modem and also on my computer's ethernet port.

    What am I doing wrong? Has my DI-524 died on me? What could have caused
    a response such as this? I have, in the past, used the same DI-524
    (dont remember the revision number) and it worked like it should
    without any problems. Basically I am trying to say that I dont think
    that DI-524 sucks. But may be I am wrong?

    Thanks in advance.

    The Alchemist, May 25, 2006
    1. Advertisements

  2. Hi

    As a first step disconnect the Router from the University connection.

    Look at the Router's manual and find how to Hardware reset the Router.
    Reconfigure the Router with one computer that is attached to it by a Wire.
    When it works with a Wire, configure the Wireless.

    If the above is successful you are ready to reconnect the Internet.

    However, you should check with the IT whether Router is allowed, and or
    supported on the University Network.

    Jack (MVP-Networking).
    Jack \(MVP-Networking\)., May 25, 2006
    1. Advertisements

  3. The Alchemist

    jimbo Guest

    I usually try this procedure when things just won't work.

    Power everything off. Wait about 60 sec, then power up the DSL modem.
    Wait about 60 sec, then power up the router. Wait about 60 sec, then
    power up the PC. You might want to connect the PC hard wire to the
    router for this procedure. And you might want to do a hardware reset
    of the router to factory defaults before you do this procedure. D-link
    routers usually have a button that you depress for several seconds
    while power is on to do a hardware reset. D-link factory defaults will
    usually work for DSL or Cable modems.

    When you use the router, your gateway is the router's LAN IP address,
    in your case, And you should leave the router set for DHCP.

    If you still can't connect to the router or the Internet, you may have
    a router problem. I thought routers would last almost forever, but I
    just had a D-Link router die.

    Good luck, jimbo
    jimbo, May 25, 2006
  4. Thank you for your inputs. Some clarifications:

    1. My computer (its a desktop) is connected to the router via a wire
    and am not trying to access it wirelessly. It has Win2K Pro as its OS.
    2. The university does allow connecting a router so that shouldnt be
    the case.
    3. I tried moving the entire setup to another port in the house. So now
    its a new port, new computer (its a laptop, running WinXP) and the rest
    is just the same. And miraculously it connects to the internet AND I
    can also access my router now. I guess this would mean that the router
    has not died on me. I perhaps need to update my Win2K (?)
    4. I will get back to you with the ipconfig/all result. I remember it
    giving me 4 lines of output and the same error message in all. But it
    was certainly not to the effect that "destination host unreachable" or
    "cannot be found"


    The Alchemist, May 25, 2006
  5. The Alchemist


    Most universities have static ip settings that you can manually setup in
    your router. But like you said , they don't want routers installed on there
    network for obvious reasons..

    MHPNW STAFF, May 25, 2006
  6. Thank you all for your inputs. I thought I will update with what
    exactly the messages are when I try to ping the router and what the
    ipconfig/all results are ... but somehow everything is back to working


    The Alchemist, May 26, 2006
  7. The Alchemist

    RalfG Guest

    As an FYI, I had almost exactly the same symptom happen one time. It turned
    out to be a firewall issue. The firewall determined that some communication
    between the router and computer was actually an attack so it put the router
    IP into a temporary Blocked address list. After the Block time period
    expired the router was accessible again. This all despite the router and LAN
    IPs being listed in the firewall's the safe or local zone. The firewall had
    the potential to Block any LAN IP permanently as well.
    RalfG, May 26, 2006
  8. The Alchemist


    Mar 11, 2008
    Likes Received:
    DI 524 Default factory reset.

    THIS IS IN NO DOCUMENTATION. Note the only real way to truely reset the factory settings on this machine is to press and hold the reset button for 10 seconds during power up...(as you are plugging in the device.) The other reset as suggested in the manual of just a 10 sec press of the reset will not reset the password to the default or change any IP settings. NOTE. Have a bin copy of the latest firmware ready as it will ask you for this at first login to the default
    wertthey, Mar 11, 2008
  9. The Alchemist


    Apr 3, 2008
    Likes Received:
    D-link status light not on but other lights work

    Turned out, the problem was the power supply, believe it or not.

    Multiple attempts to hard-reset the router (DI-524) didn't work.

    Eventually tried a different wall-wart power supply and everything works fine!

    teddyc1, Apr 3, 2008
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.