Cannot Access NAS Share Folders

Discussion in 'Windows 64bit' started by George Ioakimedes, Dec 6, 2008.

  1. I have a newly built WinXP 64-bit machine on my network. The network has 2
    Buffalo Terastation NAS. I can see the shares on the NAS' but if I try to
    view the contents I just get an hourglass and after ~2 minutes a message
    comes up that I don't have permission.

    There are several other PCs on the network that can access the NAS'. I tried
    turning off ESET antivirus as well as Windows firewall. I've tried accessing
    and mapping the drive shares using both the names and the IP addresses
    without any luck.

    The NAS also have a web interface but I am unable to access that either so
    I'm thinking there is some default security setting when you first install
    WinXP 64-bit that I need to change but I can't seem to find anything. I've
    looked in the event viewer and no errors or warning have been posted to give
    me any clues.

    I can see other PCs and shares as well as access the other PC's shares so
    this is strictly an issue where I cannot access the NAS drives.

    I hope someone has an answer because tech support at Buffalo couldn't help me!

    Thanks in advance,
    George
     
    George Ioakimedes, Dec 6, 2008
    #1
    1. Advertisements

  2. Is this by any chance an Nvidia chipset motherboard? If so, the following
    may apply:

    Unfortunately, the built in nVidia firewall product appears to install at
    least some portion of itself even if you've never chosen to install it. And
    this appears to interfere with 32-bit programs. The solution is to install
    the firewall program if it isn't already installed, and then uninstall it.

    If that isn't it, then start with basic troubleshooting. Can you ping? Also,
    you shouldn't turn off the firewall, but rather enable the appropriate rules
    to allow it to map drives and authenticate.
     
    Charlie Russel - MVP, Dec 6, 2008
    #2
    1. Advertisements

  3. Charlie:

    No it's a Gigabyte EX58-Extreme with a new iCore 7 CPU. I can see shares on
    other PCs in the network and can quickly map a drive to one of the shares on
    the other PCs.

    Yes, I can ping both NAS

    So I can ping each NAS and see what shares that they have but once I try to
    access a share on the NAS I'll get the hourglass for ~2 minutes and then the
    message

    "\\Ioakstorage\Documents is not accessible. You might not have permission to
    use this network resource. Contact the administrator of this server to find
    out if you have access permissions.

    The specified network name is no longer available."

    I also tried mapping the NAS share using the login name I use for the web
    interface that didn't work either.

    So it seems that somehow the OS sees the NAS differently than the other PCs
    on the network. It's odd that the web interface to the NAS doesn't work
    either since I can access the web interface of my router.

    I hope you've got another good suggestion on where I can look to open up
    whatever is locked down!
     
    George Ioakimedes, Dec 6, 2008
    #3
  4. I know of no reason why it shouldn't work, George. Therefore, I strongly
    suspect something amiss in the AV, or in the NAS itself. I do know that XP
    x64 is fussier about RPC packets than 32-bit XP. You might try enabling File
    and Printer Sharing in Windows Firewall. And verify that Client for
    Microsoft Networks is enabled in the TCP stack. Finally, I'd look at the
    network card itself. If it has TCP Offload enabled or large packets, or any
    other advanced features, I'd kill them.
    (HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters).

    DisableTaskOffload=1
    EnableTCPChimney=0
    EnableTCPA=0
    EnableRSS=0
     
    Charlie Russel - MVP, Dec 6, 2008
    #4
  5. Charlie:

    Looks like you got this one. Turns out if I disable Jumbo Frmaes I'm able to
    access the Nas's shares. One NAS is set to use 7k frames and the other is set
    for ~9k. I had the NIC set for 9k and everybody else on the network was able
    to negotiate fine but the 2 NAS just didn't want to play.

    Looks like now I need to try adjusting the frame sizes on everything to see
    if I can find a magic setting that everybody will like. Any helpful ideas?

    Thanks,
    George
     
    George Ioakimedes, Dec 6, 2008
    #5
  6. Ah, Jumbo frames. Will get you every time. Vista/2008 likes them. XP/2003
    does not. And the 64-bit version of XP/2003 definitely does not. Go back to
    the defaults, whatever that is. (I think it's 4k, but I could be wrong. It's
    not anything I ever tinker with!)
     
    Charlie Russel - MVP, Dec 6, 2008
    #6
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.