C836 not booting after ROMMON upgrade

Discussion in 'Cisco' started by Uli Link, Apr 17, 2005.

  1. Uli Link

    Uli Link Guest

    After the Router rebooted it now hangs after ROMMON version message.
    The hardware info doesn't appear anymore.

    Here's the capture of the terminal console session. I'm using ZOC.

    Last successful boot:

    System Bootstrap, Version 12.2(11r)YV, RELEASE SOFTWARE (fc1)
    TAC Support: http://www.cisco.com/tac
    Copyright (c) 2002 by cisco Systems, Inc.
    C800/SOHO series (Board ID: 30-132) platform with 49152 Kbytes of main
    memory

    ....

    monitor: command "boot" aborted due to user interrupt
    rommon 1 >
    rommon 1 > dir flash:
    File size Checksum File name
    9833384 bytes (0x960ba8) 0x3893 c836-k9o3s8y6-mz.123-11.T5.bin
    rommon 2 > set
    PS1=rommon ! >
    RET_2_RUTC=0
    BSI=0
    RANDOM_NUM=336295625
    ROM_PERSISTENT_UTC=1014941299
    RET_2_RTS=
    RET_2_RCALTS=
    ?=0
    rommon 3 > tftpdnld


    Missing or illegal ip address for variable IP_ADDRESS
    Illegal IP address.


    usage: tftpdnld [-ur]
    Use this command for disaster recovery only to recover an image via TFTP.
    Monitor variables are used to set up parameters for the transfer.
    (Syntax: "VARIABLE_NAME=value" and use "set" to show current variables.)
    "ctrl-c" or "break" stops the transfer before flash erase begins.


    The following variables are REQUIRED to be set for tftpdnld:
    IP_ADDRESS: The IP address for this unit
    IP_SUBNET_MASK: The subnet mask for this unit
    DEFAULT_GATEWAY: The default gateway for this unit
    TFTP_SERVER: The IP address of the server to fetch from
    TFTP_FILE: The filename to fetch


    The following variables are OPTIONAL:
    TFTP_VERBOSE: Print setting. 0=quiet, 1=progress(default),
    2=verbose
    TFTP_RETRY_COUNT: Retry count for ARP and TFTP (default=7)
    TFTP_TIMEOUT: Overall timeout of operation in seconds
    (default=7200)
    TFTP_CHECKSUM: Perform checksum test on image, 0=no, 1=yes
    (default=1)


    Command line options:
    -r: do not write flash, load to DRAM only and launch image
    -u: upgrade the rommon, system will reboot once upgrade is complete
    rommon 4 > IP_ADDRESS=192.168.170.1
    rommon 5 > IP_SUBNET_MASK=255.255.255.0
    rommon 6 > DEFAULT_GATEWAY=192.168.170.1
    rommon 7 > TFTP_SERVER=192.168.170.101
    rommon 8 > TFTP_FILE=C820_RM_ALT.srec.122-11r.YV1
    rommon 9 > tftpdnld -u


    IP_ADDRESS: 192.168.170.1
    IP_SUBNET_MASK: 255.255.255.0
    DEFAULT_GATEWAY: 192.168.170.1
    TFTP_SERVER: 192.168.170.101
    TFTP_FILE: C820_RM_ALT.srec.122-11r.YV1...
    ARP: address resolution for 192.168.170.101 timed out.
    ARP failed with failure code 1. TFTP transfer aborted.

    TFTP: Operation terminated prematurely.
    rommon 10 > TFTP_SERVER=192.168.170.100
    rommon 11 > tftpdnld -u


    IP_ADDRESS: 192.168.170.1
    IP_SUBNET_MASK: 255.255.255.0
    DEFAULT_GATEWAY: 192.168.170.1
    TFTP_SERVER: 192.168.170.100
    TFTP_FILE: C820_RM_ALT.srec.122-11r.YV1
    Receiving C820_RM_ALT.srec.122-11r.YV1 from 192.168.170.100
    !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
    File reception completed.
    Copying file C820_RM_ALT.srec.122-11r.YV1 to flash.
    Erasing flash ..
    Programming flash ..
    Rebooting.

    System Bootstrap, Version 12.2(11r)YV1, RELEASE SOFTWARE (fc1)
    Technical Support: http://www.cisco.com/techsupport
    Copyright (c) 2004 by cisco Systems, Inc.
     
    Uli Link, Apr 17, 2005
    #1
    1. Advertisements

  2. Uli Link

    thrill5 Guest

    The image is on the flash. At the rommon prompt, type

    boot

    If it boots, make sure the config-register is 0x2102.

    Scott
     
    thrill5, Apr 18, 2005
    #2
    1. Advertisements

  3. Uli Link

    Uli Link Guest

    There is a valid image in flash. At least I can say, that before the
    ROMMON update there was a image and a working config and I haven't
    erased the flash.

    I would type "boot" at the rommon prompt, if I could reach that prompt
    by sending a telnet Break to the device.

    I don't know how to alter the conf register, if *no* rommon or IOS exec
    prompt.

    The LED of the Ethernet port went on and off according to the status of
    the ethernet line.

    Console cable and terminal emulator settings triple checked and proved
    working.

    The ROMMON version banner appears 1 or 2 seconds after power on and
    thats the end of discussion with this piece of hardware.

    The line (which usually appears later)is the first missing sign.
    "C800/SOHO series (Board ID: 30-132) platform with 49152 Kbytes of main
    memory"
     
    Uli Link, Apr 18, 2005
    #3
  4. Uli Link

    Brad Guest

    Try booting with the old boot rom. If that works then I would say there
    is likely a problem with the new boot rom. Buy another one, they're
    pretty cheap. I'm sure you know this but it's worth mentioning, the
    boot roms are platform dependent.

    If it still doesn't boot then I would try re-installing your
    backed-upped copy of the IOS to flash to make sure it is a clean
    version and not corrupted. It looks like from the output that you are
    getting a rommon prompt.

    After that if it still doesn't boot then it's time to hope you have a
    smartnet contract.

    Good luck.
     
    Brad, Apr 19, 2005
    #4
  5. Uli Link

    XTREM

    Joined:
    Aug 11, 2009
    Messages:
    1
    Likes Received:
    0
    it's so silly

    its a silly thing , i had the same problem , everything was ok
    your settings are ok , but the romon is case sensitive so u have to type the setting in capitale letters as follow :

    Rommon 1 "IP_ADDRESS=192.168.1.1
    Rommon 2 "IP_SUBNET_MASK=255.255.255.0
    Rommon 3 "DEFAULT_GATEWAY=192.168.1.1
    Rommon 4 "TFTP_SERVER=192.168.1.11
    Rommon 5 "TFTP_FILE=IOS.bin
    Rommon 6 "tftpdnld

    then wait 10 min for the ios to be downloaded from you tftp server.
     
    XTREM, Aug 11, 2009
    #5
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.