BulletProof FTP Server Help Needed

Discussion in 'Computer Support' started by Yucko the Clown, Feb 5, 2004.

  1. I'm new at setting up an FTP server and I was able to connect via my own
    ftp client no no one else can. What's confusing to me is that there my LAN
    IP and WAN IP. When I check my real IP address its the WAN IP. Yet with the
    FTP server I see the LAN IP.I have use IP passive mode checked along with
    fixed IP using the WAN IP. I'm behind a Speedstream router that has a
    firewall in it. Is anyone out there experienced in this? All I'm trying to
    do is set it up so my brother's computer can connect to mine. Can someone
    recommend some settings changes that might work? Any help would be greatly
    appreciated. Thanks.
     
    Yucko the Clown, Feb 5, 2004
    #1
    1. Advertisements

  2. Yucko the Clown

    °Mike° Guest

    Before you set up your own FTP server, for whatever reason, be
    sure you know what you are doing *first* -- you are in danger
    of leaving your system wide open. Read up, read up some more,
    and then read up again.
     
    °Mike°, Feb 5, 2004
    #2
    1. Advertisements

  3. Yucko the Clown

    Dan Shea Guest

    Hi Yucko:

    I'm guessing you're setting this FTP server up on your home LAN,
    behind a firewall? If so, the computer it's on is going to have a
    private LAN address -- end of story.

    The WAN IP address is the external address of your router (whatever
    address you get from your ISP). When you say you check your "real" IP
    address, how did you do that? At one of those "what's my address"
    sites? Those will just tell you what the external address of your
    router is.

    In other words, everything is as it should be. What you need to do is
    configure your firewall to forward all the FTP traffic from the
    internet to the FTP server. Typically, that's port 21. Now, whenever
    FTP traffic tries to hit your WAN address, it will be forwarded to the
    private address of the FTP server.

    I would strongly suggest you read up on some network security before
    exposing a computer to public internet traffic in this way.

    Cheers,
    dan


    I have use IP passive mode checked along with
     
    Dan Shea, Feb 5, 2004
    #3
  4. Yucko the Clown

    Unk Guest

    You need to allow TWO ports to pass through the firewall.
    port 20, FTP-data
    port 21, FTP-control

    You can connect because you are on the LAN side. (Inside the firewall)
    No one else can connect because the firewall blocks the 2 ports on the WAN
    side. (Public side)

    Read the manual on how to open the 2 ports.
     
    Unk, Feb 5, 2004
    #4
  5. Yucko the Clown

    Dan Shea Guest

    Good call.

    Cheers,
    dan
     
    Dan Shea, Feb 5, 2004
    #5
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.