[bug report] Javascript applet doesn't work on Mozilla 1.5 (Windows Version) !

Discussion in 'Firefox' started by Penang, Oct 18, 2003.

  1. Penang

    Penang Guest

    [bug report] Javascript applet doesn't work on Mozilla 1.5 (Windows
    Version) !

    Just downloaded the Mozilla 1.5 (Windows Version), and just found out
    that there is at least one java applet that doesn't work on it !

    Machine: Intel PIII 1.3 GHz

    OS: MS Windows ME

    RAM: 512 MB

    I went to download some Chinese fonts, and when I reached this page
    http://www.twinbook.com/eBook/Service/font_download.asp - you have to
    first go to this page
    http://www.twinbook.com/eBook/Service/FontUser1.asp to register, blah
    blah blah, before you reach the above download page - there are two
    fonts available for download. The page uses javascript.

    When I clicked on the javascipt nothing happened.

    Clicked again, and still nothing happened.

    I powered up the Opera 7.20 browser, and went to the same page
    (http://www.twinbook.com/eBook/Service/FontUser1.asp, then register,
    then blah, blah blah to the download page) and the javascript applet
    worked on Opera !

    Now I don't know if it's Mozilla 1.5 that doesn't do javascipt or if
    there's some configuration error on my machine.

    Can anybody help out, please ?

    Thank you !

    Also, if there are any other newsgroups, or online forum that I can
    post this report to the developers/gurus, please tell me.

    Thank you again !
     
    Penang, Oct 18, 2003
    #1
    1. Advertisements

  2. Penang

    Keith Bowes Guest

    Is it a problem with Java or JavaScript? If it's Java, make sure that
    you have the latest version of the Java Environment
    <http://www.java.com/> (go into the Help Menu and select "About
    Plug-ins" to see which version you have installed).

    If it's JavaScript, check the JavaScript console (in Tools -> Web
    Development -> JavaScript Console) and look for errors about
    document.all or document.layers not having properties. If you see
    those, contact the webmaster and point him to
    <http://www.mozilla.org/docs/web-developer/>.

    If it is indeed a bug in Mozilla (rather than an old version of Java or
    a webmaster's ignorance), report a bug formally:
    <http://bugzilla.mozilla.org/enter_bug.cgi?format=guided>.

    I hope this helped.
     
    Keith Bowes, Oct 18, 2003
    #2
    1. Advertisements

  3. Penang

    Penang Guest

    They are javascripts, and upon doing what you have described (in Tools
    ->Web Development -> JavaScript Console) what I got is "Error:
    Document forms is not a function".

    Funny thing is the Opera browser, version 7.20 execute them without
    error.

    And I have tried MS IE browser, version 5.1 and version 6.0, both of
    them execute the javascripts without error either.

    The javascripts only not working on the Mozilla browser, version 1.5.

    Dunno what's going on......




     
    Penang, Oct 20, 2003
    #3
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.