buffer overflow

Discussion in 'Cisco' started by Wojtek, Apr 2, 2005.

  1. Wojtek

    Wojtek Guest

    Hello, I have problem with boot tftp. I've tried to config my Cisco801 to
    boot from TFTP server, which is actually my winxp notebook with the
    SolarWinds TFTP server
    installed. When the router try get file from tftp server, it failed with
    error message of buffer overflow as follow:

    boot# list
    Status Size Dev Name
    ------ 48K flash TinyROM-1.4(1)
    8128K free 8192K total
    boot# boot tftp
    Accessing tftp://192.168.0.5/c800-y6-mw.121-9.bin
    TFTP initiated.
    Build [kellythw 9] -- Wed Jun 13 18:00:37 PDT 2001

    File name: c800-y6-mw

    RAM size: 0x0066e394 (6742932)

    Raw size: 0x0054e880 (5564544)

    Image size: 0x002d162c (2954796)

    |----------------+----------------+----------------+----------------|

    Error 7 at offset 24.
    boot tftp: failed (1 second), "buffer overflow"
    boot: failed, "buffer overflow"
    boot#

    Info from tftp server:

    2005-04-02 21:00 :Sending c800-y6-mw.121-9.bin to (192.168.0.1)
    2005-04-02 21:00 :Timeout error sending c800-y6-mw.121-9.bin from
    (192.168.0.1), 512 bytes

    Questions:

    Why will it happen ( I've tried to use another tftp servers - didn't help)?
    How can I config my router 801 ?

    Thanks
     
    Wojtek, Apr 2, 2005
    #1
    1. Advertisements

  2. With MS-Win, nothing can amaze me anymore.

    Ever tried with something else like an OS?

    Regards,

    Nicholas
     
    Nicholas Wheeler (Denver, Colarado, USA), Apr 3, 2005
    #2
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.