Block inbound ports 443 and 22 on a Cisco PIX 501

Discussion in 'Cisco' started by Bill56, Mar 26, 2012.

  1. Bill56

    Bill56

    Joined:
    Mar 26, 2012
    Messages:
    1
    Likes Received:
    0
    Hello:

    I believe inbound ports should be closed by default on the PIX. However I seem to have ports 22 and 443 open. Can someone give me the commands to close those 2 inbound ports? I use Cisco's VPN client to access the computer behind the router, so I don't believe these ports need to be open. I am failing PCI compliance because these ports are open. Thanks.

    Here is my config:

    PIX Version 6.3(4)
    interface ethernet0 auto
    interface ethernet1 100full
    nameif ethernet0 outside security0
    nameif ethernet1 inside security100
    enable password xxxxxxxxxxxxxxxxx encrypted
    passwd xxxxxxxxxxxxxx encrypted
    hostname pixfirewall
    domain-name ciscopix.com
    clock timezone EST -5
    clock summer-time EDT recurring
    fixup protocol dns maximum-length 512
    fixup protocol ftp 21
    fixup protocol h323 h225 1720
    fixup protocol h323 ras 1718-1719
    fixup protocol http 80
    fixup protocol rsh 514
    fixup protocol rtsp 554
    fixup protocol sip 5060
    fixup protocol sip udp 5060
    fixup protocol skinny 2000
    fixup protocol smtp 25
    fixup protocol sqlnet 1521
    fixup protocol tftp 69
    names
    name 70.200.20.0 XXXX
    name 71.240.240.236 XXXXXXX
    access-list inside_outbound_nat0_acl permit ip any 192.168.1.192 255.255.255.192
    access-list inside_outbound_nat0_acl permit ip 192.168.1.0 255.255.255.0 192.168.2.0 255.255.255.0
    access-list outside_cryptomap_dyn_20 permit ip any 192.168.1.192 255.255.255.192
    access-list penn_splitTunnelAcl permit ip 192.168.1.0 255.255.255.0 any
    access-list outside_cryptomap_20 permit ip 192.168.1.0 255.255.255.0 192.168.2.0 255.255.255.0
    access-list OUTSIDE-ACL-IN permit icmp any any echo
    access-list OUTSIDE-ACL-IN permit icmp any any echo-reply
    access-list OUTSIDE-ACL-IN permit icmp any any unreachable
    access-list OUTSIDE-ACL-IN permit icmp any any time-exceeded
    pager lines 24
    logging on
    logging buffered debugging
    logging history errors
    mtu outside 1500
    mtu inside 1500
    ip address outside 70.200.20.28 255.255.255.0
    ip address inside 192.168.1.1 255.255.255.0
    ip audit info action alarm
    ip audit attack action alarm
    ip local pool pool 192.168.1.201-192.168.1.254
    pdm location 192.168.2.0 255.255.255.0 outside
    pdm location 192.168.1.0 255.255.255.0 inside
    pdm location 24.62.100.0 255.255.252.0 outside
    pdm location 192.168.1.10 255.255.255.255 inside
    pdm location XXXX 255.255.255.255 outside
    pdm logging informational 100
    pdm history enable
    arp timeout 14400
    global (outside) 1 interface
    nat (inside) 0 access-list inside_outbound_nat0_acl
    nat (inside) 1 0.0.0.0 0.0.0.0 0 0
    access-group OUTSIDE-ACL-IN in interface outside
    route outside 0.0.0.0 0.0.0.0 70.200.20.1 1
    timeout xlate 0:05:00
    timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
    timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
    timeout uauth 0:05:00 absolute
    aaa-server TACACS+ protocol tacacs+
    aaa-server TACACS+ max-failed-attempts 3
    aaa-server TACACS+ deadtime 10
    aaa-server RADIUS protocol radius
    aaa-server RADIUS max-failed-attempts 3
    aaa-server RADIUS deadtime 10
    aaa-server LOCAL protocol local
    http server enable
    http 0.0.0.0 0.0.0.0 outside
    http 192.168.1.0 255.255.255.0 inside
    snmp-server host inside 192.168.1.10
    snmp-server location RWAR
    snmp-server contact NOBODY
    snmp-server community public
    snmp-server enable traps
    floodguard enable
    sysopt connection permit-ipsec
    crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
    crypto dynamic-map outside_dyn_map 20 match address outside_cryptomap_dyn_20
    crypto dynamic-map outside_dyn_map 20 set transform-set ESP-3DES-MD5
    crypto map outside_map 20 ipsec-isakmp
    crypto map outside_map 20 match address outside_cryptomap_20
    crypto map outside_map 20 set peer 603
    crypto map outside_map 20 set transform-set ESP-3DES-MD5
    crypto map outside_map 65535 ipsec-isakmp dynamic outside_dyn_map
    crypto map outside_map interface outside
    isakmp enable outside
    isakmp key XXXXX address XXXX3 netmask 255.255.255.255 no-xauth no-config-mode
    isakmp keepalive 15
    isakmp nat-traversal 20
    isakmp policy 20 authentication pre-share
    isakmp policy 20 encryption 3des
    isakmp policy 20 hash md5
    isakmp policy 20 group 2
    isakmp policy 20 lifetime 86400
    vpngroup XXX address-pool pool
    vpngroup XXX split-tunnel penn_splitTunnelAcl
    vpngroup XXX idle-time 1800
    vpngroup XXX password XXXXXXX
    telnet 0.0.0.0 0.0.0.0 outside
    telnet 192.168.1.0 255.255.255.0 inside
    telnet timeout 5
    ssh 0.0.0.0 0.0.0.0 outside
    ssh 24.62.100.0 255.255.252.0 outside
    ssh 192.168.1.0 255.255.255.0 inside
    ssh timeout 5
    management-access inside
    console timeout 0
    dhcpd address 192.168.1.101-192.168.1.200 inside
    dhcpd dns 151.197.0.38 199.45.32.38
    dhcpd lease 3600
    dhcpd ping_timeout 750
    dhcpd auto_config outside
    dhcpd enable inside
    terminal width 80
     
    Bill56, Mar 26, 2012
    #1
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.