Bios Rom checksum error

Discussion in 'Computer Information' started by William, May 14, 2008.

  1. William

    William Guest

    I've have had some trouble starting my computer after I had to unplug it
    because of an electrical storm but, after a few tries, was able to start
    it. This time I had not unpluged it only shut it down through windows. When
    I turned it on I got the Bios Rom checksum error and instructions to boot
    from floppy. I bought a new battery for rom but this did no good. I have
    WinXP installed. Made floppy startup disk from my other computer. Computer
    will read floppy and go to the A prompt but there are no more tools so this
    is as far as I can go. Computer will not boot from my CD or DVD drive. What
    advice can you give me, anyone. Thank you.
    William, May 14, 2008
    1. Advertisements

  2. William

    Baron Guest

    Possibly your PSU has been damaged, so I would at least try a new one.
    The BIOS checksum error usually means what it says ! This can often be
    as simple as going into it and re-detecting your drives and closing it.
    It is very unlikely to be anything to do with the battery.
    Baron, May 14, 2008
    1. Advertisements

  3. William

    William Guest

    Thanks Baron. Just so I understand and I hope I don't sound too dumb. PSU
    stands for power supply unit. Is this correct? Could just part of it be bad?
    I did have a Win98 startup disk with the cd driver on it but it could not
    detect any cd drives. Also it said it could not detect any FAT.
    William, May 14, 2008
  4. William

    Baron Guest

    More than likely !
    That could be just configuration error. Check the BIOS first.
    XP doesn't use FAT William's ;-)

    Unless you have specifically used a FAT file system, XP used NTFS.
    Baron, May 14, 2008
  5. William

    Paul Guest

    You don't say what kind of motherboard it is, but if you can boot a
    DOS floppy, then you may be able to run BIOS tools. For example, you
    could use a DOS BIOS tool in read-only mode, and make an archival copy
    of the current BIOS, and save it to the floppy. (The exceptions to
    this, are a few modern motherboards where the BIOS image is now
    larger than can be stored on a floppy.)

    In terms of things that will upset the BIOS checksum -

    1) Actual corruption of the BIOS. The BIOS executable code consists of two parts.
    The boot block. And the main BIOS. The boot block, as the name
    suggests, has limited booting ability. In the past, the boot block
    may have allowed a "blind" BIOS recovery, as there might not have been
    video output in that state. Perhaps your boot block works well enough,
    to actually support video. Or, another interpretation, is the BIOS
    main code actually ran. But if that were the case, the BIOS checksum would
    have to be good. The main code won't run, unless the checksum passes.
    So that implies you have an intact boot block, and perhaps you will be
    able to use a BIOS tool.

    2) It is possible for the BIOS settings, to actually upset the ability
    to read the main ROM code. For example, if I overclocked my old AMD
    motherboard, I could get reports of "bad checksum", followed by the
    computer prompting me to "insert motherboard CD". In some cases, following
    that instruction leads to disaster. Instead, the first thing to do,
    is use the "Clear CMOS" or "Clear RTC" jumper. That returns the BIOS
    settings, like some of the clock signals, to nominal safe values. After
    which, the BIOS main code may be readable. If, on the other hand, I
    inserted the motherboard CD, the board may attempt to flash the BIOS
    chip, when we know the clock to the BIOS chip is currently out of
    spec (which is why the checksum was bad).

    Note - when clearing the CMOS or RTC (whatever terminology your motherboard
    manual uses), be careful to remove all power from the computer. Unplug
    the computer before following the procedure. You can actually damage
    a diode on many boards, if you carry out clear CMOS, with power still

    If you use a BIOS tool, and make an archival copy of the BIOS, it will not
    be exactly the same as the original BIOS. The BIOS consists of the main
    code (invariant), DMI and ESCD (rewritable during POST or when using a DMI
    tool), and the boot block at the end of the BIOS. If doing a binary comparison
    or delta between the original BIOS image, and an archival copy, there will be
    small sections near the end of the BIOS that won't match. So it is a
    little difficult to determine whether the important parts of the BIOS match.

    I would start with clearing the CMOS/RTC first, and then see if the
    checksum error disappears. Removing the CMOS battery for a long period
    of time will do the same thing - the CMOS settings are stored in a
    small RAM (256 bytes) inside the Southbridge. When all power is
    removed from the computer, and the CMOS battery is removed, the
    256 byte memory will lose its contents. CMOS RAM is also protected by
    checksum bytes, and the BIOS should be able to detect that it
    needs to be re-initialized on the next POST. You can enter
    the BIOS, after clearing the CMOS settings, and set any custom
    settings you had before. For example, if you used to have a RAID
    array connected to the motherboard, you'd check that the disk
    interfaces were set to RAID mode. This is why it helps if you
    write down any custom settings, for occasions when the settings
    need to be restored.

    Flashing the BIOS, would be something I'd save for later. First
    try clearing the CMOS, and then POST back with whatever new
    symptoms you're seeing.

    And if you do flash the BIOS and brick the system (no POST),
    as long as the BIOS chip is in a socket, you can go to
    and buy a new BIOS chip. That can be installed in the sccket,
    to take the place of the old one. But that is only necessary, if
    the boot block is also wiped out.

    Paul, May 14, 2008
  6. William

    William Guest

    Hi Paul
    I unpluged my computer from wall outlet. I removed rom battery. Left it
    over night. This morning I put battery back in, pluged in computer and tried
    to turn it on. Nothing happened. After several tries computer came on lights
    came on cd and dvd drives. Computer light in front came on but no video.
    Pushed reset button. Video came on. Message on screen

    Award BootBlock Bios V1.0
    Copywrite (c) 2000, Award Software, Inc.
    Bios Rom checksum error
    Decting floppy drive A media
    Insert system Disk and press enter

    Put floppy startup disk in and pressed enter and nothing happened. Left
    startup floppy in and pressed reset and computer read floppy. A:\> prompt
    showed up. Like I said before there are no tools I can use on floppy. My
    mother board is a SYNTAX K7SV266AD. I have not changed the Power supply yet
    like Baron said. That is a little more trouble. What do you think I should
    do next?
    William, May 15, 2008
  7. William

    Baron Guest

    William Inscribed thus:
    Hi William,

    I don't think overnight would be long enough for the BIOS to forget its
    settings. There will be a jumper on the mainboard that you move to do
    this. Don't do this with the computer plugged in or powered. But do
    maintain an earth connection between you and the case while you move
    the jumper. Refer to your M/B manual if you are not sure.

    Leave the jumper in the discharge position for ten seconds. Then put
    the jumper back in its original place. Now you can turn the machine
    back on and go through the BIOS settings as required.
    Baron, May 15, 2008
  8. William

    William Guest

    Hi Baron
    Nothing changed. Everything came up the same. I even tried holding the
    Delete key down hoping to bring up the Bios utility. Could not do it. I
    already have another PSU. Do you think I could try it or do have another
    sugestion? I can already get to the A prompt. Can I use an autoexec.bat
    and/or a config.sys file to get to C: drive? If I can what parameters could
    I put in? Thanks.
    William, May 15, 2008
  9. William

    Baron Guest

    Hi William,
    I'm getting a bad feeling about this. An un-clearable "Bad Checksum" is
    not good. Particularly when the BIOS is able to see and let you use the
    floppy drive.

    You need either a W98 boot floppy or a bootable floppy with "fdisk" on

    Boot the machine from the floppy and a the prompt type "fdisk" without
    the quotes. If fdisk comes back with no hard drives found or similar
    message there are two possible reasons.
    1/ The IDE controller or the drives are dead,
    2/ The BIOS is shot and probably so is the mainboard.

    At this point I would be checking the hard disk/s and CD roms in another
    machine. Simply to rule out that one or more may have failed.

    Incidentally DOS cannot see NTFS formated partitions and you will not
    see a "C:" prompt.

    Report back with your findings.
    Baron, May 15, 2008
  10. William

    Paul Guest

    I found a picture of the motherboard here. It looks similar to "PCChips M811LU (V3.1)"

    And several references to the board, indicating that a number of companies
    shipped something similar.

    The trouble is, I don't like any of the options I've seen so far.
    I'd probably want to look for the motherboard CD, if the product
    came with one. Maybe there is a copy of the BIOS on there.

    Paul, May 15, 2008
  11. William

    w_tom Guest

    Notice how much work and so many posts. What has been
    accomplished? Nothing. With a meter, in but 5 seconds, you could
    have measured the BIOS battery voltage. If good, then CMOS was not
    corrupted - all that labor would have been avoided. Worse, we still
    do not know if battery voltage corrupted the CMOS because you fixed
    something (replaced the battery) before seeing a failure.

    Removing the battery for five minutes was much more than
    sufficient. You are seeing symptoms of a problem elsewhere and
    confusing those changes with BIOS battery.

    Paul suggested what you must do now - master reset the CMOS to
    defaults. Why? Because with all those changes, we have little idea
    what did and now does exist.

    Then move on to subsystems that must be confirmed before even
    looking at the BIOS - the many components of a power supply 'system'.
    Without numbers from that, then all those 'try this and try that'
    becomes more wasted labor.

    A two minute procedure (notice massive information from so little
    labor) was posted in "When your computer dies without warning....."
    starting 6 Feb 2007 in the newsgroup at:
    Connector chart to locate each color:

    In your case, most important information are numbers (voltage) on
    green and purple wire both before and when power switch is pressed.
    If those numbers are good, then numbers from any one orange, red, and
    yellow wire when computer should be working.

    To get the better informed to reply, you must provide useful
    information. That means numbers. So much labor avoided had battery
    voltage been measured (without even removing the battery - all numbers
    taken without removing or disconnecting anything). Stop trying to fix
    it. First learn what is bad (or good). Your replies will only be as
    useful as information provided - especially numbers.
    w_tom, May 15, 2008
  12. William

    Paul Guest

    There is no reason to reach for the multimeter yet. The system is
    coming up, but is stuck in the boot block. The symptoms indicate
    a damaged BIOS, and the question is, what to try reflashing with.
    The trick will be finding a good BIOS file to use.

    If the symptoms were different, such as crashing without getting
    anywhere, or signs the system tried to access a hard drive, then
    I might be more curious about power. But right now, it looks like
    a BIOS issue.

    Paul, May 16, 2008
  13. William

    William Guest

    Hi Paul
    I found a floppy I made when I got the board in 2004 that I put two
    files on. and Win9XME. I was using WinME when I bought the mother
    board. I marked the disk, Bios for Syntax Mother Board, but I am not sure
    what it is because it has been a while. I have the Syntax Mother Board CD
    and I think there is a utility on it to flash the Bios but when I looked on
    the CD I could not find the file.
    William, May 16, 2008
  14. William

    Paul Guest

    Actually, that is the file I saw mentioned in a download link. The problem
    is, the IP address is no longer valid. So that does look like a good file
    to use. A reverse lookup on the IP address, gives "",
    a clever misspelling of syntaxbrillian. But syntaxbrillian is doing other
    things now, and probably isn't interested in supporting older products.

    It could be, when you unzip that file, you'll find two files. A 256KB
    ..bin or .rom, and a flasher program ending in .exe . Make sure the file
    extension of the BIOS file, is proper for the flash tool. (Some tools
    are sensitive to the file extension used.)

    The DOS version of flasher is here, from the ECS site. This should be
    similar to whatever Syntax bundled with their product.

    This thread gives a syntax for flashing with the ECS award flasher.
    In your case, the /f flag would be kinda silly, as the main BIOS
    is damaged, and using the executable flashing code inside the BIOS
    chip would be a mistake. I don't think I'd use /f in this case.

    A:\awd865 a360719.bin /cc/cd/cp/f

    I found a picture of a DOS screen, so you can decode what the various
    command line switches do.

    If you look in the awd865.exe file with a hex editor, you can see what
    BIOS chips the flasher program supports. This is an example of one of the

    "SST 49LF040B"

    The BIOS chip on your board, could be sitting in a socket in the lower
    left hand corner of the picture below. Removing the paper label, would
    show the BIOS chip part number, and you'd want to see your BIOS chip listed
    inside the flasher executable.

    As long as you have the BIOS file in your hand, you can go to
    and buy a replacement BIOS chip. You can do that, if you run into problems
    doing the BIOS recovery by reflashing. You tell them what part number of
    chip you want, provide them with a BIOS file, and they send a BIOS chip with
    that code flashed into it.

    Good luck,
    Paul, May 16, 2008
  15. William

    w_tom Guest

    Getting Bios to start but then system crashing when reading a
    peripheral: also a symptom of a defective power supply. Sometimes,
    BIOS does not start or intermittently declares a checksum error - same
    power symptom. Power 'system' can make all computer parts appear
    intermittent. That's what was posted here. Sometimes even BIOS would
    not execute.

    A problem that takes less than 2 minutes to identify or exonerate.
    So much information using so little time. And, the answer means
    progress. After so many posts, still, nothing has been accomplished.
    Not one item is on a list of 'definitively something' - nothing has
    been accomplished.

    Was battery low? That would not change a BIOS. That may corrupt
    CMOS and data time clock. A CMOS reset would eliminate that failure.
    If problem was due to CMOS corruption, then computer would now boot.
    It does not. If something was accomplished, then at minimum, a suspect
    has been identified. Even a suspect has not been identified – nothing
    yet accomplished.
    w_tom, May 16, 2008
  16. William

    Baron Guest

    w_tom Inscribed thus:
    w_Tom ! If you have nothing useful to say then shut up !

    William. w_tom is a water muddier ! Some of what he says would be fine
    if it was relevant in this case !
    Baron, May 16, 2008
  17. William

    Baron Guest

    w_tom Inscribed thus:
    w_tom doesn't bother to read previous posts either !
    Baron, May 16, 2008
  18. William

    William Guest

    Thanks Baron for that feed back I didn't want to say
    anything but I was wondering about w_toms' post. Thanks also for your help
    and Pauls'. Have a good day.
    I'll be back in touch.
    William, May 17, 2008
  19. William

    William Guest

    The Floppy disk I had that I marked BIOS for Syntax mother board did had
    AWD822A.exe and a SP3917.bin file on it when I unziped it. I executed the
    flash utility and enter file name sp3917.bin. Flash utility seemed to accept
    the file. Screen flashed and then was blank. The floppy drive light was
    still on so I waited about 3 minutes but still nothing was happening so I
    pushed reset. Screen came on with same checksum message. How long does it
    take for the bios to flash?
    William, May 17, 2008
  20. William

    w_tom Guest

    And what was the post that I did not read? Where is this
    w_tom, May 18, 2008
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.