BGP issue. Please help

Discussion in 'Cisco' started by phillip, Dec 12, 2004.

  1. phillip

    phillip Guest

    This is probably a simple issue but I canot figure it out?

    Router1 and Router3 are IBGP neighbors.
    Router1 and Router2 are EBGP neighbors.
    Router2 can get to BGP routee advertised by Router3.
    Router3 cannot get to BGP routes advertised by Router2.

    Router3<--IBGP -->Router1<---EBGP--->Router2

    Router3
    Router1
    AS 65001

    Router2
    AS 65002
    --------------------

    ROUTER2
    router bgp 65002
    no synchronization
    bgp log-neighbor-changes
    network 172.31.1.0 mask 255.255.255.0
    neighbor 1.1.1.1 remote-as 65001
    neighbor 1.1.1.1 ebgp-multihop 2
    neighbor 1.1.1.1 update-source Loopback1

    ip route 1.1.1.1 255.255.255.255 10.1.1.1
    ----------------------

    ROUTER1
    router bgp 65001
    no synchronization
    bgp log-neighbor-changes
    network 192.168.11.0
    neighbor 2.2.2.2 remote-as 65002
    neighbor 2.2.2.2 ebgp-multihop 2
    neighbor 2.2.2.2 update-source Loopback1
    neighbor 192.168.1.3 remote-as 65001
    neighbor 192.168.1.3 next-hop-self

    ip route 2.2.2.2 255.255.255.255 10.1.1.2

    router eigrp 1
    network 1.1.1.0 0.0.0.255
    network 10.1.1.0 0.0.0.255
    network 192.168.1.0
    network 192.168.11.0
    no auto-summary
    -------------------------------

    ROUTER3
    router bgp 65001
    no synchronization
    bgp log-neighbor-changes
    network 192.168.33.0
    neighbor 192.168.1.1 remote-as 6500

    router eigrp 1
    network 192.168.1.0
    network 192.168.33.0
    no auto-summary
    no eigrp log-neighbor-changes

    ROUTER3
    Router3#sh ip route
    1.0.0.0/24 is subnetted, 1 subnets
    D 1.1.1.0 [90/2297856] via 192.168.1.1, 00:06:01, Serial0
    172.31.0.0/24 is subnetted, 1 subnets
    B 172.31.1.0 [200/0] via 192.168.1.1, 00:14:54
    D 192.168.11.0/24 [90/2297856] via 192.168.1.1, 00:07:12, Serial0
    10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
    D 10.1.1.0/24 [90/2681856] via 192.168.1.1, 00:05:02, Serial0
    C 10.4.1.3/32 is directly connected, Loopback0
    C 192.168.1.0/24 is directly connected, Serial0
    C 192.168.33.0/24 is directly connected, Ethernet0

    Router3#ping 172.31.1.1

    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 172.31.1.1, timeout is 2 seconds:
    ......
    Success rate is 0 percent (0/5)

    -----------------------------------

    ROUTER2
    Router2#show ip route

    1.0.0.0/32 is subnetted, 1 subnets
    S 1.1.1.1 [1/0] via 10.1.1.1
    2.0.0.0/24 is subnetted, 1 subnets
    C 2.2.2.0 is directly connected, Loopback1
    172.31.0.0/24 is subnetted, 1 subnets
    C 172.31.1.0 is directly connected, Loopback0
    B 192.168.11.0/24 [20/0] via 1.1.1.1, 00:12:10
    10.0.0.0/24 is subnetted, 1 subnets
    C 10.1.1.0 is directly connected, Serial1
    C 192.168.32.0/24 is directly connected, Ethernet0
    B 192.168.33.0/24 [20/0] via 1.1.1.1, 00:16:50
    Router2#

    Router2#ping 192.168.33.1

    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 192.168.33.1, timeout is 2 seconds:
    !!!!!
    Success rate is 100 percent (5/5), round-trip min/avg/max = 8/11/24 ms
     
    phillip, Dec 12, 2004
    #1
    1. Advertisements

  2. phillip

    Ben Guest


    Hi Phillip,

    First a bit of clarification. When you ping from R2 to R3 the
    source/dest ip pairs in your emaples are totally different than when
    from R3 to R2:

    192.168.33.1 (R2) <--- 10.1.1.2 (R3)
    192.168.1.3 (R2) ---> 172.33.1.1 (R3)

    This is because ping chooses the outgoing interface as the source ip by
    default.

    Before I go on I should also mention the BGP configuration is a little
    non-standard as you are using loopbacks on the EBGP session but
    point-to-point interface ips on the IBGP session. This is opposite to
    standard practice so unless you need to use ebgp multihop I would
    convert that to a point-to-point EBGP session.
    There shouldn't be any reason why you can't convert the IBGP session to
    loopbacks also. These will stay up regardless of interface status as
    long as the router is reachable (although this is more relevant when you
    have 3 or more routers in your AS and multiple paths).

    Anyways back to this situation. The problem is now obvious - R2 does not
    have a route back to the 192.168.1.0 network as so can't reply to the
    ping even though the forward path is fine. If you enable debug icmp on
    R1 you might see an icmp unreachable message come back from R2.

    The solution is to advertise 192.168.1.0 to R2 via the bgp network
    statement.

    cheers,

    Ben
     
    Ben, Dec 12, 2004
    #2
    1. Advertisements

  3. When router3 sends out its pings, the source address is 192.168.1.3, but
    router2 doesn't have a route for 192.168.1.0/24, so it can't reply. You
    need to add "network 192.168.1.0" to router1's BGP configuration so that
    router2 will learn this route.
     
    Barry Margolin, Dec 12, 2004
    #3
  4. phillip

    phillip Guest

    The solution is to advertise 192.168.1.0 to R2 via the bgp network <--- I
    will give it a try

    Should I add the statement to R1 or R3?


     
    phillip, Dec 12, 2004
    #4
  5. phillip

    phillip Guest

    You rule! It worked!! Thanks

     
    phillip, Dec 12, 2004
    #5
  6. phillip

    Ben Guest

    No worries Phillip. You can advertise from either router but I would
    choose R1.
     
    Ben, Dec 12, 2004
    #6
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.