Bandwidth limiting per host

Discussion in 'Cisco' started by bbaruah2003, Jan 23, 2006.

  1. bbaruah2003

    bbaruah2003 Guest

    Hi,
    I have applied the following rules of limit a particular host to
    128Kbps. But I don't think its working. Any wrong with the following ?
    Please guide.

    The router is Cisco 3620 with Version 12.2(12).


    interface Ethernet0/0
    ip access-group 101 in
    rate-limit input access-group 101 128000 16000 16000 conform-action
    transmit ex
    ceed-action drop
    rate-limit output access-group 101 128000 16000 16000 conform-action
    transmit e
    xceed-action drop
    full-duplex


    access-list 101 permit ip host xx.xx.xx.xx any
    access-list 101 deny ip any any



    Regards
    baruah
     
    bbaruah2003, Jan 23, 2006
    #1
    1. Advertisements

  2. bbaruah2003

    Leigh Guest

    Hey there,

    That's kind of right, but you could tweak it a bit better. With
    rate-limiting you are giving 128k bandwidth with 16k burst each time
    period, effectively giving 256k. Which is probably why you don't think
    it's working.

    It would make more sense to build it this way, using the mcq:-

    --------

    access-list 10 permit host w.x.y.z

    class-map match-any SpecificHost
    match access-group 10

    policy-map SqueezeHost
    class SpecificHost
    police 128

    interface e0/0
    service-policy input SqueezeHost
    service-policy output SqueezeHost

    --------

    This way your chap will only get 128k tops. I would use a standard
    access-list if you are specifying a single host. If you want to use an
    extended, then make sure that you catch both to and from traffic.

    Enjoy

    LH
    CCIE#15331
     
    Leigh, Jan 23, 2006
    #2
    1. Advertisements

  3. One minor typo:
    .... should read "mqc", not "mcq". MQC stands for "Modular QoS CLI".

    Also, I suspect everyone will be happier if you _shape_ the victim host
    to
    128Kbit/sec, as opposed to _policing_ to 128Kbit/sec.

    Bruce Lueckenhoff
     
    Bruce.Lueckenhoff, Jan 23, 2006
    #3
  4. bbaruah2003

    Leigh Guest

    Good calls Bruce



     
    Leigh, Jan 23, 2006
    #4
  5. bbaruah2003

    bbaruah2003 Guest

    Hi,
    Thanks for the reply.

    But its still not working that way also. When I measure the
    bandwidth from
    x.x.x.x(client pc) its shows very high download spead. The network is
    like this:

    x.x.x.x------------------->Cisco router( where this is
    done)----->Backbone router---->Serial link.

    Cisco Router got single ethernet card and its gw has been set as the IP
    address of "Backbone Router".

    Please suggest. I want to limit each and every user passing that Cisco
    router.

    regards
    baruah
     
    bbaruah2003, Jan 24, 2006
    #5
  6. bbaruah2003

    Leigh Guest

    Hey there,

    What kind of download speeds are you getting? 128k bandwidth is not too
    slow a link for a single user.

    Could you post the bits of config that you have put on ?

    LH
    CCIE#15331
     
    Leigh, Jan 24, 2006
    #6
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.