Backlight dimming not working on Vaio after OEM install of Windows

Discussion in 'Computer Support' started by Ron, Nov 14, 2006.

  1. Ron

    Ron Guest

    I have a Vaio Sony PCG-505BXP. I wanted to do a clean install of the OS
    without all the extraneous Sony junk being installed.

    Formatted HD
    Installed a retail copy of XP Pro SP2.
    I extracted from the PAC files on the recovery CDs all of the hardware
    drivers and other software I would need and installed them manually from the
    included setup files (including Sony Shared Library, Sony shared DLL, HotKey
    Util, PowerPanel).

    I have everything working on the clean install except one small minor
    problem which is really bothering me. The PowerPanel power management
    program does not dim the LCD light when running on batteries. The program
    does recognize the change of power state and pops up a message "dimming
    LCD", but the screen does not dim. If I change the PowerPanel power scheme
    to a lower back-light brightness setting the screen does not dim as well.

    The manual fn key (HotKey util) dimming of the LCD DOES WORK.


    If I do a Sony system restore the LCD dimming does work, but of course I get
    back all the Sony garbage.

    I have an image of the entire drive (including recovery partition) of both
    the SONY SYSTEM RESTORED version and the RETAIL version affording me the
    luxury of being able to play around.

    I have even copied the registry entries from the working drive to the non
    working drive, did not help.

    I know that I could just do a system recovery and uninstall the junk, but
    this is really annoying me. I also hate to start with a less than clean
    system right out of starting gate.

    The only thing I can think of is the Sony OEM version of Windows has somehow
    been slightly modified from the retail version. But if the HotKey util can
    control the back-light through software I don't see why the PowerPanel util
    can't.

    Any thoughts or ideas would be greatly appreciated as this has really got me
    stumped.

    Thanks
     
    Ron, Nov 14, 2006
    #1
    1. Advertisements

  2. Ron

    Ron Guest

    Sorry, subject line should have read
    "Backlight dimming not working on Vaio after Retail install of Windows"
     
    Ron, Nov 14, 2006
    #2
    1. Advertisements

  3. Ron

    beenthere Guest

    snipped for reply

    Yuo could check in your Event Viewer for any errors.
    Something might show, about a file missing etc.
    HTH.
     
    beenthere, Nov 14, 2006
    #3
  4. Ron

    Ron Guest

    Thanks, nothing relevant in log.
     
    Ron, Nov 14, 2006
    #4
  5. Ron

    Evan Platt Guest

    Unless anyone else chimes in with an idea, I can guarantee you that
    you hid the nail on the head.

    I have a Dell with the same function keys up arrow, down arrow, escape
    is standby, f1 is hybernate, etc. Would all these work if I did a
    format and reinstalled from a REAL XP CD?

    I doubt it.
     
    Evan Platt, Nov 14, 2006
    #5
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.