averatec battery not charging

Discussion in 'Computer Information' started by Ronald Murray, Jul 21, 2006.

  1. Hello
    I purchased a used Averatec Laptop. 5100 Series. The battery would not power
    the unit on. It works fine as long as I stay plugged into an electrical
    outlet. I assumed the battery was dead. So I bought a new battery.It
    appeared to take a charge at first. I could turn the laptop on without the
    AC adapter , but it did not last for very long. Now it will not power on
    the laptop either.
    The power indicator in the control panel shows the old battery at 95%
    charged & the new one at 51%. I've had it plugged in for 4 hours & still it
    reads 51%.
    How much faith can I put into the power indicator?
    Is there a reason why the new battery will not charge beyond the 51% mark?
    Could there be something wrong with the laptop that would cause the
    batteries to go dead or not take a charge?
    Is there such a thing as an external laptop battery charger?
    Is there any test that I could do that would determine whether the batteries
    are actually at 95% & 51%?
    Any help would be greatly appreciated.
    Thanks in advance.
    ron
     
    Ronald Murray, Jul 21, 2006
    #1
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.