Asterisk + Granstream Budgetone + X-Pro

Discussion in 'VOIP' started by Scot, May 18, 2004.

  1. Scot

    Scot Guest

    I have Asterisk setup and running, currently just to handle calls internally
    via SIP. Using an X-Pro client to another X-Pro client, I have no problems.
    However, using X-Pro client to talk to the Budgetone IP phone, I have lots
    of problems. The connection rings and has once partially established. The
    one time it worked, I called from the Budgetone to an X-Pro and could hear
    on the Budgetone side but nothing else. Now I can't seem to even repeat
    that. In addition, when the Budgetone calls an X-Pro client, once the
    Budgetone is hung up, the X-Pro client locks up frozen.

    I'm sure it has something to do with the codecs, as I am able to ring each
    extension and connect to the Asterisk box okay. Here is my codec setup:

    Asterisk (in sip.conf):
    disallow=all
    allow=gsm
    allow=ulaw
    allow=alaw
    allow=G723.1
    On the Budgetone (under the Preferred Vocoder section):
    Choice 1: PCMU
    Choice 2: G723
    Choice 3: G723
    Choice 4: G729
    Choice 5: G726-32
    Choice 6: G728
    X-Pro (under codec settings):
    g711u
    g711a
    gsm
    g729
    iLBC
    Speex


    Any ideas?

    Thanks,

    Scott
     
    Scot, May 18, 2004
    #1
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.