asterisk and BT100

Discussion in 'VOIP' started by radar, Dec 4, 2004.

  1. radar

    radar Guest

    Hope someone can point me in the right direction with this problem. I
    have 2 BT100 phones connecting to asterisk (on a Debian box) and when
    those 2 phones (including the asterisk box) are all behind a linksys
    befsx41 they work fine, but as soon as one phone is at a different
    location (off-site) and on high-speed internet and behind a linksys
    (befsr41) also the calls can never connect. That 2nd phone gets a
    dialtone and can ring the 1st one but the call just can't connect.

    In sip.conf the 2nd phone has nat=yes and canreinvite=no (was yes but
    made no difference) but does anyone have any hints on why it would not work?
     
    radar, Dec 4, 2004
    #1
    1. Advertisements

  2. radar

    Ian Guest

    work?

    Have you got all the relevent ports open? and forwarded ? I have not yet
    tried double Nat!!!

    On the BT100 the * server should be the visible ip address that is
    forwarded. you will also need to forward all the RTP ports as well.

    Feel free to email me direct or call me 9 - 7pm (UK time) on FWD 43143

    Ian
    voipATcyber-cottage.co.uk
     
    Ian, Dec 4, 2004
    #2
    1. Advertisements

  3. radar

    BlueRinse Guest

    The dialtone on the Grandstream is from the phone so you'll always have it.

    Using double NAT you will have to be sure that on both NAT routers, the
    appropriate ports are forwarded.

    On the asterisk side (assume its ip were 192.168.1.10) you would forward
    5060 and 10000-10100 to 192.168.1.10

    On the phone side, you'd forward the same ports to the phone's ip.

    You can set up multiple SIP clients by using a range of ports like
    5060-5063 and forwarding them appropriately.

    People on mailing lists love to argue about this, but it has always
    worked for me using X-Lite, Grandstreams and Linksys NAT routers.
     
    BlueRinse, Dec 6, 2004
    #3
  4. radar

    radar Guest

    I know this is a silly question but for the ports 10000-10100 should I
    open just UDP or UDP&TCP?
     
    radar, Dec 13, 2004
    #4
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.