Assigning Invalid IP address???

Discussion in 'Wireless Networking' started by Guest, Jan 25, 2007.

  1. Guest

    Guest Guest

    I've run into a problem with my wireless laptop connection. Things were
    working fine until a few days ago. My set up is as follows -

    I have a cable modem connected to a DLink DI-624 wireless router. My home
    desktop is a LAN connection to the router. I also have a Compaq laptop with
    a built in wireless adapter, which connects into the network & I have been
    successful in file & print sharing. I also use my laptop at my office which
    has a very similar setup. The office desktop is connected to a DI-624 router
    by LAN, plus I have an office laptop & my personal laptop both connected
    wirelessly. The workgroup name on all of the computers is the same, so if I
    have my personal laptop at home, I can file share with my home desktop. If I
    have my personal laptop at the office I can file share with my office desktop
    or office laptop. It has all worked fine until a few days ago...

    Before Christmas I purchased a new home desktop computer (replaced my
    previous one) & did not have any difficulties connecting it to the network &
    was able to file share between the laptop & desktop. Last week, I got a new
    printer which I installed on my home desktop. I went to set it up to print
    share with my wireless laptop (which I was able to do before) & that's when I
    realized I no longer had file or print sharing at home. I was a bit confused
    but did some fiddeling around (mainly just ran network connection wizard on
    each computer) & managed to get things connected again. It was late at night
    & I was tired when all this occured so I figured I probably could have
    problem solved a bit better if I wasn't as tired, but under the circumstances
    the network wizard got everything fix.

    But, I took my laptop to the office today, now I cannot connect at all to my
    office network. The office desktop (LAN) & office laptop (wireless) are
    connecting fine & I have file/print sharing between those two computers, but
    I cannot get my personal laptop linked in in any way - not even to share
    internet. When I boot the computer the wireless icon displays it is
    connected to 'NFWC', the name of the network & signal strength, but then it
    has the dot going back and forth 'aquireing network address'. After a minute
    or so I get the limited or no connectivity balloon. I've tried repairing the
    connection, but still get the same result. If I open the wireless network
    status window & go to support it shows the IP address as 'invalid IP
    address'. I ran a ipconfig command & the displayed IP address was My IP address has always been . I checked
    the other computers at the office & they both have 192 addresses. Similarly
    I checked my desktop at home, its a 192 address. My laptop is connecting
    fine at home (with a 192 address). So what is causing my laptop to now get
    this invalid 169. address when I go to the office?

    Any help would be greatly appreciated.
    Guest, Jan 25, 2007
    1. Advertisements

  2. Guest

    David Hettel Guest

    My guess is in playing with the connections you broke the security setting
    for the office network. Try deleting the office network on your laptop and
    recreating it again on the laptop.

    David Hettel

    Please post any reply as a follow-up message in the news group for everyone
    to see. I'm sorry, but I don't answer questions addressed directly to me in
    E-mail or news groups.

    Microsoft Most Valuable Professional Program

    DISCLAIMER: This posting is provided "AS IS" with no warranty of any kind,
    either expressed or implied, made in relation to the accuracy, reliability
    or content of this post. The author shall not be liable for any direct,
    indirect, incidental or consequential damages arising out of the use of, or
    inability to use, information or opinions expressed in this post and confers
    no rights.
    David Hettel, Jan 25, 2007
    1. Advertisements

  3. Guest

    Guest Guest

    OK, that idea makes sense to me & that is what I was thinking/hoping to do,
    but I don't understand how I delete the office network. Could you give a bit
    more direction please. Thanks for your help in advance.
    Guest, Jan 25, 2007
  4. Guest

    Jim Guest

    The 169.x.x.x address is the one which the software on your computer uses
    when it cannot find a DHCP server.
    Thus, your problem is that your laptop cannot find the DHCP server.
    Jim, Jan 25, 2007
  5. Hi

    It is not a day to day usual occurrence, but settings of a computer can
    suddenly change, it can be done inadvertently by the user, or and, by
    applications and process that affect one the other due to programming
    mistakes, or in case of temporary malfunction.

    While running the Wizards is a good idea when setting new "stuff" on the
    computer it is not a good idea to keep running it when some thing goes wrong
    and need to be fixed. By running the wizard on top of already configured
    Network, it does not necessarily erasing the current none functional
    settings, but might add more entries to the registry and configuration
    files, and thus add more confusion.

    When a system is working OK and suddenly gets out of control the way to deal
    with it is to find what is not functioning correctly and "Fix" it.

    As David said above, your description might indicate that the Laptop's
    Wireless settings does not match any more to the Wireless Router and thus
    can not establish a connection and be assigned with am IP. As a result it
    defaults to the Windows OS setting its own default IP

    Disable temporarily the security measures that you have on the Laptop, log
    to the Router with a functional computer, (or connect the laptop with a wire
    to the Router) write down the Wireless setting and duplicate them to the

    Jack (MVP-Networking).
    Jack \(MVP-Networking\)., Jan 25, 2007
  6. Guest

    Guest Guest

    Thanks for the advice. Before I recieved you message, I actually tried
    something different & it worked. I probably didn't have to do both of these
    things, but at any rate it work. First I opened the Wireless Network Connect
    & delected the network from the preferred network. Then (this is the part
    that probably wasn't necessary) I deleted the wireless network adapater from
    the device manager. Rebooted the system & let it redetect the wireless
    adapter & network, re-entered the network key & everything works.
    Guest, Jan 25, 2007
  7. Hi

    Glad that you solved it.

    By deleting the Wireless card from the Device manager, the old settings are
    out, and Windows installed a new TCP/IP stack (a good idea that might help
    cleaning some of the junk that repetitive running of the wizard could
    create). If you look at the Control Pane/Network Connections, you would see
    that there is new Local Area Connection with advanced number for the
    connection (If it was #2 it would be now #3 etc).

    Fresh TCP/IP Stack with the right Wireless settings is as good as new ;).

    Jack (MVP-Networking).
    Jack \(MVP-Networking\)., Jan 25, 2007
  8. Guest

    Brigadier Guest

    Just out of curiosity, could this TCP/IP Stack 'junk' be responsible
    for a range reduction or slow connection?

    Brigadier, Jan 28, 2007
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.