ASA 5505 behind Router -> Port-forwarding

Discussion in 'Cisco' started by Steffen Mauch, Nov 14, 2008.

  1. Hello Group!

    I've got a difficult task (for me) with the ASA5505. We want to use the ASA
    on several locations around the world. Because the different locations have
    different ways to access the internet we must find a simple way to connect
    the ASA to the internet which fits most (probably all) variations we will
    encounter. So we had the idea to use port-forwarding from the routers which
    are installed at the different locations to our ASAs. I'm now testing this
    solution but there are several Problems. First of all, this ist the
    test-configuration:

    Draytek 2930 router connected via fixed IP to the Internet. On the Draytek I
    added port-forwarding from 40000 to the ASA port 443. Behind the ASA we have
    several services (webserver -> port 80, windows remote desktop, vnc ...)
    which we want to access.

    When I type in the internet-address of the Draytek and add port 40000 I see
    the ASAs login page. Login is possible without problems. Bookmarks to
    webservers behind the ASA seem to work fine (as long as the response
    html-code is not to buggy, which "destroys" the opened site in ASA (buttons
    on the upper left doesn't show up, the site is blank, html-code of the page
    ends abnormal)).
    Now I've tried the AnyConnect but when I click the link to start AnyConnect
    I get an timeout. I wasn't able to get this problem solved. Any Ideas how to
    get AnyConnect to work behind the first router via port-forwarding?

    Thank you for your attention.
    Steffen mauch
     
    Steffen Mauch, Nov 14, 2008
    #1
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.