Area 0 in OSPF routing protocol ?

Discussion in 'Cisco' started by Benson, Aug 17, 2004.

  1. Benson

    Benson Guest

    Hi,

    I have a network 10.0.0.0. the area is like the following :

    network 10.9.0.0 0.0.255.255 area 9

    I want to config an area 0 for the network.

    Can I configure like the following :

    network 10.9.0.0 0.0.255.255 area 9
    network 10.9.252.0 0.0.0.255 area 0

    thank you
    Benson
     
    Benson, Aug 17, 2004
    #1
    1. Advertisements

  2. Benson

    Ivan Ostres Guest

    In article <>,
    says...
    > Hi,
    >
    > I have a network 10.0.0.0. the area is like the following :
    >
    > network 10.9.0.0 0.0.255.255 area 9
    >
    > I want to config an area 0 for the network.
    >
    > Can I configure like the following :
    >
    > network 10.9.0.0 0.0.255.255 area 9
    > network 10.9.252.0 0.0.0.255 area 0
    >
    > thank you
    > Benson
    >


    You can get some unexpected results doing that. It looks like it should
    work, since network statements should act like access lists (first thing
    first). If you want to be sure what you're doing, you can specify the
    interfaces themself (with wildcard mask 0.0.0.0).

    It might be much easier this way when problems come in and you need to
    troubleshoot.

    --
    -Ivan.

    *** Use Rot13 to see my eMail address ***
     
    Ivan Ostres, Aug 17, 2004
    #2
    1. Advertisements

  3. Benson

    Vikram Guest

    Ivan Ostres <> wrote in message news:<>...
    > In article <>,
    > says...
    > > Hi,
    > >
    > > I have a network 10.0.0.0. the area is like the following :
    > >
    > > network 10.9.0.0 0.0.255.255 area 9
    > >
    > > I want to config an area 0 for the network.
    > >
    > > Can I configure like the following :
    > >
    > > network 10.9.0.0 0.0.255.255 area 9
    > > network 10.9.252.0 0.0.0.255 area 0
    > >
    > > thank you
    > > Benson
    > >

    >
    > You can get some unexpected results doing that. It looks like it should
    > work, since network statements should act like access lists (first thing
    > first). If you want to be sure what you're doing, you can specify the
    > interfaces themself (with wildcard mask 0.0.0.0).
    >
    > It might be much easier this way when problems come in and you need to
    > troubleshoot.


    I believe u cannot have n/w 's

    network 10.9.0.0 0.0.255.255 area 9
    network 10.9.252.0 0.0.0.255 area 0

    defined like the one above, since on u'r Area Boundary Router (for
    Area 9) u will need to summarize 10.9.0.0 network and advertise .

    Regds,
    Vikram
     
    Vikram, Aug 18, 2004
    #3
  4. Benson

    Hansang Bae Guest

    In article <>,
    says...
    > Hi,
    >
    > I have a network 10.0.0.0. the area is like the following :
    >
    > network 10.9.0.0 0.0.255.255 area 9
    >
    > I want to config an area 0 for the network.
    >
    > Can I configure like the following :
    >
    > network 10.9.0.0 0.0.255.255 area 9
    > network 10.9.252.0 0.0.0.255 area 0


    YOu can do the above. But based on your earlier question, you may want
    to research what it is you're trying to accomplish. It's quite easy to
    break OSPF if you don't design it properly.

    --

    hsb

    "Somehow I imagined this experience would be more rewarding" Calvin
    *************** USE ROT13 TO SEE MY EMAIL ADDRESS ****************
    ********************************************************************
    Due to the volume of email that I receive, I may not not be able to
    reply to emails sent to my account. Please post a followup instead.
    ********************************************************************
     
    Hansang Bae, Aug 18, 2004
    #4
  5. Benson

    Hansang Bae Guest


    > > network 10.9.0.0 0.0.255.255 area 9
    > > network 10.9.252.0 0.0.0.255 area 0


    In article <>,
    says...
    > YOu can do the above. But based on your earlier question, you may want
    > to research what it is you're trying to accomplish. It's quite easy to
    > break OSPF if you don't design it properly.


    Oops.. didn't see the overlapping wildcard mask.

    --

    hsb

    "Somehow I imagined this experience would be more rewarding" Calvin
    *************** USE ROT13 TO SEE MY EMAIL ADDRESS ****************
    ********************************************************************
    Due to the volume of email that I receive, I may not not be able to
    reply to emails sent to my account. Please post a followup instead.
    ********************************************************************
     
    Hansang Bae, Aug 18, 2004
    #5
  6. Benson

    Benson Guest

    Hi, Ivan,


    Thank you for your help.
    Could you please tell me something about the "unexpected result" ?

    And show me how to configure the "If you want to be sure what you're
    doing, you can specify the interfaces themself (with wildcard mask
    0.0.0.0). " ?

    Thank you



    Ivan Ostres <> wrote in message news:<>...
    > In article <>,
    > says...
    > > Hi,
    > >
    > > I have a network 10.0.0.0. the area is like the following :
    > >
    > > network 10.9.0.0 0.0.255.255 area 9
    > >
    > > I want to config an area 0 for the network.
    > >
    > > Can I configure like the following :
    > >
    > > network 10.9.0.0 0.0.255.255 area 9
    > > network 10.9.252.0 0.0.0.255 area 0
    > >
    > > thank you
    > > Benson
    > >

    >
    > You can get some unexpected results doing that. It looks like it should
    > work, since network statements should act like access lists (first thing
    > first). If you want to be sure what you're doing, you can specify the
    > interfaces themself (with wildcard mask 0.0.0.0).
    >
    > It might be much easier this way when problems come in and you need to
    > troubleshoot.
     
    Benson, Aug 18, 2004
    #6
  7. Benson

    Ivan Ostres Guest

    In article <>,
    says...
    > Hi, Ivan,
    >
    >
    > Thank you for your help.
    > Could you please tell me something about the "unexpected result" ?
    >
    > And show me how to configure the "If you want to be sure what you're
    > doing, you can specify the interfaces themself (with wildcard mask
    > 0.0.0.0). " ?
    >
    >


    Let's say you have following interfaces:

    int faste 0/1
    ip address 10.10.10.1 255.255.255.0

    int faste 0/2
    ip address 10.11.12.13 255.255.255.0

    router ospf 1
    network 10.10.10.1 0.0.0.0 area 0
    network 10.11.12.13 0.0.0.0 area 9

    You don't need to specify networks (in ospf), just interfaces that
    participate in OSPF process.


    --
    -Ivan.

    *** Use Rot13 to see my eMail address ***
     
    Ivan Ostres, Aug 18, 2004
    #7
  8. Benson

    Hansang Bae Guest

    In article <>,
    says...
    > Hi, Ivan,
    >
    >
    > Thank you for your help.
    > Could you please tell me something about the "unexpected result" ?
    >
    > And show me how to configure the "If you want to be sure what you're
    > doing, you can specify the interfaces themself (with wildcard mask
    > 0.0.0.0). " ?


    Please don't take this the wrong way, but if your company is expecting
    you to connect the two companies together, you really should get some
    help making this happen.

    --

    hsb

    "Somehow I imagined this experience would be more rewarding" Calvin
    *************** USE ROT13 TO SEE MY EMAIL ADDRESS ****************
    ********************************************************************
    Due to the volume of email that I receive, I may not not be able to
    reply to emails sent to my account. Please post a followup instead.
    ********************************************************************
     
    Hansang Bae, Aug 19, 2004
    #8
    1. Advertisements

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.
Similar Threads
  1. news.comcast.giganews.com

    Protocol Chart - Learn how to use a Protocol Analyzer

    news.comcast.giganews.com, Aug 21, 2004, in forum: Wireless Networking
    Replies:
    0
    Views:
    3,510
    news.comcast.giganews.com
    Aug 21, 2004
  2. Benson

    OSPF Area 0

    Benson, Jun 19, 2004, in forum: Cisco
    Replies:
    4
    Views:
    1,117
    Benson
    Jun 21, 2004
  3. Benson
    Replies:
    0
    Views:
    633
    Benson
    Aug 17, 2004
  4. Victor
    Replies:
    1
    Views:
    3,608
    Barry Margolin
    Aug 10, 2005
  5. Harkin
    Replies:
    6
    Views:
    6,166
    Harkin
    Aug 11, 2005
  6. cisco_guru

    How many routers in OSPF area

    cisco_guru, Mar 23, 2006, in forum: Cisco
    Replies:
    1
    Views:
    1,211
    Kevin Widner
    Mar 23, 2006
  7. Replies:
    4
    Views:
    6,942
  8. Ockerr

    ZAP 0.0.0.0/0.0.0.0 mystery network

    Ockerr, May 28, 2006, in forum: Computer Support
    Replies:
    3
    Views:
    568
    Ralph Wade Phillips
    May 29, 2006
Loading...