Adobe Photoshop Elements 2.0

Discussion in 'Digital Photography' started by Robert Peirce, Nov 1, 2003.

  1. On my Mac, I keep getting a panel (see below) that says an operation
    could not be completed because the file is locked. However, it doesn't
    tell me what file is locked. Does anybody know? Once I click OK,
    everything seems normal, but I can't be sure.


    Adobe Photoshop Elemeents
    Could not complete your request because the file
    is locked. Use the 'Get Info' command in the
    Finder to unlock the file.
     
    Robert Peirce, Nov 1, 2003
    #1
    1. Advertisements

  2. Robert Peirce

    Argon3 Guest

    This has been plaguing me as well...I assume that it's a glitch of some kind.
    What version of the Mac OS are you using? I'm on 10.2.8 and I could swear that
    this wasn't a problem until the last one or two system upgrades that I
    downloaded from Apple.

    argon
     
    Argon3, Nov 1, 2003
    #2
    1. Advertisements

  3. Robert Peirce

    Sloopy Guest

    I'd say it means the file you're trying to work on is locked. It tells
    you how to fix it. Does that not work?

    -Sloopy
     
    Sloopy, Nov 1, 2003
    #3
  4. Robert Peirce

    Bob Haar Guest

    I am getting the same error message when I am not trying to open or
    manipulate any image file - just sitting at a directory browsing level with
    nothing happening that I have initiated.

    My suspicion is that PE is trying to look for new images in the background
    or is doing some internal housekeeping.

    My other thought is that since I installed PE from the admin account but am
    running it from a use account, there may be some kind of permissions problem
    in the way that PE access preferences, etc. This would not be the first
    application that didn't handle the multi-user environment and UNIX file
    permissions in OS X.
     
    Bob Haar, Nov 1, 2003
    #4
  5. Robert Peirce

    CSM1 Guest

    If you have any image open in any program other than PS Elements, The file
    is locked to PS Elements..
     
    CSM1, Nov 1, 2003
    #5
  6. Robert Peirce

    LarryDoc Guest

    Two thoughts: IF the message panel opens when you launch PE:

    1. At one point you quite the app without saving the open file and
    dismissed the warning dialog box and that file is still "waiting to be
    opened". Easy to happen when, especially, if you "force quit" the app.
    "Find" files created with PE since around the time this "error" began
    and take a look see.

    2. The good old permissions thing: why don't you just check and look and
    fix it. And move to Panther.

    --LB

    --
    Dr. Larry Bickford, O.D.
    Family Practice Eye Health & Vision Care

    The Eyecare Connection
    http//www.eyecarecontacts.com
    larrydoc at m a c.c o m
     
    LarryDoc, Nov 2, 2003
    #6
  7. Why would elements care if I was not trying to open it?
     
    Robert Peirce, Nov 3, 2003
    #7
  8. Nope. The file I am working on is okay. This is referrencing something
    else.
     
    Robert Peirce, Nov 3, 2003
    #8
  9. I am running 10.2.8 but I had it before I installed PE. I can't see
    that anything is affectged, but it is annoyinbg.
     
    Robert Peirce, Nov 3, 2003
    #9
  10. Robert Peirce

    CSM1 Guest

    Because Elements is trying to write to the file. Elements has to keep the
    actions that you perform somewhere. If Elements thinks the file is locked,
    then nothing you try to do will work.

    It's a PITA.
     
    CSM1, Nov 3, 2003
    #10
  11. This is not correct. Having any image open in any other program NOT
    cause a problem with PS Elements. Also (though it does not effect the
    original poster), if you have image a.jpg open in a another program and
    then try to open the same image in PS Elements then you still don't get
    a problem - it opens fine. You can edit and save file in both programs
    with the last save overwriting the first (using SAVE rather than SAVE AS...
    and chosing different names).

    So I think the problem lies with one of PS Elements own files though I
    am surprised that PS Elements does not give more information about the
    problem. I think it is more likely that a preference or scratch file has
    been damaged. Have you tried creating a new account on your Mac and
    launching PS Elements from that? If the works then suggests the problem
    is with a preference file, for example, stored in your own folders (
    perhaps ~/Library/preferences/com.adobe.Photoshop.Elements.plist or
    files in ~/Library/preferences/PhotoShop Elements 2.0 Prefs, where ~ is
    your home directory). You could simply delete these but you will lose
    some personal settings related to PS Elements and list of recent files.


    If this does not work maybe the problem lies with files in /Applications/
    Adobe Photoshop Elements 2/ or with the Application bundle itself.
    Either way the easiest thing may be to try re-installing. If doing this
    doesn't work then I would delete
    /Applications/Adobe Photoshop Elements 2/ folder first then re-install.
    You will need your original serial number available if you do this, I
    think.
     
    Stephen Bedford, Nov 4, 2003
    #11
  12. Thanks. I'll check this out.
     
    Robert Peirce, Nov 5, 2003
    #12
  13. Hello,

    Assuming your problem is the same as mine, the fix is pretty simple.

    First, go to the Adobe web site. There's a support page there that
    explains what's going on (has to do with using the app from an account
    that's not an admin account). The URL is:

    <http://www.adobe.com/support/techdocs/3019e.htm>

    Follow the instructions there. If you cannot get the "Get Info"
    Ownership & Permissions dialog to do the work for you, get "BatchMod"
    from VersionTracker or whatever.

    Hope this solves your problem, best,

    Todd
     
    F. Todd Wilson, Nov 11, 2003
    #13
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.