Activating Programs ( Cursor Non-Flashing )

Discussion in 'Windows 64bit' started by Jack Rabbitt, Mar 12, 2012.

  1. Jack Rabbitt

    Jack Rabbitt Guest

    Hi All,

    On our Windows 2008 64 bit server, we have noticed that the cursor does not
    flash/blink in any of our programs, such as in notepad, word etc,... where
    as in windows xp server it does. ( try it, create a new text document and
    see the flashing cursor in top left )

    We have checked the cursor settings and they are set to flash fast, so we
    think there is some other security setting somewhere, as we have to
    effectivally activate the program by clicking into it, then it will allow us
    to type - does this sound plausable?

    Any help or guideance apprieated.

    Thanks
     
    Jack Rabbitt, Mar 12, 2012
    #1
    1. Advertisements

  2. Jack Rabbitt

    VanguardLH Guest

    Does "cursor" mean the mouse cursor or the insertion point in a
    document? The mouse should not flash/blink. The insertion point
    should.
    No such animal.
    Sounds more like some process and its window is stealing focus. You
    open a program that paints its window but the insertion point is showing
    there because some other process has stolen back the focus even those
    that have their windows minimized or hidden (visible attribute is
    disabled). If the focus-stealing program has an visible non-minimized
    window, hit Alt+Spacebar to open its control menu and then look to see
    which window is showing it. Alternatively, you can use SysInternals'
    Process Explorer and when focus gets stolen then hit Alt+F4 to exit that
    application and notice which process disappears in Process Explorer.

    You'll need to investigate what processes are running. You'll want to
    disable all the startup items, reboot, and retest. Reenable one startup
    item at a time, reboot, and retest. When the problem reappears, the
    just-previously-reenabled program is the culprit.

    Is the server running on a laptop? If so, have you tried disabling the
    touchpad so close proximity of the heels of your palms isn't triggering
    a mouse click somewhere you don't expect?

    While there are C+ examples of how to find which process has focus, you
    can also use AutoHotkey and a script to find out, as in (got this from a
    Google search):

    #NoEnv ; Recommended for performance and compatibility with future AutoHotkey releases.
    SendMode Input ; Recommended for new scripts due to its superior speed and reliability.
    SetWorkingDir %A_ScriptDir% ; Ensures a consistent starting directory.

    ^!s::

    WinGetActiveTitle, text ; The window found above will be used.
    MsgBox, The text is:`n%text%

    Does the problem go away if you disable any microphone (as a separate
    mic or in a headset) and retest?
     
    VanguardLH, Mar 13, 2012
    #2
    1. Advertisements

  3. Jack Rabbitt

    Jack Rabbitt Guest

    Thanks for reply, will have a good look at this.
     
    Jack Rabbitt, Mar 17, 2012
    #3
  4. The scrpt is run by pressing (Ctrl Alt s) ?

    Also, isn't it time to upgrade from C+ to C++ ? :)
     
    Robert Carnegie, Mar 17, 2012
    #4
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.