"Acquiring Network Address"

Discussion in 'Wireless Networking' started by babyeggplant, Feb 27, 2010.

  1. babyeggplant

    babyeggplant Guest

    Hello,

    We're talking about two Windows XP machines, one a Sony Vaio laptop, the
    other a MacBook, running boot camp. Both have all service packs installed,
    all current patches and updates installed. Both are carefully checked for
    malware. Both of them connect to the internet via my WiFi router.

    I recently upgraded the firmware for my D-Link WiFi router. The DSL modem
    is in bridge mode. The configurations for connecting to my DSL ISP (AT&T) are
    entered into the router.

    After the firmware upgrade, I re-entered the ISP settings, and entered a new
    WPA password for the WiFi. The wifi network worked, sort of, for both
    Macintosh and Windows machines. But it seemed like it was often disconnecting
    and reconnecting the machines connected by WiFi, even though the signal was
    strong.

    Frustrated, and attempting to troubleshoot, I disabled the WPA protection.
    For now, I have no password protection for WiFi access.

    The WiFi seems to work fine on my Macintosh laptops.

    On my Windows Xp machines, described above, the WiFi frequently disconnects,
    momentarily. If I click on the little WiFi icon, I see a message that says
    "Acquiring network address." Sometimes this happens once every few minutes.
    Sometimes it happens less often. Soon, a network address is re-established,
    and I'm connected to the internet.

    I particularly notice this problem because I use the Rhapsody To Go
    application on the Windows XP machines. Every time the WiFi looks for a new
    network address, I lose my connection, have to log in again.

    I'm tempted to buy a new router, but I'd be really discouraged if I had the
    same problems with a new one.

    What could the trouble be? Troubleshooting suggestions very welcome.

    Thanks in advance,

    Tim
     
    babyeggplant, Feb 27, 2010
    #1
    1. Advertisements

  2. babyeggplant

    Lem Guest

    It could be something as simple as a power-save feature on the wifi
    adapter on the Sony or it could be something in the new router firmware
    (why did you update it?).

    Try checking in a D-Link specific forum (and include the model of your
    router): e.g., http://www.dslreports.com/forum/dlink (there seems to be
    some issue with firmware rev 1.20 for the DGL 4500).

    D-Link company forums: http://forums.dlink.com/
     
    Lem, Feb 27, 2010
    #2
    1. Advertisements

  3. babyeggplant

    babyeggplant Guest

    :



    Thankya Lem,

    It's a D-Link WBR-2310. I see a some other similar complaints about this
    router on the DSLreports.com forum. I upgraded the firmware because someone
    told me that more recent firmware is safer and more reliable. This router
    worked fine with the old firmware. However, I think I had WEP password
    protection enabled.

    It looks like I'm not making any classic mistakes, and maybe this router is
    kind of old. I might try a hardware reset first, then reset the DSL settings,
    and so on. If that doesn't work, I suppose I will replace it and hope for the
    best.


    Tim
     
    babyeggplant, Feb 28, 2010
    #3
  4. babyeggplant

    noi ance Guest

    I hope I'm not too late but I think you just need to reset your router to
    factory settings. Then re-enter your desired configuration. Follow
    router instruction manual to reset to factory settings.

    I had a similar problem when my router was constantly scanning for
    channels, which meant it disconnected every 3 seconds. Solved by reset
    to factory settings, then putting in my configuration.
     
    noi ance, Feb 28, 2010
    #4
  5. babyeggplant

    babyeggplant Guest

    :

    I actually solved this problem! Lurkers and future searchers might find this
    helpful.

    It was a conflict between the Rhapsody (music player) application and the
    D-Link router. D-Link routers often have problems with UPnP (Universal Plug
    and Play). This is a well-known problem with the Rhapsody application. You
    have to turn off the UPnP application. I think it's in the preferences menu.


    Baby E.
     
    babyeggplant, Mar 4, 2010
    #5
  6. babyeggplant

    babyeggplant Guest

    I meant "UPnP option," not "UPnP application."

    BE
     
    babyeggplant, Mar 4, 2010
    #6
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.