Accessing a LAN resource using WAN IP using a Linksys WRT55AGv2 router

Discussion in 'Computer Support' started by Donald Burr, Nov 14, 2006.

  1. Donald Burr

    Donald Burr Guest

    I recently upgraded my Linksys wireless router. Previously I had a
    WRT54GSv1.1, which worked perfectly. However, recently the density of
    2.4GHz wireless devices around me has suddenly increased, making my
    wireless extremely unstable on any channel. To help alleviate this, I
    decided to upgrade to a Linksys WRT55AGv2 router, which supports both
    802.11A (on the 5.8 GHz band) and 802.11b/g (on the 2.4GHz band). I
    plan on using this router with the 2.4 GHz *b/g) side disabled. I have
    8902.11a cards for all of my machines, so that is fine with me.

    Anyway, I am having a major problem with this new router. First, a
    description of how I have things set up.

    I've got a small network consisting of several machines (both desktops
    and laptops) and a FreeBSD server, sitting behind a Linksys wireless &
    wired router. The Linksys is in turn hooked to my DSL modem, which has
    a static IP associated with it. (Let's refer to this as "PUBIP" for
    convenience's sake). The DSL modem is connected to the "WAN" port on
    the LInksys, as it should be.

    The FreeBSD server is connected to one of the wired LAN ports on the
    LInksys. I have assigned it a Static IP in the private range
    (192.168.1.x). Let's called this "SPRVIP" (Static PRiVate IP). This
    IP is set as the "DMZ Host" in the Linksys, so that anybody attempting
    to connect to PUBIP (i.e. incoming connections from the Internet) get
    routed to the FreeBSD box on SPRVIP. This is because I run various
    services (remote login, FTP server, web server, etc.) for myself and
    several friends on this machine.

    The various other client machines (laptops and desktops) are hooked
    either to wired ports, or connected via wireless. They are getting
    their addresses from the DHCP server built into the Linksys. They
    never need to be reachable from the outside world, so DMZ, port
    forwarding, etc. on these machines is NOT a concern.

    Now, any internal host can connect with any other internal host. And,
    as expected, any Internet user who tries to connect to any port on
    PUBIP (say, port 80 to get to my web server), gets properly DMZ'd to
    the FreeBSD server's SPRVIP. Both of these worked fine with the old
    router, and still work fine with the new router.

    However, there is one thing that no longer works.

    Let's say I am on one of the internal machines, say, one of the
    laptops. I fire up my Web browser, and I want to check out the web
    site running on my FreeBSD server. Of course, I can do this by
    browsing to "http://SPRVIP/" (i.e. connect to the FreeBSD box's
    internal IP address). That in fact still works fine on the new router.


    When I was using the WRT54GS, I *also* used to be able to connect to
    the *EXTERNAL* IP address from an *INTERNAL* host, and the router was
    smart enough to send it through to the DMZ host. So, again on one of
    my internal machines, I would browse to the URL "http://PUBIP/", and
    the router would see this, and figure out "ahh! I need to send this to
    the DMZ host -- SPRVIP".

    This NO LONGER WORKS on the new WRT55AGv2. Any accesses to any
    resource (be it HTTP, SMTP, FTP, what have you), sit there and hang for
    several minutes before timing out.

    I've been tearing my hair out on this for almost 12 hours now, with no
    luck. I've tried every permutation of the Security,
    Applications/Gaming, DMZ, etc. configuration screens, with NO success.
    I even gritted my teeth and played with the mysterious "Static Routes"
    to no avail. I've searched Google (including Google Groups) but have
    found only one post that describes this problem:
    (in fact, I found a posting from this very newsgroup, from back on
    January 19, from a "Jack B. Pollack", with only one response that did
    not properly address the problem.

    Please, I am hoping that someone out there has an idea of how to get
    this working. I'd really hate to have to return this lovely 802.11A
    router (my wireless stability and performance have improved
    dramatically since switching to the 5.8 GHz 802.11a).

    Thank you in advance for any assistance you may be able to provide.
    Donald Burr, Nov 14, 2006
    1. Advertisements

  2. Hi,

    Was reading your post and was about to reply with some comments, when I got
    to the part where you found my old post. I was never able to resolve the
    problem using the new router. I eventual ended up getting a different router
    that supported the loop-back feature. Sorry not to have any more help.
    Jack B. Pollack, Nov 14, 2006
    1. Advertisements

  3. Donald Burr

    Tony Guest

    I'm wondering if a workaround might be to set up a free subdomain with
    someone like then point to the subdomain to your
    public IP address. Instead of typing the public IP address into the
    browser, you would type in the subdomain name, which would then point back
    to your public IP address and then to the server in the DMZ - ie create a
    loop sending outside the router via the internet back to the router.

    Just a long shot.
    Tony, Nov 14, 2006
  4. Donald Burr

    Whiskers Guest


    I think that some routers provide a 'loopback' and some don't.

    You could get the same effect by putting an entry into your 'hosts' file
    (on each machine that you want it to work on) so that trying to access
    your public domain name is directed to the local IP number of the public
    web server. You could try using the public IP number intead of the local
    one, too.
    Whiskers, Nov 14, 2006
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.