Access to Program Files <x86> Drectory

Discussion in 'Windows 64bit' started by =?Utf-8?B?dG9iaWFsbA==?=, Feb 14, 2006.

  1. I installed a 32 bit application that runs from the command line and it
    installed in Program Files <x86> Drectory. how do I access the directory to
    exicute the command?
     
    =?Utf-8?B?dG9iaWFsbA==?=, Feb 14, 2006
    #1
    1. Advertisements

  2. =?Utf-8?B?dG9iaWFsbA==?=

    Rick Guest

    Click on <Start> then <Run> then <Browse> and find the directory and the
    file you want to execute. The exact same procedure you would in any
    version since Windows 95.
     
    Rick, Feb 14, 2006
    #2
    1. Advertisements

  3. The command needs to be executed from the command line. When you run in from
    <Start Run> all you get is a flash by CMD window. I tried to go to the
    C:\Program Files <x86> using cd but I get (The system cannot find the path
    specified) error.
     
    =?Utf-8?B?dG9iaWFsbA==?=, Feb 14, 2006
    #3
  4. There's a registry hack that will add a "Open CMD Prompt here" to your right
    click menu, and I'll include that at the end of this. But you can always
    just open a command window and navigate to the directory. It's a nuisance
    when the directory name has spaces in it, but you have some choices to help.
    Wild cards are accepted, as long as they're not ambiguous, so, to get into
    the Program Files (x86) directory:
    Start->Run->Cmd gives you a command window.
    CD /d C:\*86* changes your working drive and directory to c:\Program
    Files (x86)

    From there, change into your applications directory.

    Now, for the registry hack. Copy the stuff between the lines to a .REG file
    and double click on it.

    ======================
    Windows Registry Editor Version 5.00

    [HKEY_CLASSES_ROOT\Folder\shell]
    @="open"

    [HKEY_CLASSES_ROOT\Folder\shell\Command_Prompt_Here]
    @="Command Prompt Here"

    [HKEY_CLASSES_ROOT\Folder\shell\Command_Prompt_Here\command]
    @="cmd.exe /k cd \"%1\""

    [HKEY_CLASSES_ROOT\Folder\shell\explore]
    "BrowserFlags"=dword:00000022
    "ExplorerFlags"=dword:00000021

    [HKEY_CLASSES_ROOT\Folder\shell\explore\command]
    @=hex(2):25,00,53,00,79,00,73,00,74,00,65,00,6d,00,52,00,6f,00,6f,00,74,00,25,\
    00,5c,00,45,00,78,00,70,00,6c,00,6f,00,72,00,65,00,72,00,2e,00,65,00,78,00,\
    65,00,20,00,2f,00,65,00,2c,00,2f,00,69,00,64,00,6c,00,69,00,73,00,74,00,2c,\
    00,25,00,49,00,2c,00,25,00,4c,00,00,00

    [HKEY_CLASSES_ROOT\Folder\shell\explore\ddeexec]
    @="[ExploreFolder(\"%l\", %I, %S)]"
    "NoActivateHandler"=""

    [HKEY_CLASSES_ROOT\Folder\shell\explore\ddeexec\application]
    @="Folders"

    [HKEY_CLASSES_ROOT\Folder\shell\explore\ddeexec\ifexec]
    @="[]"

    [HKEY_CLASSES_ROOT\Folder\shell\explore\ddeexec\topic]
    @="AppProperties"

    [HKEY_CLASSES_ROOT\Folder\shell\open]
    "BrowserFlags"=dword:00000010
    "ExplorerFlags"=dword:00000012

    [HKEY_CLASSES_ROOT\Folder\shell\open\command]
    @=hex(2):25,00,53,00,79,00,73,00,74,00,65,00,6d,00,52,00,6f,00,6f,00,74,00,25,\
    00,5c,00,45,00,78,00,70,00,6c,00,6f,00,72,00,65,00,72,00,2e,00,65,00,78,00,\
    65,00,20,00,2f,00,69,00,64,00,6c,00,69,00,73,00,74,00,2c,00,25,00,49,00,2c,\
    00,25,00,4c,00,00,00

    [HKEY_CLASSES_ROOT\Folder\shell\open\ddeexec]
    @="[ViewFolder(\"%l\", %I, %S)]"
    "NoActivateHandler"=""

    [HKEY_CLASSES_ROOT\Folder\shell\open\ddeexec\application]
    @="Folders"

    [HKEY_CLASSES_ROOT\Folder\shell\open\ddeexec\ifexec]
    @="[]"

    [HKEY_CLASSES_ROOT\Folder\shell\open\ddeexec\topic]
    @="AppProperties"

    ======================
     
    Charlie Russel - MVP, Feb 14, 2006
    #4
  5. Hi,
    try :
    cd "C:\Program Files (x86)"
    in quotes (? - i am german)
    regards
    jk
     
    Juergen Kluth, Feb 14, 2006
    #5
  6. Thanks this worked fine.

     
    =?Utf-8?B?dG9iaWFsbA==?=, Feb 14, 2006
    #6
  7. Thank you this worked fine also. I spent 4 nice years in Mienz.
     
    =?Utf-8?B?dG9iaWFsbA==?=, Feb 14, 2006
    #7
  8. =?Utf-8?B?dG9iaWFsbA==?=

    jcha

    Joined:
    May 28, 2016
    Messages:
    1
    Likes Received:
    0
    i am having trouble with this. I am new to using the command prompt. I have been getting the irql_not_less_or_equal blue screen because of a driver I just installed. I am trying to delete the folder, but I don't remember what the file name was, so I need to see the directory of x86 so I can delete it. then I'll need advice on how to delete the file. luckily the automatic repair has the option of the command prompt, and I know just enough to know I can fix this issue this way with just a little guidance. thanks for any help.

    to be clear, i tried to do the cd/d C:\*86* and other variations of this to no avail
     
    jcha, May 28, 2016
    #8
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.