Able to Connect to wireless router, but can't see internet

Discussion in 'Wireless Networking' started by Guest, Dec 20, 2005.

  1. Guest

    Guest Guest

    I have a linksys WRT54G wireless router. I have two computers: A desktop
    and a laptop, both running Windows XP Pro SP 2. My desktop connects to the
    router using a wireless G card. On the desktop, I am able to connect to the
    router and surf the net without problem. My laptop, on the other hand, is
    able to connect to the router, but when I bring up internet explorer, I am
    unable to access any websites. From the laptop, I can "ping" the router. I
    am able to establish what seems to be a working wireless connection. My
    connection status is "connected," my speed is 54mbs and packets are being
    sent and received. When I go to the command window and type "ipconfig," I
    have an ip address for the laptop:, my subnet mask is, my default gateway is But when I bring up
    internet explorer, I can go no where. I get the "page cannot be displayed"
    screen. I have tcp/ip installed and have selected "obtain address
    Does anyone have any suggestions on what I should try? Any help would be
    GREATLY appreciated. Thanks.
    Guest, Dec 20, 2005
    1. Advertisements

  2. Guest

    Guest Guest

    Joe, I'm having the identical problem with a brand new Toshiba Satellite
    Notebook PC (M45-S169). I've tried everything I can think of. IE will
    connect if I use a wired connection but it will not connect to the net over
    the wireless although the wireless is pulling an IP and DNS.

    Anybody have a clue as to what this could be? Thanks!
    Guest, Dec 21, 2005
    1. Advertisements

  3. Try:

    1. ping If this works, you have Internet connectivity.

    2. ping If this works, you have DNS name resolution.

    3. If #1 and #2 work, the problem is probably with IE - make sure that no
    proxy server is configured and clear the check box for Automatically detect
    settings in LAN settings on the Connections tab.

    4. If #1 doesn't work, check your router/firewall settings to make sure the
    laptop is not being blocked from Internet access.

    5. If #1 works, but #2 does not; the problem is DNS. Run ipconfig /all and
    see what your DNS setting is - probably should be Make sure
    the local Area Connection is set to obtain both IP and DNS automatically -
    or configure everything manually.

    Doug Sherman
    Doug Sherman [MVP], Dec 21, 2005
  4. Guest

    Guest Guest

    Thanks for the suggestions. I've determined that I have internet
    connectivity, but do not have DNS name resolution (i.e. #1 works, but #2 does
    not). I ran ipconfig /all and received the following read out (connection

    Physical Address 00-13-CE-78-CC-3E
    Dhcp enabled: Yes
    Auto config enabled: Yes
    IP Address:
    Subnet Mask:
    Default gateway:
    DHCP Server:
    DNS Server:

    I followed your suggestion and made sure that my local area connection was
    set to obtain both IP and DNS automatically. However, the DNS name
    resolution problem persists.

    (1) How can I configure DNS manually. Do I need to put DNS entrys in my
    router set-up then make sure that my local area network (on my PC) is set to
    go to those manual addresses?
    (2) When I examine my ipconfig /all read out (above), I see that my DHCP
    server is (which is my linksys router) and the DNS server is (which is my Actiontec DSL modem). So, the router seems to be
    managing DHCP, while the modem is managing DNS. Should I experiment with
    turning OFF the DHCP/DNS functionality of the DSL modem, thus forcing that
    function onto my linksys router. I'm starting to suspect that my problem
    could be the result of both my router and my DSL modem trying to control DHCP
    and DNS functions. Could this be correct?
    Thanks again for your help.
    Guest, Dec 23, 2005
  5. Guest

    Joe Guest

    My IPS had specific instructions on how to set up the router to work with
    them. It also included DNS addresses to be set in the Pc. I had to manually
    set an IP address in my desktop, and set the modem to disable the ppp. ppp
    had to be set in the router.

    Check the website for your Isp and see if they can provide info.



    Joe, Dec 24, 2005
  6. There is definitely something unusual here. It looks to me like your modem
    is actually a router. Try:

    1. run ipconfig /all on the desktop and see what its DNS setting is.

    2. If the desktop has something other than listed, manually
    configure tCP/IP on the laptop - use all of the existing settings except
    change DNS to match the desktop.

    3. If #2 does not work, determine your ISP's DNS server - you may have to
    call them to do this. Use the IP address of this server in the DNS setting
    on your laptop.

    Doug Sherman
    Doug Sherman [MVP], Dec 24, 2005
  7. Guest

    Guest Guest

    Doug (and Joe),
    Thanks for your suggestions. They solved my problem. In the end, I had to
    put my ISP's DNS server IP address directly into my laptop's configuration.
    (Doug's suggestion #3). That did it.
    Thanks again and happy holidays.
    Guest, Dec 24, 2005
  8. Guest

    Guest Guest


    I was using the Linksys router with my laptop as well, had connection, but
    could not view pages. Are you using the Norton Internet Security that comes
    with this router? If so, I solved my issue by going to the settings in
    Norton, and if you are using cable access, change the Inbound NETBIOS name in
    the advanced firewall settings to "permit" I was then able to view pages. In
    fact, the Norton help suggests this as a fix. Hope this helps.
    Guest, Mar 13, 2006
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.