A pattern emerging for wireless and SP2

Discussion in 'Wireless Networking' started by Jonathan Eales, Sep 22, 2004.

  1. I've upgraded a number of my client's systems with Windows XP SP2 recently,
    both desktops and laptops usually without problems. However all those who
    had existing secured (WEP 64-bit) WLANs have not worked with WZC. I've had
    to fall back to the wireless cards utility in each case and stop WZC
    managing the wireless connection. In all cases this has worked.

    Different cards, PCI and PCMCIA from different vendors (3com, Belkin,
    Linksys, Safecom, etc.) all had the same effect with WZC. All could see the
    wireless network but could not acquire network address through DHCP.

    Disable security and WZC works fine. But who wants an unsecured WLAN?

    What gives with wireless and SP2 or am I doing something wrong?

    All systems are periodically checked with anti-virus and spy/adware

    Jonathan Eales, Sep 22, 2004
    1. Advertisements

  2. Jonathan Eales

    Jeff Durham Guest

    Here would be something interesting to try. Delete/uninstall the wireless
    adapter including removal of the device prior to installing SP2. Install
    SP2, re-add the wireless adapter and driver. It would be interesting to see
    if this makes any difference.

    Jeff Durham, Sep 22, 2004
    1. Advertisements

  3. Jonathan Eales

    Txl Guest


    By playing on 3 computyer only I have made it working this way :

    1) remove WZC
    2) Use card's config tools to make it running unsecured
    3) Add WEP

    Don't forget to reboot between each step and make sure upon each reboot
    that the WZC is not running, yoiu can run netstumbler because it also
    shuts down the WZC.

    Bottom line is DON'T USE THE WZC !!!

    Good luck and good hunting
    Txl, Sep 22, 2004
  4. Jonathan Eales

    TW Guest

    I have an HP 2600+ with Dlink G520 using WZC, connecting to a Dlink G624
    router. It all works fine. Before I installed SP2 I upgraded the firmware
    for the card and updated the drivers from their website. Before SP2, WZC
    wouldn't work very well and I used the Dlink utility.

    Strange but I helped a friend with a similar setup with a new HP one year
    newer than mine and the same card. I updated his to SP2 and his mouse would
    freeze when using WZC. When I turn this off and used the Dlink utility the
    mouse is works fine. On this setup I didn't updated the firmware or drivers
    yet, but I will do this in the next couple of days. I will post back with my
    finding after the updates.
    TW, Sep 23, 2004
  5. I tried this, even adding a different make of wireless card, and it didn't
    work. Loaded the WLAN card Utility, turn off WZC, and bingo I get full
    connectivity immediately. I've done this in so many systems now that I'm
    convinced that there is something seriously broken with Wireless in Windows
    XP SP2.

    When you install the card and just load the driver from the CD, it installs
    well but WZC doesn't manage the connection completely. It fails on
    'acquiring network address'. Running the CD's Setup program and disabling
    WZC works every time.

    Jonathan Eales, Sep 25, 2004
  6. Jonathan Eales

    Pavel A. Guest

    Well, if you're serious about investigating it -
    the checked build of WZCSVC provides debug log where it is supposed to
    trace all it's actions. How to get checked build of SP2 and enable this trace, you can find
    in the KB.

    Pavel A., Sep 25, 2004
  7. Jonathan Eales

    ?fooguy? Guest

    Let me throw my hat into the ring:

    ABIT NF7-2 MB with VIA chipset and an Athon CPU. Reinstalled XP from
    scratch, updated to SP2, installed the D-Link drivers for my DWL-G520
    and the system reboots constantly. I removed the G520 and switched to
    a regular 520 and the system reboots, but not nearly as often. This is
    connecting to a DI-624 AP. This whole setup replaces my D-Link 802.11a
    setup that I had previously and didn't have these kinds of problems
    with. I suspect a problem with the drivers but I have no way to
    confirm it (other than, if I plug my DWL-810+ into the ethernet jack
    the system never reboots). I should mention that I reinstalled a
    couple times and saw this behavior without an SP, SP1, and SP2.

    There does not seem to be a firmware update for my rev of the card
    (V.B1). I am using 128bit WEP, perhaps I should try turning WEP off to
    see if that's the cause?
    ?fooguy?, Oct 4, 2004
  8. Jonathan Eales

    DrBol Guest

    I have had the same problem, after installing SP2 using a Belkin 11
    wireless network. After a while the client gets stuck "acquiring
    network address". The Repair-option solves the problem, but only for
    while. The solution to the problem is a fix for SP2 provided b
    Microsoft. For details look a
    http://www.pchell.com/support/limitedconnectivity.shtml. Using WP
    works fine now.

    DrBol, Nov 2, 2004
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.