836 as an ISDN router > HELP : process_bri_call: Outgoing call id 0x8 004 blocked

Discussion in 'Cisco' started by Thierry, Jan 23, 2004.

  1. Thierry

    Thierry Guest

    Hi,

    We need urgent help. We have a Cisco 836 (DSLoISDN) that we want to
    use only as an ISDN router to an ISP. (the ISP part works fine).

    The config seems to fine (we tried most of it on a 801 from the same
    ISDN plug, and it worked fine, and we try the ISP connexion with a
    ISDN adapter, it also works fine.).

    Then trouble is that on the 836, when we try to go "out" (internet),
    we get the following output :
    (debug isdn q931) :

    *Mar 1 00:37:51.259: ISDN BR0 **ERROR**: process_bri_call: Outgoing
    call id 0x8 004 blocked
    *Mar 1 00:37:51.259: ISDN BR0 **ERROR**: UserIdle: process_bri_call
    failed on c all to 0860840101.....

    We checked the ISDN part (extract just below) and it seems to be fine.

    xxx#show isdn status
    Global ISDN Switchtype = vn3
    ISDN BRI0 interface
    dsl 0, interface ISDN Switchtype = vn3
    Layer 1 Status:
    ACTIVE
    Layer 2 Status:
    TEI = 81, Ces = 1, SAPI = 0, State =
    MULTIPLE_FRAME_ESTABLISHED
    Layer 3 Status:
    0 Active Layer 3 Call(s)
    Active dsl 0 CCBs = 0
    The Free Channel Mask: 0x80000003
    Total Allocated ISDN CCBs = 0
    xxx#
    --------------------

    Here's the result of the same operation + debug isdn q921 + debug isdn
    events

    *Mar 1 00:11:18.211: ISDN BR0 Q921: User TX -> RRp sapi=0 tei=83 nr=0
    *Mar 1 00:11:18.227: ISDN BR0 Q921: User RX <- RRp sapi=0 tei=83 nr=0
    *Mar 1 00:11:18.227: ISDN BR0 Q921: User TX -> RRf sapi=0 tei=83 nr=0
    *Mar 1 00:11:18.235: ISDN BR0 Q921: User RX <- RRf sapi=0 tei=83 nr=0
    *Mar 1 00:11:19.315: BR0 DDR: rotor dialout [priority]
    *Mar 1 00:11:19.315: BR0 DDR: Dialing cause ip (s=10.149.7.97,
    d=194.4.56.1)
    *Mar 1 00:11:19.315: BR0 DDR: Attempting to dial 0860840101
    *Mar 1 00:11:19.315: ISDN BR0 EVENT: UserIdle: callid 0x8002 received
    ISDN_CALL (0x0)
    *Mar 1 00:11:19.319: ISDN BR0 **ERROR**: process_bri_call: Outgoing
    call id 0x8002 blocked
    *Mar 1 00:11:19.319: ISDN BR0 **ERROR**: UserIdle: process_bri_call
    failed on call to 0860840101.....
    *Mar 1 00:11:28.235: ISDN BR0 Q921: User TX -> RRp sapi=0 tei=83 nr=0
    *Mar 1 00:11:28.235: ISDN BR0 Q921: User RX <- RRp sapi=0 tei=83 nr=0
    *Mar 1 00:11:28.239: ISDN BR0 Q921: User TX -> RRf sapi=0 tei=83 nr=0
    *Mar 1 00:11:28.255: ISDN BR0 Q921: User RX <- RRf sapi=0 tei=83 nr=0
    *Mar 1 00:11:38.255: ISDN BR0 Q921: User RX <- RRp sapi=0 tei=83 nr=0
    *Mar 1 00:11:38.255: ISDN BR0 Q921: User TX -> RRp sapi=0 tei=83 nr=0
    *Mar 1 00:11:38.255: ISDN BR0 Q921: User TX -> RRf sapi=0 tei=83 nr=0
    *Mar 1 00:11:38.275: ISDN BR0 Q921: User RX <- RRf sapi=0 tei=83 nr=0
    *Mar 1 00:11:48.275: ISDN BR0 Q921: User TX -> RRp sapi=0 tei=83 nr=0
    *Mar 1 00:11:48.283: ISDN BR0 Q921: User RX <- RRp sapi=0 tei=83 nr=0
    *Mar 1 00:11:48.283: ISDN BR0 Q921: User TX -> RRf sapi=0 tei=83 nr=0
    *Mar 1 00:11:48.291: ISDN BR0 Q921: User RX <- RRf sapi=0 tei=83 nr=0
    *Mar 1 00:11:49.315: BRI0: wait for isdn carrier timeout, call
    id=0x8002
    *Mar 1 00:11:49.315: ISDN BR0 EVENT: UserIdle: callid 0x8002 received
    ISDN_HANGUP (0x1)
    *Mar 1 00:11:49.315: ISDN BR0 **ERROR**: CCBRI_Go: NO CCB Src->HOST
    call id 0x8002, event 0x5 ces 1
    *Mar 1 00:11:49.315: ISDN BR0 EVENT: process_rxstate: ces/callid
    1/0x8002 calltype 1 HOST_QUERY_RESPONSE
    *Mar 1 00:11:58.295: ISDN BR0 Q921: User TX -> RRp sapi=0 tei=83 nr=0
    *Mar 1 00:11:58.323: ISDN BR0 Q921: User RX <- RRf sapi=0 tei=83 nr=0
    *Mar 1 00:12:08.303: ISDN BR0 Q921: User RX <- RRp sapi=0 tei=83 nr=0
    *Mar 1 00:12:08.307: ISDN BR0 Q921: User TX -> RRf sapi=0 tei=83 nr=0

    Please help ! What have we done wrong ?

    Here's the config !

    version 12.2
    no parser cache
    no service pad
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname xxxxxx
    !
    enable secret 5 <removed>
    enable password <removed>
    !
    username remote password 0 <removed>
    ip subnet-zero
    !
    ip urlfilter alert
    ip audit notify log
    ip audit po max-events 100
    isdn switch-type vn3
    isdn tei-negotiation first-call
    !
    interface Ethernet0
    ip address 10.149.7.97 255.255.255.224
    ip nat inside
    no cdp enable
    !
    interface BRI0
    no ip address
    encapsulation ppp
    dialer pool-member 1
    dialer pool-member 2
    isdn switch-type vn3
    no cdp enable
    ppp authentication chap pap callin
    !
    interface ATM0
    no ip address
    shutdown
    no atm ilmi-keepalive
    dsl operating-mode auto
    !
    interface Dialer1
    description CONNECTION VERS EASYNET
    ip address negotiated
    ip nat outside
    encapsulation ppp
    dialer pool 1
    dialer remote-name easynet
    dialer idle-timeout 180
    dialer string 0860840101
    dialer-group 1
    no cdp enable
    ppp authentication chap pap callin
    ppp chap hostname xxxxxx
    ppp chap password 0 xxxx
    ppp pap sent-username xxxxxx password 0 xxxx
    !
    interface Dialer2
    description Connexion vers Londres
    ip unnumbered Ethernet0
    no ip proxy-arp
    encapsulation ppp
    no ip split-horizon
    dialer pool 2
    dialer remote-name xxxxxx
    dialer idle-timeout 180
    dialer string xxxxxx
    dialer-group 1
    no cdp enable
    ppp authentication chap callin
    !
    ip nat inside source list 102 interface Dialer1 overload
    ip classless
    ip route 0.0.0.0 0.0.0.0 Dialer1
    ip route 10.149.7.0 255.255.255.224 Dialer2
    no ip http server
    no ip http secure-server
    !
    !
    access-list 102 remark ACL de NAT
    access-list 102 deny ip 10.149.7.96 0.0.0.31 192.168.16.0 0.0.0.255
    access-list 102 deny ip 10.149.7.96 0.0.0.31 10.148.0.0 0.0.255.255
    access-list 102 permit ip 10.149.7.96 0.0.0.31 any
    dialer-list 1 protocol ip permit
    no cdp run
    !
    line con 0
    exec-timeout 3 0
    stopbits 1
    line vty 0 4
    exec-timeout 3 0
    password <removed>
    login
    !
    scheduler max-task-time 5000
    !
    end
     
    Thierry, Jan 23, 2004
    #1
    1. Advertisements

  2. Hi there,

    might be a license issue. AFAIK the BRI Interface is only fully functional when using the
    +Dialbackup IOS image on the 836.


    Regards,
    Stefan
     
    Stefan Dambeck, Jan 27, 2004
    #2
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.