64-bit vs 32-bit Remote Desktop Connections

Discussion in 'Windows 64bit' started by David L. West, Jan 12, 2007.

  1. I have a small LAN with one 64-bit XP workstation with the rest XP Pro.
    Remote Desktop is enabled on all machines. The 64-bit box can RDC to other
    workstations, but other workstations can't RDC to it. Firewall is off,
    machine is pingable, and I can find no reason this shouldn't work.
     
    David L. West, Jan 12, 2007
    #1
    1. Advertisements

  2. David L. West

    Aaron Kelley Guest

    I do this all the time and it works fine... Shouldn't be a 32-bit/64-bit
    issue.
    Only thing I can think of is, you did enable incoming remote desktop
    connections in the System control panel?

    - Aaron
     
    Aaron Kelley, Jan 12, 2007
    #2
    1. Advertisements

  3. David L. West

    NuTCrAcKeR Guest

    it may also be necessary to enable RDP on all network interfaces. I ran into
    a problem once where I had it set to listen on a particular NIC, and then i
    replaced the NIC sometime later, and I couldnt RDP to the server.

    - NuTs
     
    NuTCrAcKeR, Jan 12, 2007
    #3
  4. Yep, that's what I meant by "Remote Desktop is enabled...". I also verified
    that it's listening on port 3389 via a "netstat -an" command.
     
    David L. West, Jan 12, 2007
    #4
  5. David L. West

    Aaron Kelley Guest

    What error do you get? Just something indicating that there is no machine
    at that address?

    Can you establish a telnet connection to the x64 machine on port 3389? Go
    to a command prompt and type
    telnet [x64 machine's address] 3389

    If the whole command window goes black, then the connection worked, but it
    if gives you a connection error, there is some network connectivity/firewall
    issue preventing you from connecting to the x64 machine and remote desktop
    will not work.

    - Aaron
     
    Aaron Kelley, Jan 13, 2007
    #5
  6. Is your 64bit machine using an nvidia chipset? If so, please follow these
    instructions:
    ===
    Known Problem:
    Unfortunately, the built in nVidia firewall product appears to install at
    least some portion of itself even if you've never chosen to install it. And
    this appears to interfere with 32-bit programs. The solution is to install
    the firewall program if it isn't already installed, and then uninstall it.
     
    Charlie Russel - MVP, Jan 13, 2007
    #6
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.