5.1, MMDriver.inf and Machine check error

Discussion in 'Windows 64bit' started by max_e_mum, Dec 15, 2006.

  1. max_e_mum

    max_e_mum Guest

    I have been having a load of (non) fun over the last couple of days,
    just when I thought I had this second re-build working it turns out
    it's not.

    I've just bought the Emu 1820m Sound-Card and wanted to test getting
    a 5.1 output from Windows Media Player (WMP). While following the
    instructions found in the http://www.productionforums.com forums =
    Tools/Options/Devices/Speakers/Properties and make sure that
    DirectSound is selected (though I'm not sure at this point as that I
    have two DirectSound choices - as well as the default there is an
    E-DSP Wave [BCE0] version. (I've tried both) , anyways, when I
    clicked on advanced it came up that the MMDriver.inf file was missing,
    yet I could see it clear as day sitting in my system32 directory -
    where it was supposed to be. So I searched this fault and found many
    people had posted copies in the groups, which I copied into my system32
    folder after changing the name of the original .inf to .old.
    I even put a copy into my WOW64 directory.
    Nothing seemed to be working, so I went into Programs (rightclick) My
    Computer/manage/eventviewer/system and found a WMIxWDM Errors 120, 122,
    123, Machine Check Event reported is a fatal bus or interconnect error.
    So off I went down this road and read how many people said memory is
    bad or CPU is bad. My ram is brand new Corsair - the stuff that they
    So I started poking around in my bios, tried turning ECC on again,
    turned chipkill off and searched to find out what the 4 or 8 beat burst
    was all about. The side panel in my bios said that 64 bit Dq must use 4
    beats - and I had it on the 4 because (in my mind) I was running 64
    bit. It turns out that 64 bit Dq is single channel memory, so I changed
    my bios to 8 beats and rebooted and no more WMIxWDM errors.
    It also turns out that this error is the machine saying it found a
    problem, but it has fixed it.
    I notice today that it is still happening at boot, but not on warm

    Back to the MMDriver issue, at Free Codecs.com I found a tute telling
    how to load the MMDriver.inf, titled "How to (re)install Default Codecs
    in Windows XP/2000. "

    1. Choose Start > Control Panel and click Add hardware, then click Next
    from Add Hardware Wizard.
    Click "Yes, I have already connected the hardware" then click Next
    button, again.

    2. Choose Add a new hardware device at the bottom of the list and click
    Select "Install the hardware that I manually select from a list
    (Advanced)", and click Next.

    3. Select "Sound, video and game controllers" from "Common hardware
    types" list and click Next.
    Select "(Standard system devices)" from "Manufacturer" and click Have
    Disk... button.

    4. Click Browse in the Install From Disk dialog box and open the folder
    Find mmdriver.inf file, select it and click Open then click OK in the
    Install From Disk dialog box. If you see a warning about logo
    compatibility, just click "Continue Anyway".

    5. Now you should finally see a list of audio codecs.

    But I didn't, I got a new error message, "The specified location does
    not contain a compatible software driver for your device. If the
    location contains a driver, make sure it is designed to work with
    windows for x64based systems."
    I got to thinking that maybe this copy of XP 64bit that I bought from
    an online retailer who I had dealt with many times had sold me a
    pirated copy.
    So I dug deeper on this MMDriver thing, turning up at Microsoft to read

    "Microsoft Windows Server 2003 x64 editions and Microsoft Windows XP
    Professional x64 Edition require that OEM device driver .inf files
    specify a TargetOsVersion entry in the [Manufacturer] section and in
    the [Models] section for the following 64-bit computer platforms "

    "Note The .NTamd64 decoration in the following .inf file excerpt is
    used for all AMD64 or EM64T platforms. Conversely, the .NTia64
    decoration is used for Intel Itanium platforms.
    %mycompany% = MyCompanyModels, NTamd64

    %MyDev% = mydevInstall, mydevHwid "

    Now if you look at the MMDriver.inf you will see no decorations like
    above, which makes me suspicious about my copy of x64, or that
    Microsoft don't do what they say needs to be done.

    Further down the page I found

    "Installing Undecorated INFs on X64-based Systems
    The following workarounds can be used to install undecorated INFs on
    x64-based systems. These workarounds are intended only for use on test
    systems and are not recommended for production drivers.
    Method 1. Turn off the undecorated models check for AMD64. To turn off
    the undecorated models check for AMD64-based systems only, create the
    following non-zero numeric registry value:

    REG_DWORD: DisableDecoratedModelsRequirement

    Set the key to a non-zero value (such as 1) and restart the system,
    then install the driver. "

    Now running the free-codecs install worked, but what do I need to load?

    [note: I just installed Microsoft ADPCM CODEC, but SiSandra still only
    shows 1 channel]
    choices are
    [MCI] CD Audio
    [MCI] Microsoft Video for Windows
    [MCI] Midi Sequencer
    [MCI] Sound
    Cinepak Codec by Radius Inc
    DSP Group TrueSpeech Audio Codec
    IMA ADPCM Audio codec
    Microsoft ADPCM Audio Codec
    Microsoft Audio Compression Manager
    Microsoft CCIT G.711 Audio Codec
    Microsoft GSM 6.10 Audio Codec
    Microsoft RLE Codec
    Microsoft Video 1
    Midi Mapper

    On this OS install I did not load the AMD Driver Pack, it seems that I
    have to load the setup_8131.exe first to get the amdpci64 filter
    loaded, because the driver pack asks for this sys file which is not
    anywhere else in the machine.
    I've tried loading the amdapic64 but I get an error that I have no
    supported hardware.

    I'd want to think that the OS has the chipset drivers etc

    My system specs are
    MSI 9131
    Dual 248
    Primary drive is 80GB WD
    On PCI-X slot 1 is RocketRaid 2224 with 2xSamsung 250GB SATA-II drives
    set in Raid_0
    In PCI slot_1 Emu sync card, PCI slot_2 Emu 1010 card, PCI-X slot 2
    VisionTek (ATI) X1300 VGA, PCI-X slot 3 VisdionTek Theatre 550
    Com and printer ports turned off in BIOS
    Enermax Liberty 500w power supply
    Antec Titan case
    Rounded cables

    SiSoftware Sandra

    Host Name : XXXXXXXXXXX

    Model : 2x AMD Opteron(tm) Processor 248
    Speed : 2.19GHz
    Model Number : 3490 (estimated)
    Performance Rating : PR7894 (estimated)
    Cores per Processor : 1 Unit(s)
    Threads per Core : 1 Unit(s)
    Internal Data Cache : 64kB Synchronous, Write-Back, 2-way set, 64 byte
    line size
    L2 On-board Cache : 1MB ECC Synchronous, Write-Back, 16-way set, 64
    byte line size

    Bus(es) : ISA PCI PCIe IMB USB FireWire/1394 i2c/SMBus
    MP Support : 2 Processor(s)
    MP APIC : Yes
    NUMA Support : 2 Node(s)
    System BIOS : American Megatrends Inc. 080008
    System : MSI MS-9131
    Mainboard : MSI MS-9131
    Total Memory : 3GB DDR-SDRAM Registered

    Chipset 1
    Model : Advanced Micro Devices (AMD) Athlon 64 / Opteron HyperTransport
    Technology Configuration
    Front Side Bus Speed : 2x 796MHz (1592MHz data rate)
    Total Memory : 2GB DDR-SDRAM Registered
    Memory Bus Speed : 2x 199MHz (398MHz data rate)

    Chipset 2
    Model : Advanced Micro Devices (AMD) Athlon 64 / Opteron HyperTransport
    Technology Configuration
    Front Side Bus Speed : 2x 796MHz (1592MHz data rate)
    Total Memory : 1GB DDR-SDRAM Registered
    Memory Bus Speed : 2x 199MHz (398MHz data rate)

    Video System
    Monitor/Panel : Plug and Play Monitor
    Adapter : Standard VGA Graphics Adapter
    Adapter : Radeon X1300 Series
    Adapter : Radeon X1300 Series Secondary

    Physical Storage Devices
    Removable Drive : Floppy disk drive
    Hard Disk : WDC WD800JB-00JJC0 (75GB)
    Hard Disk : HPT DISK 0_0 SCSI Disk Device (466GB)
    CD-ROM/DVD : LITE-ON LTR-52327S (CD 52X Rd, 52X Wr)

    Logical Storage Devices
    Hard Disk (C : 29GB (23GB, 78% Free Space) (NTFS)
    Store (D : 45GB (44GB, 97% Free Space) (NTFS)
    Raid Capture (E : 466GB (459GB, 99% Free Space) (NTFS)
    ARMPXOEM_EN (F : 559MB (CDFS) ***
    my x64 disk
    3.5" 1.44MB (A : 1.4MB (1.1MB, 83% Free Space) (FAT)

    USB Controller/Hub : AMD PCI to USB Open Host Controller
    USB Controller/Hub : AMD PCI to USB Open Host Controller
    USB Controller/Hub : USB Root Hub
    USB Controller/Hub : USB Root Hub
    FireWire/1394 Controller/Hub : OHCI Compliant IEEE 1394 Host Controller

    Keyboard : Standard 101/102-Key or Microsoft Natural PS/2 Keyboard
    Mouse : Microsoft PS/2 Mouse

    MultiMedia Device(s)
    Device : ATI Unified AVStream Driver
    Device : E-MU E-DSP

    Power Management
    AC Line Status : On-Line

    Operating System(s)
    Windows System : Microsoft Windows XP/2003 Professional x64 Edition
    5.02.3790 (Service Pack 1)

    Network Services
    Adapter : Broadcom NetXtreme Gigabit Ethernet
    Adapter : Broadcom NetXtreme Gigabit Ethernet #2 (not connected)

    Any help would be apprechiated, TIA

    max_e_mum, Dec 15, 2006
    1. Advertisements

  2. This is much too specific that I can be of any immediate help? Great piece
    of investigative work though.

    You should try and insert the decorations to the .INF file manually and see
    what happens. Somewhere near the top as I remember. Your OS version: It is
    hardly a pirated copy, it could be one of the RC's - the decoration
    requirement came about rather late, and quite unexpected. If so, it is
    hardly completely legal either, as these early versions were not slated for
    distribution from non-microsoft sources.

    The finished product is an OEM version, by then the requirement was well
    established, and this version was not distributed by MS. The opposite goes
    for the Beta's and RC's and the Trial version, as those aren't actual
    products at all.

    Tell your dealer, in the friendliest tone of voice that you can muster, that
    if you ever hear from the MS legal department you know where to point your
    finger, there's a chance it would trigger some creative thinking?

    Tony. . .
    Tony Sperling, Dec 16, 2006
    1. Advertisements

  3. max_e_mum

    max_e_mum Guest

    I did a what I will call a fake media encoding last night, I encoded a
    5.1 channel video sequence and in Windows media player while the video
    is playing under file/properties it states 5.1 channels.
    Fake= I set the 1820m up with an ADAT in [I have no adat equipment
    sending a signal], but the encoder sees the multichannel inputs.
    max_e_mum, Dec 17, 2006
    1. Advertisements

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.
Similar Threads
  1. =?Utf-8?B?Sm9obg==?=

    Xp machine causes ME machine to get error 'unable to browse networ

    =?Utf-8?B?Sm9obg==?=, Nov 30, 2005, in forum: Wireless Networking
    Ryan Younger
    Dec 1, 2005
  2. Dave_s
    Apr 1, 2006
  3. Dave F.
    Dave F.
    Apr 23, 2006
  4. ex-Zephion

    Port 6667 &

    ex-Zephion, Sep 18, 2003, in forum: Computer Security
    Sep 19, 2003
  5. Siddhartha Jain

    Canon 100-300mm f/4.5-5.6 vs Tokina 80-400mm f/4.5-5.6

    Siddhartha Jain, Jan 17, 2005, in forum: Digital Photography
    Phil Wheeler
    Jan 17, 2005
  6. Siddhartha Jain

    Canon 100-300mm f/4.5-5.6 vs Tokina 80-400mm f/4.5-5.6

    Siddhartha Jain, Jan 17, 2005, in forum: Digital Photography
    Gautam Majumdar
    Jan 17, 2005
    Dec 15, 2010
  8. =?Utf-8?B?Sm9obiBEeWVy?=

    Win32 install error "for a machine type other than current machine

    =?Utf-8?B?Sm9obiBEeWVy?=, May 8, 2007, in forum: Windows 64bit
    John Barnes
    May 10, 2007