3x Cisco 1841 and GRE tunnels through Internet

Discussion in 'Cisco' started by DH3JHZ, Jul 9, 2007.

  1. DH3JHZ

    DH3JHZ

    Joined:
    Jul 9, 2007
    Messages:
    1
    Likes Received:
    0
    Hi *.*!

    Cause I am not the Cisco specialist, I googled around and found this incredible forum. May be there is someone out there who has no problem with the configuration I need:

    I have a typical star infrastructure, a central router and several (actually only 2) remote stations. All type Cisco 1841.
    We have on all sites a DSL line with external DSL modem which comes from the provider so we need to "dial-in" with PPPoE and the appropriate credentials.

    I tested the GRE tunnel in a testing environment by connecting 2 routers 1841 with a crosswired cable back to back. Between the routers only GRE traffic flows (cause this is the part which has to go over the internet)

    I tried the following config but I have no idea how to implement the Dialer interface on the WAN side to dial in to the provider using PPPoE!??!

    Code:
    !
    version 12.4
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname AABBCC
    !
    boot-start-marker
    boot-end-marker
    !
    no logging console
    enable password XYZ
    !
    no aaa new-model
    !
    resource policy
    !
    mmi polling-interval 60
    no mmi auto-configure
    no mmi pvc
    mmi snmp-timeout 180
    ip subnet-zero
    ip cef
    !
    !
    no ip dhcp use vrf connected
    no ip dhcp conflict logging
    !
    ip dhcp pool pool1
       network 172.16.1.0 255.255.255.0
    !
    !
    no ip domain lookup
    ip multicast-routing 
    !
    !
    interface Tunnel3
     ip unnumbered FastEthernet0/1
     ip mtu 1440
     ip pim sparse-mode
     ip igmp version 3
     keepalive 10 3
     tunnel source FastEthernet0/0
     tunnel destination 192.168.151.4 (WHICH IS THE DESIGNATED INTERNET SIDE!)
    !
    interface FastEthernet0/0
     ip address 192.168.151.2 255.255.255.0
     duplex auto
     speed auto
     no cdp enable
    !
    interface FastEthernet0/1
     ip address 172.16.1.1 255.255.255.0
     ip pim sparse-mode
     ip igmp version 3
     duplex auto
     speed auto
     no cdp enable
    !
    ip classless
    ip route 0.0.0.0 0.0.0.0 Tunnel3
    !
    ip http server
    no ip http secure-server
    ip pim bidir-enable
    ip pim rp-address 172.16.1.1
    !
    no cdp run
    !
    So as you could see the interface FE0/0 is the one which faces to the external DSL modem and the FE0/1 is the one which faces to the internal LAN.

    Does anyone how to establish this config with a PPPoE and an external DSL modem? :?:
     
    DH3JHZ, Jul 9, 2007
    #1
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.