3750 no answer TTL Time exceeded

Discussion in 'Cisco' started by its.a.user, Oct 11, 2007.

  1. its.a.user

    its.a.user Guest

    Hi,
    i have a 3750G Stack with iBGP enabled. Routing works fine, but there is
    no answer from this Switch if the TTL=0. e.g. if i traceroute over this
    switch. With Linux or Windows its the same effect (traceroute udp/icmp).
    There are about 1000 routes learned by BGP. CPU is 14 %.
    What can it be.

    Thanks
    a.user
     
    its.a.user, Oct 11, 2007
    #1
    1. Advertisements

  2. its.a.user

    Merv Guest


    If the packet received by a device has a TTL = zero it must discard
    the packet and it may or may not send an ICMP packet ( i.e it is okay
    to silently discard).
     
    Merv, Oct 12, 2007
    #2
    1. Advertisements

  3. its.a.user

    its.a.user Guest

    it seems the switch discard silently, but why. Is there an option, i can
    force to send ICMP TTL time exceede? With mtr i have about 80% packet
    lost on this hop, all other hops has 0% packet lost.
     
    its.a.user, Oct 13, 2007
    #3
  4. its.a.user

    Merv Guest

    There is probably nothing thant can be done.

    Why are the traceroute packets being send with TTL= 0 ???


    Post toutput for:

    show version

    sh ip interface <ingress interface on which traceroute packets are
    being received>

    sh run interface <same as above>
     
    Merv, Oct 14, 2007
    #4
  5. Can you post SVI configuration? If there is "no ip unreachables" that
    would be the answer.

    Regards,
    Andrey.
     
    Andrey Tarasov, Oct 14, 2007
    #5
  6. its.a.user

    its.a.user Guest

    indeed there is "no ip redirects" configured on SVI, that enables icmp
    messages. I enabled ip redirects, but no effects.
    ip unreachables was enabled.
    regards
    a.user
     
    its.a.user, Oct 17, 2007
    #6
  7. its.a.user

    its.a.user Guest

    2 3750 in a Stack.

    C3750-IPSERVICESK9-M), Version 12.2(35)SE2

    GigabitEthernet1/0/24 is up, line protocol is up (connected)
    Hardware is Gigabit Ethernet, address is 001b.5392.1d98 (bia
    001b.5392.1d98)
    Description: CE1_main
    MTU 1500 bytes, BW 1000000 Kbit, DLY 10 usec,
    reliability 255/255, txload 3/255, rxload 3/255
    Encapsulation ARPA, loopback not set
    Keepalive set (10 sec)
    Full-duplex, 1000Mb/s, media type is 10/100/1000BaseTX
    Media-type configured as connector
    input flow-control is off, output flow-control is unsupported
    ARP type: ARPA, ARP Timeout 04:00:00
    Last input 00:00:24, output 00:00:04, output hang never
    Last clearing of "show interface" counters never
    Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
    Queueing strategy: fifo
    Output queue: 0/40 (size/max)
    5 minute input rate 13674000 bits/sec, 3548 packets/sec
    5 minute output rate 13583000 bits/sec, 2313 packets/sec
    82460951604 packets input, 27395949469315 bytes, 0 no buffer
    Received 537419 broadcasts (0 multicasts)
    0 runts, 0 giants, 0 throttles
    0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
    0 watchdog, 218891 multicast, 0 pause input
    0 input packets with dribble condition detected
    55306780192 packets output, 54191595455625 bytes, 0 underruns
    0 output errors, 0 collisions, 4 interface resets
    0 babbles, 0 late collision, 0 deferred
    0 lost carrier, 0 no carrier, 0 PAUSE output
    0 output buffer failures, 0 output buffers swapped out
    GigabitEthernet2/0/24 is up, line protocol is up (connected)
    Hardware is Gigabit Ethernet, address is 001b.53d1.a898 (bia
    001b.53d1.a898)
    Description: CE2_main
    MTU 1500 bytes, BW 1000000 Kbit, DLY 10 usec,
    reliability 255/255, txload 1/255, rxload 1/255
    Encapsulation ARPA, loopback not set
    Keepalive set (10 sec)
    Full-duplex, 1000Mb/s, media type is 10/100/1000BaseTX
    Media-type configured as connector
    input flow-control is off, output flow-control is unsupported
    ARP type: ARPA, ARP Timeout 04:00:00
    Last input 00:00:47, output 00:00:00, output hang never
    Last clearing of "show interface" counters never
    Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
    Queueing strategy: fifo
    Output queue: 0/40 (size/max)
    5 minute input rate 87000 bits/sec, 10 packets/sec
    5 minute output rate 6637000 bits/sec, 1228 packets/sec
    2054239383 packets input, 1608112747890 bytes, 0 no buffer
    Received 537368 broadcasts (0 multicasts)
    0 runts, 0 giants, 0 throttles
    0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
    0 watchdog, 218894 multicast, 0 pause input
    0 input packets with dribble condition detected
    42813921870 packets output, 39026119571497 bytes, 0 underruns
    0 output errors, 0 collisions, 2 interface resets
    0 babbles, 0 late collision, 0 deferred
    0 lost carrier, 0 no carrier, 0 PAUSE output
    0 output buffer failures, 0 output buffers swapped out

    interface GigabitEthernet1/0/24
    description CE1_main
    switchport access vlan 41
    switchport mode access
    spanning-tree bpduguard disable
    end

    interface GigabitEthernet2/0/24
    description CE2_main
    switchport access vlan 41
    switchport mode access
    spanning-tree bpduguard disable
    end

    interface Vlan41
    description Transport-main
    ip address 10.2.7.66 255.255.255.240
    no ip redirects
    standby 10 ip 10.2.7.65
    standby 10 priority 150
    end
     
    its.a.user, Oct 17, 2007
    #7
  8. its.a.user

    Merv Guest

    check if icmp unreachables has been disabled on interface vlan 41

    show ip interface vlan 41
     
    Merv, Oct 18, 2007
    #8
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.