32bit aps fail on win2k3 64bit server after MS Updates

Discussion in 'Windows 64bit' started by Guest, Aug 18, 2007.

  1. Guest

    Guest Guest

    after a recent windows up date allot of my 32 bit aps are failing, even the
    32bit explorer failes while the 64 bit explorer runs fine, I removed the
    updates but it never helped any thing

    any ideas? or even where I can look will be helpful
    Guest, Aug 18, 2007
    1. Advertisements

  2. you really don't give us much information to work with. What is the failure?
    When you say 32-bit Explorer, do you mean IE or Windows Explorer? What other
    apps fail? Are you on a domain? Or a workgroup? What is your hardware
    Charlie Russel - MVP, Aug 18, 2007
    1. Advertisements

  3. Guest

    Guest Guest

    its one of our Game servers in the UK, its running the following
    Windows server 64bit Eval (20 days so far)
    Intel Quad core e6600, 4GB 1066RAM Dual DDR2, Asus P5B motherboard, 2 320GB
    SATA300 Hard drives

    now when I launch Explorer 32bit it starts but cant seem to access any web
    sites, it says Page cannot be found, I even tried http:// with our other
    servers IP and it still cannot see any sites

    our 32 bit FTP program seems to be failing a well it seems on but you cant
    connect to it, thwe run Serv-U on that server as we dont need it for web
    hosting yet, when we do get it ready for IIS I'll change back to MS FTP

    the game servers are 32bit and when run they start, and just when they show
    the port info and connection port they just shut off and report the error to

    this is what they report

    Faulting application OFPR_SOF_Server.exe, version, faulting module
    OFPR_SOF_Server.exe, version, fault address 0x0000b0b0.

    For more information, see Help and Support Center at

    my service manager FireDeamon is failing to start as well now and is
    crashing constantly it reports


    Subprocess monitoring failed due to subprocess is no longer active. The
    subprocess is probably dead. Restarting the process. Error detail: N/A

    I do have to do some research on our game servers crashing, each use about
    600MB and it seems when they all reach that they randomly fail, I think that
    is a 32bit RAM issue that I'll look more into, but in the mean even Im sure
    this is related to any net work port accessing by 32bit programs, if i run
    32bit programs that do not access the network then they seem to work
    Guest, Aug 18, 2007
  4. Guest

    Guest Guest

    ohh update

    when I said
    now when I launch Explorer 32bit it starts but cant seem to access any web
    sites, it says Page cannot be found, I even tried http:// with our other
    servers IP and it still cannot see any sites

    I forgot to mention that 64bit explorer works fine, and I can also connect
    to the remote desktop still
    Guest, Aug 18, 2007
  5. Guest

    Guest Guest

    Im pretty sure I either some how shut off wow64 ir it has become corrupted,
    any Ideas on how to repair it, my os comes with SP2 so its not like I can un
    install SP1 to remove wow64 :(

    my head works better in 10s, 32bit and 64bit makes me want to scream hahahah
    Guest, Aug 19, 2007
  6. Guest

    John Barnes Guest

    If it is corrupted, I'm not a server person, but can't you run sfc /scan
    now and repair as in XP?
    John Barnes, Aug 19, 2007
  7. Guest

    Guest Guest

    wow64 must be working, but what ever it uses to access the network is failing

    will fail if I ping a web site
    but if I use
    the ping returns with no problems

    we're getting close now but im still going to cry over the down time we've had
    Guest, Aug 19, 2007
  8. Guest

    Guest Guest

    I have 5 win2k3 32bit enterprise dual core servers with 2GB of ram

    but on my one test win2k3 64bit enterprise quad core with 4GB of ram server
    I have notice that my four 32bit Apps using 600MB each randomly fail every
    day while the 32bit servers run them stable for months

    does any one have any idea how to get these 32bit aps to run better on the
    win2k3 64bit Enterprise server, I know it must be the RAM

    I tried the 32bit server with 4GB of ram and PAE and they are nothing but a
    waste of time as they crash the apps hourly (two high memory usage apps will
    try to use the same memory location and crash constantlly - microsoft hides
    this information really well)

    I do have allot of experience with the 32 bit server so if we need to get
    deep into this I can follow whats going on
    Guest, Aug 19, 2007
  9. Guest

    John Barnes Guest

    Have you run a thorough memory test? The 64-bit os uses memory differently
    and we have had a number of previous situations where memory worked on XP86
    but failed on XP64.
    John Barnes, Aug 19, 2007
  10. Guest

    Guest Guest

    I ran ipconfig in the cmd(32bit) and I got the following
    C:\WINDOWS\SysWOW64>ipconfig /renew

    Windows IP Configuration

    The operation failed as no adapter is in the state permissible for
    this operation.
    Guest, Aug 19, 2007
  11. Guest

    Guest Guest

    had to boot into console mode via RDP to access it, I got sfc /scannow
    running now
    Guest, Aug 19, 2007
  12. Guest

    Guest Guest

    it ran then ended so no idea, gonna reboot and see what happens
    Guest, Aug 19, 2007
  13. Guest

    John Barnes Guest

    Since that should eliminate your corruption possibility, you have settings
    or memory. I still think running a thorough memory test is your best bet
    given the symptoms you have.
    John Barnes, Aug 19, 2007
  14. Guest

    Guest Guest

    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.