2950 and Fibre connections

Discussion in 'Cisco' started by Phil, Apr 13, 2006.

  1. Phil

    Phil Guest

    Hi,
    Hopefully someone can help i am trying to link up some 2950 switches
    via their gbic modules. If the fibre is linking to a switch in another
    location the switches work fine but should i set the switch to link to
    one in the same cabinet the fibre light comes on as if they are live
    but no activity occurs between the switches and i cannot access though
    the main switch.
    Any help would be appreciated and switchport mode is set to trunk

    Thanks
     
    Phil, Apr 13, 2006
    #1
    1. Advertisements

  2. Switches in the same cabinet... is it possible that there is already
    a logical link between the two, and that when you are adding the
    fibre connection that the spanning tree algorithm is kicking in and
    disabling the fibe link?
     
    Walter Roberson, Apr 13, 2006
    #2
    1. Advertisements

  3. Phil

    Phil Guest

    Sorry for the delay Walter, the main link between the 2 switches is
    normally via a ethernet port but when i am attempting to try this out
    the cable has been unplugged so the only exisiting link is that of the
    fibre - Are there any more ideas please as this is driving me mad :)
     
    Phil, Apr 19, 2006
    #3
  4. Phil

    anybody43 Guest

    Hopefully someone can help i am trying to link up some 2950 switches
    The fiber port IS an Ethernet port. So:- if you make the confguration
    of the fiber and copper ports the same _except_ for speed/duplex
    settings
    then you should be in business.

    For Gigabit do not use Speed/Duplex settings.
     
    anybody43, Apr 19, 2006
    #4
  5. Phil

    Phil Guest

    i dont quite understand what you mean there so have copied in the
    relevant parts of the config files
    interface Port-channel1
    switchport mode trunk
    no ip address
    !
    interface FastEthernet0/1
    description ******
    switchport mode trunk
    no ip address
    ....
    ....
    interface GigabitEthernet0/1
    description *** ***
    switchport mode trunk
    no ip address
    channel-group 1 mode on
    !
    interface GigabitEthernet0/2
    description *** ***
    switchport mode trunk
    no ip address
    channel-group 1 mode on


    It is similar on both switches and the connection works fine across
    cabinets just seems to fail locally.

    thanks
     
    Phil, Apr 20, 2006
    #5
  6. Phil

    Merv Guest

    What type of GBICs are being used ?

    Is the minimum fiber cable distance of 6.5 ft being respected ?

    Try using the longest patch cable available
     
    Merv, Apr 20, 2006
    #6
  7. Phil

    Phil Guest

    the gbics are 1000base-sx gbics. The fibre cables between the switches
    is only a maximum 2m. differant cables have been tried
     
    Phil, Apr 20, 2006
    #7
  8. Phil

    anybody43 Guest

    Hopefully someone can help i am trying to link up some 2950 switches
    Start from the beginning.

    Are the interfaces coming up?

    CORE1#sh int gi 1/1
    GigabitEthernet1/1 is up, line protocol is up (connected)


    If not then you have a physical layer issue. e.g.

    Are the ports err-disable?

    shut then "no shut" to remove err-disable.

    Are you using an appropriate fiber?

    The fiber you need is 62.5/125 or 50/125 micron core. NOT 8.5/125 or
    9/125 micron core.
    The fiber is usully marked periodically along its length with
    the Inner/Outer core diameter.

    You CLEARLY have to connect the Transmitter on one side to the Receiver
    on the other side. Check that this is the case. The Right hand port on
    one switch should go to the left hand one on the other.

    I have not used many GBICs for a while but they used to be pretty
    unreliable.

    If the switched have more than one GBIC port you could put them both in

    each switch in turn and check if it works that way.

    Fibers that look damaged are probably scrap. They should be stored with
    the ends
    protected from abrasion and dirt/dust.

    post
    sh int
    sh int trunk
    sh etherchannel
     
    anybody43, Apr 21, 2006
    #8
  9. Phil

    Phil Guest

    The interfaces when connected do come up live i believe the err-disable
    is off and the fibre is 62.5/125.
    As suggested above the ports are connected up as you suggest with the
    rhs of the top switch going to the lhs of the bottom switch.
    As requested here are edited versions of the files

    int :

    GigabitEthernet0/1 is up, line protocol is up (connected)
    Hardware is Gigabit Ethernet, address is 000f.34e3.50d9 (bia
    000f.34e3.50d9)
    Description: *** ***
    MTU 1500 bytes, BW 1000000 Kbit, DLY 1000 usec,
    reliability 255/255, txload 1/255, rxload 1/255
    Encapsulation ARPA, loopback not set
    Keepalive set (10 sec)
    Full-duplex, 1000Mb/s, link type is auto, media type is SX
    output flow-control is on, input flow-control is off
    ARP type: ARPA, ARP Timeout 04:00:00
    Last input 00:00:22, output 00:00:06, output hang never
    Last clearing of "show interface" counters never
    Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
    Queueing strategy: fifo
    Output queue: 0/40 (size/max)
    5 minute input rate 1487000 bits/sec, 191 packets/sec
    5 minute output rate 207000 bits/sec, 140 packets/sec
    52347378 packets input, 3517655132 bytes, 0 no buffer
    Received 5805082 broadcasts (0 multicast)
    0 runts, 0 giants, 0 throttles
    0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
    0 watchdog, 3318076 multicast, 0 pause input
    0 input packets with dribble condition detected
    44840744 packets output, 3438110220 bytes, 0 underruns
    0 output errors, 0 collisions, 2 interface resets
    0 babbles, 0 late collision, 0 deferred
    0 lost carrier, 0 no carrier, 0 PAUSE output
    0 output buffer failures, 0 output buffers swapped out
    GigabitEthernet0/2 is up, line protocol is up (connected)
    Hardware is Gigabit Ethernet, address is 000f.34e3.50da (bia
    000f.34e3.50da)
    Description: *** ***
    MTU 1500 bytes, BW 1000000 Kbit, DLY 1000 usec,
    reliability 255/255, txload 1/255, rxload 1/255
    Encapsulation ARPA, loopback not set
    Keepalive set (10 sec)
    Full-duplex, 1000Mb/s, link type is auto, media type is SX
    output flow-control is on, input flow-control is off
    ARP type: ARPA, ARP Timeout 04:00:00
    Last input 00:00:22, output 00:00:06, output hang never
    Last clearing of "show interface" counters never
    Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
    Queueing strategy: fifo
    Output queue: 0/40 (size/max)
    5 minute input rate 1216000 bits/sec, 275 packets/sec
    5 minute output rate 699000 bits/sec, 223 packets/sec
    60901726 packets input, 1416495495 bytes, 0 no buffer
    Received 1380340 broadcasts (0 multicast)
    0 runts, 0 giants, 0 throttles
    0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
    0 watchdog, 51529 multicast, 0 pause input
    0 input packets with dribble condition detected
    58637153 packets output, 3780763984 bytes, 0 underruns
    0 output errors, 0 collisions, 2 interface resets
    0 babbles, 0 late collision, 0 deferred
    0 lost carrier, 0 no carrier, 0 PAUSE output
    0 output buffer failures, 0 output buffers swapped out
    Port-channel1 is up, line protocol is up (connected)
    Hardware is EtherChannel, address is 000f.34e3.50d9 (bia
    000f.34e3.50d9)
    MTU 1500 bytes, BW 2000000 Kbit, DLY 1000 usec,
    reliability 255/255, txload 1/255, rxload 1/255
    Encapsulation ARPA, loopback not set
    Full-duplex, 1000Mb/s
    input flow-control is off, output flow-control is off
    Members in this channel: Gi0/1 Gi0/2
    ARP type: ARPA, ARP Timeout 04:00:00
    Last input 00:00:01, output never, output hang never
    Last clearing of "show interface" counters never
    Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
    Queueing strategy: fifo
    Output queue: 0/40 (size/max)
    5 minute input rate 2737000 bits/sec, 474 packets/sec
    5 minute output rate 947000 bits/sec, 377 packets/sec
    113249094 packets input, 639182691 bytes, 0 no buffer
    Received 7185414 broadcasts (0 multicast)
    0 runts, 0 giants, 0 throttles
    0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
    0 watchdog, 3369597 multicast, 0 pause input
    0 input packets with dribble condition detected
    103477886 packets output, 2923906204 bytes, 0 underruns
    0 output errors, 0 collisions, 1 interface resets
    0 babbles, 0 late collision, 0 deferred
    0 lost carrier, 0 no carrier, 0 PAUSE output
    0 output buffer failures, 0 output buffers swapped out


    int trunk :
    2950CabB#sh int trunk

    Port Mode Encapsulation Status Native vlan
    Fa0/1 on 802.1q trunking 1
    Po1 on 802.1q trunking 1

    Port Vlans allowed on trunk
    Fa0/1 1-4094
    Po1 1-4094

    Port Vlans allowed and active in management domain
    Fa0/1 1-2,6,10-11,30
    Po1 1-2,6,10-11,30

    Port Vlans in spanning tree forwarding state and not pruned
    Fa0/1 1-2,6,10-11,30
    Po1 1-2,6,10-11,30

    sh etherchannel :
    Channel-group listing:
    -----------------------

    Group: 1
    ----------
    Group state = L2
    Ports: 2 Maxports = 8
    Port-channels: 1 Max Port-channels =
    Protocol: -

    Any help again is appreciated but i will be away for the next week so
    will be a little slow in replying .

    Many many thanks
    Phil
     
    Phil, Apr 24, 2006
    #9
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.