2600 + 4BRI: can I accept V.120 ISDN calls from GSM network ? Help!

Discussion in 'Cisco' started by Gio, Feb 21, 2004.

  1. Gio

    Gio Guest

    I would like to setup some nokia phones to call a cisco
    2611 using a 4 BRI ISDN interface.
    According to Cisco web site "feature navigator", I installed
    IOS 12.1 enterprise version to have the V.120 feature.
    Now the router can receive calls, the router recognizes the call as
    a V.120 call, but nothing else happens.

    Please help me !
    Thank you

    Giovanni

    ----
    ----
    Nokia phone configuration:
    AT+CBST=39,0,1 (V.120 900bps)

    ---
    Cisco 2611, part of configuration:

    username x password y
    !
    vty-async
    vty-async virtual-template 1
    isdn switch-type basic-net3
    !
    interface BRI1/0
    description "My ISDN line"
    no ip address
    encapsulation ppp
    dialer pool-member 1 priority 10
    isdn switch-type basic-net3
    no cdp enable
    ppp authentication chap callin
    !
    interface Virtual-Template1
    ip unnumbered Ethernet0/0
    peer default ip address pool poolDialin
    ppp authentication chap
    !
    interface Dialer1
    description "Outgoing call to ISP"
    ip address negotiated
    ip nat outside
    encapsulation ppp
    dialer pool 1
    dialer remote-name xxxxxx
    dialer idle-timeout 180
    dialer string 0444444444444
    dialer-group 1
    no cdp enable
    ppp chap hostname _my_username_
    ppp chap password 7 12405
    !
    interface Dialer2
    description "Ingoing profile for maintenance access"
    ip unnumbered Ethernet0/0
    encapsulation ppp
    dialer pool 1
    dialer remote-name mainten
    dialer-group 1
    peer default ip address pool poolDialin
    no cdp enable
    ppp authentication chap callin
    !
    line vty 5 20
    no login
    autocommand ppp neg
    transport input v120
    autoselect ppp
    !

    -------------
    -------------
    Debug of a session

    debu isdn q931
    debu ppp nego
    debu ppp auth
    debu v120 event
    debu dialer

    1w5d: ISDN BR1/0: RX <- SETUP pd = 8 callref = 0x0D
    1w5d: Bearer Capability i = 0x8890
    1w5d: Channel ID i = 0x89
    1w5d: Calling Party Number i = 0x0181, '3333333333', Plan:ISDN,
    Type:Unknown
    1w5d: Called Party Number i = 0xA1, '44444444', Plan:ISDN, Type:National
    1w5d: Sending Complete
    1w5d: Low Layer Compat i = 0x8890284872BB
    1w5d: ISDN BR1/0: llc valid, speed 64, call type is V.120
    speed:8 async:Y header:Y multiframe:Y mode 1
    1w5d: stop 1 data 3 parity 3
    1w5d: ISDN BR1/0: Event: Received a V.120 call from 3333333333 on B1 at 64 Kb/s
    1w5d: BR1/0:1-v120 started - Setting V.120 parameters from llc
    1w5d: %LINK-3-UPDOWN: Interface BRI1/0:1, changed state to up
    1w5d: ISDN BR1/0: TX -> CALL_PROC pd = 8 callref = 0x8D
    1w5d: Channel ID i = 0x89
    1w5d: ISDN BR1/0: TX -> CONNECT pd = 8 callref = 0x8D
    1w5d: ISDN BR1/0: RX <- CONNECT_ACK pd = 8 callref = 0x0D
    1w5d: BR1/0:1 - changing to 2 V.120 header bytes,CS(0xF0)
    1w5d: %LINEPROTO-5-UPDOWN: Line protocol on Interface BRI1/0:1, changed state
    to up
    1w5d: V120BR1/0:1:EST:t200 expired
    1w5d: V120BR1/0:1:retransmit 1 packets
    1w5d: %ISDN-6-CONNECT: Interface BRI1/0:1 is now connected to 3333333333

    <---- PAUSE, then the client hangs up --->

    1w5d: BR1/0:1 DDR: disconnecting call
    1w5d: %ISDN-6-DISCONNECT: Interface BRI1/0:1 disconnected from 3333333333 ,
    call lasted 10 seconds
    1w5d: ISDN BR1/0: TX -> DISCONNECT pd = 8 callref = 0x8D
    1w5d: Cause i = 0x8090 - Normal call clearing
    1w5d: ISDN BR1/0: RX <- RELEASE pd = 8 callref = 0x0D
    1w5d: ISDN BR1/0: TX -> RELEASE_COMP pd = 8 callref = 0x8D
    1w5d: %LINK-3-UPDOWN: Interface BRI1/0:1, changed state to down
    1w5d: BR1/0:1:removing v120
    1w5d: BR1/0:1 LCP: State is Closed
    1w5d: BR1/0:1 DDR: disconnecting call
    1w5d: %LINEPROTO-5-UPDOWN: Line protocol on Interface BRI1/0:1, changed state
    to down
     
    Gio, Feb 21, 2004
    #1
    1. Advertisements

  2. I guess I'd add these debugs:

    debug modem
    debug ppp negotiation
    debug v120 packet
    debug vtemplate event

    Also use some msec timestamps:

    conf term
    service timestamp debug date msec

    Aaron

    ---


    ~ I would like to setup some nokia phones to call a cisco
    ~ 2611 using a 4 BRI ISDN interface.
    ~ According to Cisco web site "feature navigator", I installed
    ~ IOS 12.1 enterprise version to have the V.120 feature.
    ~ Now the router can receive calls, the router recognizes the call as
    ~ a V.120 call, but nothing else happens.
    ~
    ~ Please help me !
    ~ Thank you
    ~
    ~ Giovanni
    ~
    ~ ----
    ~ ----
    ~ Nokia phone configuration:
    ~ AT+CBST=39,0,1 (V.120 900bps)
    ~
    ~ ---
    ~ Cisco 2611, part of configuration:
    ~
    ~ username x password y
    ~ !
    ~ vty-async
    ~ vty-async virtual-template 1
    ~ isdn switch-type basic-net3
    ~ !
    ~ interface BRI1/0
    ~ description "My ISDN line"
    ~ no ip address
    ~ encapsulation ppp
    ~ dialer pool-member 1 priority 10
    ~ isdn switch-type basic-net3
    ~ no cdp enable
    ~ ppp authentication chap callin
    ~ !
    ~ interface Virtual-Template1
    ~ ip unnumbered Ethernet0/0
    ~ peer default ip address pool poolDialin
    ~ ppp authentication chap
    ~ !
    ~ interface Dialer1
    ~ description "Outgoing call to ISP"
    ~ ip address negotiated
    ~ ip nat outside
    ~ encapsulation ppp
    ~ dialer pool 1
    ~ dialer remote-name xxxxxx
    ~ dialer idle-timeout 180
    ~ dialer string 0444444444444
    ~ dialer-group 1
    ~ no cdp enable
    ~ ppp chap hostname _my_username_
    ~ ppp chap password 7 12405
    ~ !
    ~ interface Dialer2
    ~ description "Ingoing profile for maintenance access"
    ~ ip unnumbered Ethernet0/0
    ~ encapsulation ppp
    ~ dialer pool 1
    ~ dialer remote-name mainten
    ~ dialer-group 1
    ~ peer default ip address pool poolDialin
    ~ no cdp enable
    ~ ppp authentication chap callin
    ~ !
    ~ line vty 5 20
    ~ no login
    ~ autocommand ppp neg
    ~ transport input v120
    ~ autoselect ppp
    ~ !
    ~
    ~ -------------
    ~ -------------
    ~ Debug of a session
    ~
    ~ debu isdn q931
    ~ debu ppp nego
    ~ debu ppp auth
    ~ debu v120 event
    ~ debu dialer
    ~
    ~ 1w5d: ISDN BR1/0: RX <- SETUP pd = 8 callref = 0x0D
    ~ 1w5d: Bearer Capability i = 0x8890
    ~ 1w5d: Channel ID i = 0x89
    ~ 1w5d: Calling Party Number i = 0x0181, '3333333333', Plan:ISDN,
    ~ Type:Unknown
    ~ 1w5d: Called Party Number i = 0xA1, '44444444', Plan:ISDN, Type:National
    ~ 1w5d: Sending Complete
    ~ 1w5d: Low Layer Compat i = 0x8890284872BB
    ~ 1w5d: ISDN BR1/0: llc valid, speed 64, call type is V.120
    ~ speed:8 async:Y header:Y multiframe:Y mode 1
    ~ 1w5d: stop 1 data 3 parity 3
    ~ 1w5d: ISDN BR1/0: Event: Received a V.120 call from 3333333333 on B1 at 64 Kb/s
    ~ 1w5d: BR1/0:1-v120 started - Setting V.120 parameters from llc
    ~ 1w5d: %LINK-3-UPDOWN: Interface BRI1/0:1, changed state to up
    ~ 1w5d: ISDN BR1/0: TX -> CALL_PROC pd = 8 callref = 0x8D
    ~ 1w5d: Channel ID i = 0x89
    ~ 1w5d: ISDN BR1/0: TX -> CONNECT pd = 8 callref = 0x8D
    ~ 1w5d: ISDN BR1/0: RX <- CONNECT_ACK pd = 8 callref = 0x0D
    ~ 1w5d: BR1/0:1 - changing to 2 V.120 header bytes,CS(0xF0)
    ~ 1w5d: %LINEPROTO-5-UPDOWN: Line protocol on Interface BRI1/0:1, changed state
    ~ to up
    ~ 1w5d: V120BR1/0:1:EST:t200 expired
    ~ 1w5d: V120BR1/0:1:retransmit 1 packets
    ~ 1w5d: %ISDN-6-CONNECT: Interface BRI1/0:1 is now connected to 3333333333
    ~
    ~ <---- PAUSE, then the client hangs up --->
    ~
    ~ 1w5d: BR1/0:1 DDR: disconnecting call
    ~ 1w5d: %ISDN-6-DISCONNECT: Interface BRI1/0:1 disconnected from 3333333333 ,
    ~ call lasted 10 seconds
    ~ 1w5d: ISDN BR1/0: TX -> DISCONNECT pd = 8 callref = 0x8D
    ~ 1w5d: Cause i = 0x8090 - Normal call clearing
    ~ 1w5d: ISDN BR1/0: RX <- RELEASE pd = 8 callref = 0x0D
    ~ 1w5d: ISDN BR1/0: TX -> RELEASE_COMP pd = 8 callref = 0x8D
    ~ 1w5d: %LINK-3-UPDOWN: Interface BRI1/0:1, changed state to down
    ~ 1w5d: BR1/0:1:removing v120
    ~ 1w5d: BR1/0:1 LCP: State is Closed
    ~ 1w5d: BR1/0:1 DDR: disconnecting call
    ~ 1w5d: %LINEPROTO-5-UPDOWN: Line protocol on Interface BRI1/0:1, changed state
    ~ to down
    ~
    ~
     
    Aaron Leonard, Feb 23, 2004
    #2
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.