1721 router with 4esw card not routing

Discussion in 'Cisco' started by Craig, Dec 14, 2006.

  1. Craig

    Craig Guest

    I am trying to use this router to segment off a subnet with my printers
    on it. I've created a vlan 2 and assigned it to port 4 on the wic card.
    I can't ping through the router either way, and i have no connectivity.
    Anyone have any idea what i'm doing wrong? all i'm trying to do is
    connect the 192.168 and 172.16 networks. Any help would be much
    appreciated. Thanks!
    Building configuration...



    Current configuration : 1120 bytes

    !

    version 12.4

    service timestamps debug datetime msec

    service timestamps log datetime msec

    no service password-encryption

    !

    hostname printer_router

    !

    boot-start-marker

    boot-end-marker

    !

    enable password

    !

    no aaa new-model

    !

    resource policy

    !

    mmi polling-interval 60

    no mmi auto-configure

    no mmi pvc

    mmi snmp-timeout 180

    ip subnet-zero

    ip cef

    !

    !

    no ip dhcp use vrf connected

    !

    !

    !

    !

    !

    !

    interface FastEthernet0

    ip address 192.168.x.x 255.255.255.0

    speed auto

    !

    interface FastEthernet1

    !

    interface FastEthernet2

    !

    interface FastEthernet3

    !

    interface FastEthernet4

    switchport access vlan 2

    !

    interface Vlan1

    no ip address

    !

    interface Vlan2

    ip address 172.16.x.x 255.255.255.0

    !

    router eigrp 1

    network 192.168.a.0

    network 192.168.b.0

    network 192.168.c.0

    network 192.168.d.0

    network 171.16.a.0

    no auto-summary

    no eigrp log-neighbor-changes

    !

    no ip classless

    ip route 0.0.0.0 0.0.0.0 192.168.x.x

    !

    no ip http server

    !

    !

    control-plane

    !

    !

    line con 0

    password

    line aux 0

    password

    modem InOut

    transport input all

    flowcontrol hardware

    line vty 0 4

    password

    login
     
    Craig, Dec 14, 2006
    #1
    1. Advertisements

  2. You configured it wrong way. You should configure "encapsulation dot1q" on
    the physical interface, and then create subinterfaces (for example, fa4.2),
    and then configure VLAN and IP address on that subinterface.

    Another question, if you have 5 Ethernet interfaces, why don't you just
    connect each VLAN to it's own physical interface, and configure IP address
    on the physical interface?

    Good luck,

    Mike
     
    headsetadapter.com, Dec 14, 2006
    #2
    1. Advertisements

  3. Craig

    Craig Guest

    Hi Mike,

    Thanks for your reply. I was trying to connect vlan 2 to the f4
    interface. what did i do wrong? the interface itself is L2, so i
    couldn't just put an address on the f4 interface. if i put the vlan and
    ip on a subinterface, how do i bind it to one of the wic switch ports?

    Thanks
     
    Craig, Dec 14, 2006
    #3
  4. headsetadapter.com, Dec 14, 2006
    #4
  5. Craig

    Craig Guest

    Craig, Dec 15, 2006
    #5
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.