1603 to 2610 bri isdn connection problem - need help!

Discussion in 'Cisco' started by Phil, Feb 24, 2004.

  1. Phil

    Phil Guest

    I have been trying to connect a 1603 to a 2610 over isdn and succeeded
    in getting the 2610 to dial the 1603 (everything seems to work ok when
    the connection is made). However, I'm having trouble getting the 1603
    to connect to the 2610 - the call is hung up immediately.

    I have messed around with the original config on the 2610 but another
    router is still able to dial into it (haven't got the details at the
    moment but it's not a Cisco).

    debug says 'User busy' but line is free

    Dialer5 has been added to the 2610 to dial the 1603 (I also removed
    Dialer3 which was going to an ISP but need to take the route out) and
    Dialer1 on the 1603 to dial the 2610

    Can anyone spot what I'm doing wrong here?
    Thanks,
    Phil


    6d00h: BRI0 DDR: rotor dialout [priority]
    6d00h: BRI0 DDR: Dialing cause ip (s=192.168.3.73, d=192.168.1.1)
    6d00h: BRI0 DDR: Attempting to dial 0101
    6d00h: ISDN BR0: Outgoing call id = 0x8144, dsl 0
    6d00h: ISDN BR0: Event: Call to 0101 at 64 Kb/s
    6d00h: ISDN BR0: process_bri_call(): call id 0x8144, called_number
    0101, speed 64, call type DATA
    6d00h: CC_CHAN_GetIdleChanbri: dsl 0
    6d00h: Found idle channel B1
    6d00h: ISDN BR0: TX -> SETUP pd = 8 callref = 0x46
    6d00h: Bearer Capability i = 0x8890
    6d00h: Channel ID i = 0x83
    6d00h: Called Party Number i = 0x80, '0101'
    6d00h: ISDN BR0: RX <- CALL_PROC pd = 8 callref = 0xC6
    6d00h: Channel ID i = 0x89
    6d00h: ISDN BR0: received HOST_PROCEEDING call_id 0x8144
    6d00h: ISDN BR0: RX <- DISCONNECT pd = 8 callref = 0xC6
    6d00h: Cause i = 0x8A91 - User busy
    6d00h: ISDN BR0: received HOST_DISCONNECT call_id 0x8144
    6d00h: ISDN BR0: Event: Call to 0101 was hung up.
    6d00h: ISDN BR0: process_disc_ack(): call id 0x8144, ces 1, call type
    DATA
    6d00h: BRI0: wait for isdn carrier timeout, call id=0x8144
    6d00h: DDR: Dialing failed, 1 packets unqueued and discarded
    6d00h: ISDN BR0: TX -> RELEASE pd = 8 callref = 0x46
    6d00h: Cause i = 0x809108 - User busy
    6d00h: ISDN BR0: RX <- RELEASE_COMP pd = 8 callref = 0xC6
    6d00h: ISDN BR0: received HOST_DISCONNECT_ACK call_id 0x8144
    6d00h: ISDN BR0: HOST_DISCONNECT_ACK: call type is DATA





    ----------------------------------------------------------------------------
    IOS (tm) C2600 Software (C2600-I-M), Version 12.0(7)T, RELEASE
    SOFTWARE (fc2)

    cisco 2610 (MPC860) processor (revision 0x203) with 26624K/6144K bytes
    of memory.
    Processor board ID JAD04130EXO (80965002)
    M860 processor: part number 0, mask 49
    Bridging software.
    X.25 software, Version 3.0.0.
    Basic Rate ISDN software, Version 1.1.
    1 Ethernet/IEEE 802.3 interface(s)
    1 Serial network interface(s)
    4 ISDN Basic Rate interface(s)
    32K bytes of non-volatile configuration memory.
    8192K bytes of processor board System flash (Read/Write)
    ------------------------------------------------------------------------------

    IOS (tm) 1600 Software (C1600-NY-M), Version 12.0(5)T, RELEASE
    SOFTWARE (fc1)

    ROM: System Bootstrap, Version 12.0(3)T, RELEASE SOFTWARE (fc1)
    ROM: 1600 Software (C1600-RBOOT-R), Version 12.0(3)T, RELEASE
    SOFTWARE (fc1)

    cisco 1603 (68360) processor (revision C) with 9216K/3072K bytes of
    memory.
    Processor board ID 13636318, with hardware revision 00000001
    Bridging software.
    X.25 software, Version 3.0.0.
    Basic Rate ISDN software, Version 1.1.
    1 Ethernet/IEEE 802.3 interface(s)
    1 Serial(sync/async) network interface(s)
    1 ISDN Basic Rate interface(s)
    System/IO memory with parity disabled
    8192K bytes of DRAM onboard 4096K bytes of DRAM on SIMM
    System running from RAM
    7K bytes of non-volatile configuration memory.
    4096K bytes of processor board PCMCIA flash (Read/Write)
    ------------------------------------------------------------------------

    2610 config:

    version 12.0
    service timestamps debug uptime
    service timestamps log uptime
    service password-encryption
    !
    hostname C
    !
    enable password 7 xxxxxx
    !
    username
    username
    username
    username
    username
    username
    !
    !
    !
    !
    ip subnet-zero
    no ip domain-lookup
    !
    isdn switch-type basic-net3
    isdn voice-call-failure 0
    !
    !
    !
    interface Ethernet0/0
    ip address 192.168.1.210 255.255.255.0
    no ip directed-broadcast
    ip nat inside
    !
    interface Serial0/0
    ip address 10.1.1.1 255.255.255.0
    no ip directed-broadcast
    no ip mroute-cache
    shutdown
    no fair-queue
    !
    interface BRI1/0
    no ip address
    no ip directed-broadcast
    encapsulation ppp
    dialer pool-member 3
    isdn switch-type basic-net3
    isdn answer1 01010
    ppp authentication chap
    !
    interface BRI1/1
    no ip address
    no ip directed-broadcast
    encapsulation ppp
    shutdown
    dialer pool-member 1 priority 50
    isdn switch-type basic-net3
    isdn answer1 0101
    ppp authentication chap
    !
    interface BRI1/2
    no ip address
    no ip directed-broadcast
    encapsulation ppp
    dialer pool-member 1
    dialer pool-member 3 priority 50
    isdn switch-type basic-net3
    isdn answer1 0101
    ppp authentication chap
    !
    interface BRI1/3
    no ip address
    no ip directed-broadcast
    encapsulation ppp
    no ip route-cache
    no ip mroute-cache
    dialer pool-member 2
    dialer pool-member 4
    dialer pool-member 5
    isdn switch-type basic-net3
    ppp authentication pap
    !
    interface Dialer1

    ip address 172.16.0.20 255.255.0.0
    no ip directed-broadcast
    encapsulation ppp
    dialer remote-name HAM
    dialer pool 1
    dialer idle-timeout 180
    dialer string 9010101
    dialer hold-queue 10
    dialer load-threshold 1 outbound
    dialer max-call 6
    dialer-group 1
    ppp authentication chap callin
    ppp chap hostname HAM
    ppp chap password 7 xxxxxxxx
    ppp multilink
    !
    interface Dialer2
    ip unnumbered Ethernet0/0
    no ip directed-broadcast
    encapsulation ppp
    dialer remote-name HAM
    dialer pool 2
    dialer idle-timeout 60
    dialer string 90101
    dialer hold-queue 10
    dialer-group 1
    no fair-queue
    ppp authentication pap
    ppp pap sent-username XYZ password 7 xxxxxxxx
    !
    interface Dialer4
    ip unnumbered Ethernet0/0
    no ip directed-broadcast
    encapsulation ppp
    dialer remote-name SLA
    dialer pool 4
    dialer idle-timeout 180
    dialer string 9010101
    dialer hold-queue 10
    dialer-group 1
    ppp authentication pap
    ppp pap sent-username ABC password 7 xxxxxx
    !
    interface Dialer5
    ip unnumbered Ethernet0/0
    no ip directed-broadcast
    encapsulation ppp
    dialer remote-name Cisco1603
    dialer pool 5
    dialer string 0123456
    dialer hold-queue 10
    dialer-group 1
    ppp authentication pap
    ppp chap hostname Cisco1603
    ppp chap password 7 xxxxxxx
    ppp pap sent-username Cisco1603 password xxxxxxxxx
    !
    ip nat inside source list 2 interface Dialer3 overload
    ip classless
    ip route 10.50.52.0 255.255.255.0 Dialer2
    ip route 192.168.2.0 255.255.255.0 Dialer4
    ip route 192.168.3.0 255.255.255.0 Dialer5
    ip route 194.61.67.0 255.255.255.0 Dialer1
    no ip http server
    !
    access-list 1 permit 10.50.52.0 0.0.0.255
    access-list 2 permit 192.168.1.0 0.0.0.255
    access-list 2 permit 192.168.3.0 0.0.0.255
    access-list 3 permit 192.168.1.1
    access-list 100 remark Blocks Invalid IP's On Internet
    access-list 100 deny ip any 10.0.0.0 0.255.255.255
    access-list 100 deny ip any 192.168.0.0 0.0.255.255
    access-list 100 deny ip any 172.16.0.0 0.15.255.255
    access-list 100 permit ip any any
    access-list 101 remark Blocks Invalid IP's On Internet
    access-list 101 deny ip 10.0.0.0 0.255.255.255 any
    access-list 101 deny ip 192.168.0.0 0.0.255.255 any
    access-list 101 deny ip 172.16.0.0 0.15.255.255 any
    access-list 101 permit ip any any
    dialer-list 1 protocol ip permit
    dialer-list 2 protocol ip list 100
    !

    !
    end


    1603 config:

    version 12.0
    service timestamps debug uptime
    service timestamps log uptime
    no service password-encryption
    !
    hostname Cisco1603
    !
    enable password xxxxx
    !
    username
    username
    !
    !
    !
    !
    ip subnet-zero
    no ip domain-lookup
    !
    isdn switch-type basic-net3
    !
    !
    process-max-time 200
    !
    interface Ethernet0
    ip address 192.168.3.1 255.255.255.0
    no ip directed-broadcast
    ip nat inside
    !
    interface Serial0
    no ip address
    no ip directed-broadcast
    shutdown
    no fair-queue
    !
    interface BRI0
    no ip address
    no ip directed-broadcast
    encapsulation ppp
    no ip route-cache
    dialer pool-member 1
    dialer pool-member 2
    isdn switch-type basic-net3
    isdn send-alerting
    ppp authentication pap
    !
    interface Dialer0
    description ******* Dialer Interface to ISP*******
    ip address negotiated
    no ip directed-broadcast
    ip nat outside
    encapsulation ppp
    no ip route-cache
    dialer remote-name ISP
    dialer string 0808
    dialer hold-queue 10
    dialer pool 1
    dialer-group 1
    compress stac
    ppp authentication pap callin
    ppp pap sent-username username password 7 xxxxx
    !
    interface Dialer1
    ip unnumbered Ethernet0
    no ip directed-broadcast
    encapsulation ppp
    dialer remote-name ham
    dialer string 0101
    dialer caller 0101
    dialer hold-queue 10
    dialer pool 2
    dialer-group 1
    no cdp enable
    ppp authentication pap
    ppp chap hostname ham
    ppp chap password 7 xxxxxx
    ppp pap sent-username ham password 7 xxxxx
    !
    ip nat inside source list 1 interface Dialer0 overload

    ip classless
    ip route 0.0.0.0 0.0.0.0 Dialer0
    ip route 192.168.1.0 255.255.255.0 Dialer1
    no ip http server
    !
    access-list 1 permit 172.0.0.0 0.255.255.255
    access-list 1 permit 192.0.0.0 0.255.255.255
    access-list 2 permit 192.168.3.73
    dialer-list 1 protocol ip permit
    no cdp run
    snmp-server engineID local 00000009020000309492C658
    snmp-server community public RO
    !
    !
    end
     
    Phil, Feb 24, 2004
    #1
    1. Advertisements

  2. Phil

    Phil Guest

    A stupid mistake - it helps if you're given the correct number in the
    first place!!

    Now able to initiate a connection using either router but I was only
    able to by putting ppp authentication pap callin on the Dialer1
    interface of the 1603 router - it refused to authenticate without that
    - is that normal?

    Phil
     
    Phil, Feb 25, 2004
    #2
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.