10/100 Mbit Switch and 1Gbit NIC Problem

Discussion in 'Home Networking' started by Mal Franks, Mar 15, 2005.

  1. Mal Franks

    Mal Franks Guest

    Are there any/many instances of 1Gbit NICs not getting on with older non-
    1Gbit switches?

    Wife's just taken delivery of an Alienware PC which comes with a Gbit NIC
    (some sort of VIA onboard jobby i think) which i hooked up to the network
    cable of from her previous PC which is connected to the 4 year old
    Switch.

    Gave it an IP address plus DNS servers and the gateway IP addresses but
    it doesn't appear to be able to see anything on the network - tried
    pinging the IP addresses of other PCs (with firewalls turned off on all
    of them) but nothing.

    Dug out my Netgear WGE101 and connected it directly to the PC's NIC and
    it was able to see that.

    Though that's not much use atm as a replacement for directly hooking it
    up to the switch as the WGE101 will see my DLink DWL-2000AP+ WAP (when
    I've turned SSID broadcasting back on) but doesn't want to connect to it
    for some reason either
     
    Mal Franks, Mar 15, 2005
    #1
    1. Advertisements

  2. Mal Franks

    Ted Guest

    When you look in network connections on the PC does it show that the
    network is enabled.We have a PC on which we have had to put a short cut
    onto the desktop for enabling the onboard NIC connection should it not
    automatically start.
     
    Ted, Mar 15, 2005
    #2
    1. Advertisements

  3. Mal Franks

    Mal Franks Guest

    It does - the notification icon in the taskbar indicates that it is
    connected to a network
     
    Mal Franks, Mar 15, 2005
    #3
  4. Mal Franks

    Ted Guest

    I gather that since you allocated an IP address your not using DHCP on
    your network, have you tried it and are you still unable to communicate.
     
    Ted, Mar 15, 2005
    #4
  5. Mal Franks

    Mal Franks Guest

    Don't use DHCP, I have fixed ip address for each PC in the 192.168.1.x
    range, with subnet set to 255.255.255 as i have port forwarding set up
    on my router/modem for when i have http, ftp and my digitv servers
    running.
     
    Mal Franks, Mar 15, 2005
    #5
  6. Mal Franks

    Alex Fraser Guest

    Only when it's plugged in?
    Connected at what speed?

    Have you looked to see if you can override auto-negotiation? To get at the
    settings, follow the relevant instructions here:
    http://homepage.ntlworld.com/robin.d.h.walker/cmtips/ethernet.html#ethernet

    Alex
     
    Alex Fraser, Mar 15, 2005
    #6
  7. Mal Franks

    Mal Franks Guest

    On Tue, 15 Mar 2005 21:38:03 -0000 Thorin sat down and started singing
    about gold. Gandalf entered. Gandalf said "Hurry up". After being
    threatened with a cloven skull from one well placed blow, Alex Fraser
    said:
    Yep only when it's plugged in - says it's connected at 100Mbits/sec

    Will check that URL out. Going to borrow a spare 10/100 USB NIC from a
    mate tomorrow and see if that works with the switch

    Mal
     
    Mal Franks, Mar 15, 2005
    #7
  8. Mal Franks

    Mal Franks Guest

    On Tue, 15 Mar 2005 16:55:25 -0000 Thorin sat down and started singing
    about gold. Gandalf entered. Gandalf said "Hurry up". After being
    threatened with a cloven skull from one well placed blow, Mal Franks
    said:
    Tried a mate's Belkin F5D5050 USB to 10/100 Ethernet adapter and I'm
    getting a similar, though slightly different problem. When connected to
    the switch it keeps on cycling between saying it's connected to the
    network and it isn't - but works fine when hooked up to the WGE101 -
    though due to the aforementioned problem it's no use.

    So it looks like the switch could be dodgy - however I can swap around
    the various network cables and they all work fine. Think I'll try
    turning off the whole network overnight and see if that rectifies
    anything.
     
    Mal Franks, Mar 16, 2005
    #8
  9. Mal Franks

    Mal Franks Guest

    Forced the network card to 10Mbit/sec Full Duplex and it's now working -
    looks like the switch needs to be replaced (bugger) - but transferring
    files sharing isn't a priority so it's good enough for internet access.
     
    Mal Franks, Mar 17, 2005
    #9
  10. Mal Franks

    stephen Guest

    this is classic for poor cabling - often what works fine at 10M breaks at
    100 if the pairs arent wired up correctly.

    i suggest you get a known good patch lead (one that works elsewhere at 100)
    to replace any fixed wiring while testing
    if you have to force the device to full duplex, then you must also force the
    switch to full as well - otherwise auto negotiate will make it drop to 10
    and 1/2 duplex.
    Try forcing the laptop to 100 1/2 duplex.
     
    stephen, Mar 17, 2005
    #10
  11. Mal Franks

    Mal Franks Guest

    The 3 metre cable was working fine at 100M with the previous PC and I
    tried a new cable too and had the same trouble.
    Tried 100 1/2 duplex, that didn't work either (desktop btw). Thanks
    anyway :)

    Mal
     
    Mal Franks, Mar 18, 2005
    #11
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.