yet another Asterisk / Trix Box question - voicemail

Discussion in 'UK VOIP' started by RH, Jul 11, 2006.

  1. RH

    RH Guest

    Any bods help me out here as to what the correct way to get voicemail
    emailing is. been trying but can not find any real doco

    I am running trixbox 1.1

    I install the voicemail option in trixbox and set up email for voicemail and
    followed some advice from nerdvitties site
    Change etc/hosts file to give the second line my domian name ( I am on a
    fixed IP so have static name as well)
    changed /etc/asterisk/vm_general.inc to have a correct from email address
    then issued echo CGasterisk.dyndns.org >> sendmail.cf

    When I restart I still get no voice mail, but the the webserver function has
    died

    on some sites it has talked about setting up sendmail but I cannot find
    those links now

    When I try and leave voice mail and confirm it complains about an error

    Last time I tried on version trixbox 1.0 I did manage to get voicemails
    accepted and even voicemail light to flash on the phone
    but with 1.1 I can not even get that far.

    Odd thing that did happen a few months ago with *@H I had the same problem
    could not get voicemail to work, took
    the unit round to a friends, plugged it in and all emails started to be sent
     
    RH, Jul 11, 2006
    #1
    1. Advertising

  2. RH

    paul123 Guest

    RH wrote:
    > Any bods help me out here as to what the correct way to get voicemail
    > emailing is. been trying but can not find any real doco
    >
    > I am running trixbox 1.1
    >
    > I install the voicemail option in trixbox and set up email for voicemail and
    > followed some advice from nerdvitties site
    > Change etc/hosts file to give the second line my domian name ( I am on a
    > fixed IP so have static name as well)
    > changed /etc/asterisk/vm_general.inc to have a correct from email address
    > then issued echo CGasterisk.dyndns.org >> sendmail.cf
    >
    > When I restart I still get no voice mail, but the the webserver function has
    > died
    >
    > on some sites it has talked about setting up sendmail but I cannot find
    > those links now
    >
    > When I try and leave voice mail and confirm it complains about an error
    >
    > Last time I tried on version trixbox 1.0 I did manage to get voicemails
    > accepted and even voicemail light to flash on the phone
    > but with 1.1 I can not even get that far.
    >
    > Odd thing that did happen a few months ago with *@H I had the same problem
    > could not get voicemail to work, took
    > the unit round to a friends, plugged it in and all emails started to be sent


    Don't know if this'll help, but, to setup sendmail, enter as root on
    your Trixbox machine, then type in:
    setup-mail

    I've never had to change the host file to get voicemail by email to
    work.
     
    paul123, Jul 11, 2006
    #2
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Merlin Zener

    yet another yEnc question

    Merlin Zener, Jul 18, 2003, in forum: Firefox
    Replies:
    1
    Views:
    1,152
    Roger Vicker, CCP
    Jul 19, 2003
  2. PL
    Replies:
    4
    Views:
    639
  3. Replies:
    0
    Views:
    875
  4. Tinus
    Replies:
    0
    Views:
    900
    Tinus
    Aug 25, 2006
  5. Matt
    Replies:
    19
    Views:
    1,622
    David Quinton
    Jan 7, 2007
Loading...

Share This Page