XP - requires quote marks typed twice

Discussion in 'NZ Computing' started by Patrick Dunford, Jul 14, 2004.

  1. We have a number of XP machines all installed from a CD on Ministry of
    Education schools license.

    On every single one of them, whenever you type any text in a window,
    like my news client that I am writing in now, in order to enter a set of
    quote marks, the " key has to be pressed twice (and then shows "")

    Of course, this is so you can type characters like accented vowels.
    However these aren't used much in NZ and so it shouldn't force you to
    double-type quote marks etc.

    Does anyone know why XP requires this?
     
    Patrick Dunford, Jul 14, 2004
    #1
    1. Advertising

  2. Patrick Dunford

    Patrick Bold Guest

    "Patrick Dunford" <> wrote in message
    news:ey4Jc.8166$...
    > We have a number of XP machines all installed from a CD on Ministry of
    > Education schools license.
    >
    > On every single one of them, whenever you type any text in a window,
    > like my news client that I am writing in now, in order to enter a set

    of
    > quote marks, the " key has to be pressed twice (and then shows "")
    >
    > Of course, this is so you can type characters like accented vowels.
    > However these aren't used much in NZ and so it shouldn't force you to
    > double-type quote marks etc.
    >
    > Does anyone know why XP requires this?


    Control Panel | Regional and Language Options | Languages | Details --
    install the standard keyboard instead of what you currently have, the
    US-International Keyboard
     
    Patrick Bold, Jul 14, 2004
    #2
    1. Advertising

  3. In article <>, says...
    > "Patrick Dunford" <> wrote in message
    > news:ey4Jc.8166$...
    > > We have a number of XP machines all installed from a CD on Ministry of
    > > Education schools license.
    > >
    > > On every single one of them, whenever you type any text in a window,
    > > like my news client that I am writing in now, in order to enter a set

    > of
    > > quote marks, the " key has to be pressed twice (and then shows "")
    > >
    > > Of course, this is so you can type characters like accented vowels.
    > > However these aren't used much in NZ and so it shouldn't force you to
    > > double-type quote marks etc.
    > >
    > > Does anyone know why XP requires this?

    >
    > Control Panel | Regional and Language Options | Languages | Details --
    > install the standard keyboard instead of what you currently have, the
    > US-International Keyboard


    what is the name of the standard keyboard?
     
    Patrick Dunford, Jul 14, 2004
    #3
  4. On Thu, 15 Jul 2004 00:36:26 +1200, Patrick Dunford
    <> wrote:

    >> Control Panel | Regional and Language Options | Languages | Details --
    >> install the standard keyboard instead of what you currently have, the
    >> US-International Keyboard

    >
    >what is the name of the standard keyboard?


    It's just called 'US'


    --
    Kristofer Clayton (KJClayton)
    Gisborne, New Zealand
     
    Kristofer Clayton, Jul 14, 2004
    #4
  5. Patrick Dunford

    Ralph Fox Guest

    On Thu, 15 Jul 2004 00:36:26 +1200, in message
    <>, Patrick Dunford wrote:

    > In article <>, says...
    > > "Patrick Dunford" <> wrote in message
    > > news:ey4Jc.8166$...
    > > > We have a number of XP machines all installed from a CD on Ministry of
    > > > Education schools license.
    > > >
    > > > On every single one of them, whenever you type any text in a window,
    > > > like my news client that I am writing in now, in order to enter a set

    > > of
    > > > quote marks, the " key has to be pressed twice (and then shows "")


    To get a single ", press " then space.

    > > > Of course, this is so you can type characters like accented vowels.
    > > > However these aren't used much in NZ and so it shouldn't force you to
    > > > double-type quote marks etc.
    > > >
    > > > Does anyone know why XP requires this?

    > >
    > > Control Panel | Regional and Language Options | Languages | Details --
    > > install the standard keyboard instead of what you currently have, the
    > > US-International Keyboard

    >
    > what is the name of the standard keyboard?



    http://www.microsoft.com/globaldev/reference/keyboards.aspx [*Warning*: IE-only site]


    If your keyboard has the US layout (e.g. Shift+3 is #) like most PCs in NZ
    do, then the standard keyboard setting in NZ is "United States English",
    also called "US" or "United States 101" on older versions of Windows.

    Other choices include
    • US-International
    • US Ireland Extended from http://www.smo.uhi.ac.uk/~oduibhin/mearchlar/gaelicus.htm
    • Polish (programmers)




    --
    Cheers,
    Ralph

    Change is inevitable. Progress is optional.
     
    Ralph Fox, Jul 14, 2004
    #5
  6. Patrick Dunford wrote:
    >>Control Panel | Regional and Language Options | Languages | Details --
    >>install the standard keyboard instead of what you currently have, the
    >>US-International Keyboard


    > what is the name of the standard keyboard?


    US Keyboard I think. note the lack of international in the name.
     
    Dave - Dave.net.nz, Jul 14, 2004
    #6
  7. In article <>,
    -echo.invalid says...
    > On Thu, 15 Jul 2004 00:36:26 +1200, in message
    > <>, Patrick Dunford wrote:
    >
    > > In article <>, says...
    > > > "Patrick Dunford" <> wrote in message
    > > > news:ey4Jc.8166$...
    > > > > We have a number of XP machines all installed from a CD on Ministry of
    > > > > Education schools license.
    > > > >
    > > > > On every single one of them, whenever you type any text in a window,
    > > > > like my news client that I am writing in now, in order to enter a set
    > > > of
    > > > > quote marks, the " key has to be pressed twice (and then shows "")

    >
    > To get a single ", press " then space.


    Bollocks. This is not the default behaviour in any other version of
    Windows. When I type " I expect to see " on the screen.
     
    Patrick Dunford, Jul 15, 2004
    #7
  8. Patrick Dunford wrote:
    >>>>>quote marks, the " key has to be pressed twice (and then shows "")


    >>To get a single ", press " then space.


    > Bollocks. This is not the default behaviour in any other version of
    > Windows. When I type " I expect to see " on the screen.


    It is the default behaviour if you happen to install the
    US-International Keyoard Drivers.
     
    Dave - Dave.net.nz, Jul 15, 2004
    #8
  9. Patrick Dunford

    theseus Guest

    "Dave - Dave.net.nz" <dave@no_spam_here_dave.net.nz> wrote in message
    news:...
    > Patrick Dunford wrote:
    > >>>>>quote marks, the " key has to be pressed twice (and then shows "")

    >
    > >>To get a single ", press " then space.

    >
    > > Bollocks. This is not the default behaviour in any other version of
    > > Windows. When I type " I expect to see " on the screen.

    >
    > It is the default behaviour if you happen to install the
    > US-International Keyoard Drivers.


    To see why, try typing " then e or o
    You will find other characters on the keyboard that behave the same way.
    They are used by multicultural Un American foreigners
     
    theseus, Jul 15, 2004
    #9
  10. Patrick Dunford

    Patrick Bold Guest

    "Dave - Dave.net.nz" <dave@no_spam_here_dave.net.nz> wrote in message
    news:...

    > Patrick Dunford wrote:
    > >>>>>quote marks, the " key has to be pressed twice (and then shows

    "")
    >
    > >>To get a single ", press " then space.

    >
    > > Bollocks. This is not the default behaviour in any other version of
    > > Windows. When I type " I expect to see " on the screen.

    >
    > It is the default behaviour if you happen to install the
    > US-International Keyoard Drivers.


    Yes. This is not a "Windows" problem, Patrick, or an "XP" problem. It's
    a simple matter of choosing the right installation option. Whoever
    configured the setup cd you're using obviously made a mistake. But
    hey -- now you've learned something new yourself.
     
    Patrick Bold, Jul 15, 2004
    #10
  11. On Thu, 15 Jul 2004 01:14:23 -0400, "Patrick Bold" <>
    wrote:

    >"Dave - Dave.net.nz" <dave@no_spam_here_dave.net.nz> wrote in message
    >news:...
    >
    >> Patrick Dunford wrote:
    >> >>>>>quote marks, the " key has to be pressed twice (and then shows

    >"")
    >>
    >> >>To get a single ", press " then space.

    >>
    >> > Bollocks. This is not the default behaviour in any other version of
    >> > Windows. When I type " I expect to see " on the screen.

    >>
    >> It is the default behaviour if you happen to install the
    >> US-International Keyoard Drivers.

    >
    >Yes. This is not a "Windows" problem, Patrick, or an "XP" problem. It's
    >a simple matter of choosing the right installation option. Whoever
    >configured the setup cd you're using obviously made a mistake. But
    >hey -- now you've learned something new yourself.
    >




    The Keyboard can be changed at any time..
     
    The GHOST of WOGER., Jul 15, 2004
    #11
  12. Patrick Dunford

    Ryan Jacobs Guest

    "The GHOST of WOGER." <> wrote in message
    news:...
    > On Thu, 15 Jul 2004 01:14:23 -0400, "Patrick Bold" <>
    > wrote:
    >
    > >"Dave - Dave.net.nz" <dave@no_spam_here_dave.net.nz> wrote in message
    > >news:...
    > >
    > >> Patrick Dunford wrote:
    > >> >>>>>quote marks, the " key has to be pressed twice (and then shows

    > >"")
    > >>
    > >> >>To get a single ", press " then space.
    > >>
    > >> > Bollocks. This is not the default behaviour in any other version of
    > >> > Windows. When I type " I expect to see " on the screen.
    > >>
    > >> It is the default behaviour if you happen to install the
    > >> US-International Keyoard Drivers.

    > >
    > >Yes. This is not a "Windows" problem, Patrick, or an "XP" problem. It's
    > >a simple matter of choosing the right installation option. Whoever
    > >configured the setup cd you're using obviously made a mistake. But
    > >hey -- now you've learned something new yourself.
    > >

    >
    >
    >
    > The Keyboard can be changed at any time..
    >
    >


    Well yes. Just like Dickford - you missed the point!

    The problem is clearly a PEBKAC error. No OS can safely account for the
    PEBKAC error - not even the holy grail known as Linux.

    RJ out.
     
    Ryan Jacobs, Jul 15, 2004
    #12
  13. Patrick Dunford

    Ralph Fox Guest

    On Thu, 15 Jul 2004 17:59:39 +1200, in message
    <>, The GHOST of WOGER. wrote:

    > The Keyboard can be changed at any time..


    That is correct. I can switch keyboard "drivers" in 2 seconds.

    I have an icon in the system tray to switch keyboard "drivers" between
    'US' and 'US-International' (and a few others I hardly ever use, such
    as 'Polish programmers' and 'US-Esperanto').



    --
    Cheers,
    Ralph

    Change is inevitable. Progress is optional.
     
    Ralph Fox, Jul 15, 2004
    #13
  14. Patrick Dunford

    Ralph Fox Guest

    On Thu, 15 Jul 2004 14:28:33 +1200, in message
    <>, Patrick Dunford wrote:

    > > > > > On every single one of them, whenever you type any text in a window,
    > > > > > like my news client that I am writing in now, in order to enter a set
    > > > > of
    > > > > > quote marks, the " key has to be pressed twice (and then shows "")

    > >
    > > To get a single ", press " then space.

    >
    > Bollocks.



    It appears from your description that those PCs have been _configured_
    with the "US-International" keyboard driver.

    On PCs which have been configured this way, to get a set of quote marks
    one does NOT HAVE TO press the " key twice.

     • Pressing the " key twice will show ""
     • Pressing the key " once followed by the space bar will show "

    Try it on those PCs (before you reconfigure them) and report back.


    > This is not the default behaviour in any other version of
    > Windows.



    This behaviour is nothing to do with the _version_ of Windows.

    This is a _configuration_ option, from the Win95 "PanEuro" version onwards.
    In Win XP it is controlled by the language/keyboard setting at
    Control Panel -> Regional and Language Options -> Languages -> Details


    Let's recap in the thread so far

    1. You described the problem and asked "why XP requires this".
    2. You got a reply which said to change the XP language/keyboard
    setting from "US-International" to the standard keyboard.
    3. You asked what the standard keyboard was.
    4. You got several replies (including mine) saying to use the "US"
    keyboard (i.e. without the "International").


    Have you not read any of the several replies to your request?
    Did you not understand them?


    [Patrick Dunford]
    | | > > > Does anyone know why XP requires this?

    [Patrick Bold]
    | | > > Control Panel | Regional and Language Options | Languages | Details --
    | | > > install the standard keyboard instead of what you currently have, the
    | | > > US-International Keyboard

    [Patrick Dunford]
    | | > what is the name of the standard keyboard?

    [Kristofer Clayton]
    | | It's just called 'US'

    [Ralph Fox]
    | | called "US"

    [Dave]
    | | US Keyboard I think. note the lack of international in the name.



    > When I type " I expect to see " on the screen.


    So have you reconfigured those PCs yet, as per the replies?


    For your information, Windows has more than one choice of
    language/keyboard setting for use with physical keyboards which have
    the US layout. Some of those choices are

    A. "US"

    For the US and other places where characters like accented vowels
    aren't used much.

    B. "US-International"

    For Western European languages when there is a need to enter
    characters like accented vowels while using a US physical keyboard.

    C. "Polish Programmers"

    For the Polish language, when there is a need to enter Polish
    characters like Å and Ä™ while using a US physical keyboard.


    You can see the so-called "dead" keys and the key-to-character mappings,
    in visual format, from this Microsoft web page.

    http://www.microsoft.com/globaldev/reference/keyboards.aspx [*Warning*: IE-only site]


    --
    Cheers,
    Ralph

    Change is inevitable. Progress is optional.
     
    Ralph Fox, Jul 15, 2004
    #14
  15. Ryan Jacobs wrote:
    > The problem is clearly a PEBKAC error. No OS can safely account for the
    > PEBKAC error - not even the holy grail known as Linux.


    although because of the steeper learning curve, less PEBKAC errors seem
    to surface.
     
    Dave - Dave.net.nz, Jul 15, 2004
    #15
  16. Patrick Dunford

    AD. Guest

    On Fri, 16 Jul 2004 08:42:16 +1200, Dave - Dave.net.nz wrote:

    > Ryan Jacobs wrote:
    >> The problem is clearly a PEBKAC error. No OS can safely account for the
    >> PEBKAC error - not even the holy grail known as Linux.

    >
    > although because of the steeper learning curve, less PEBKAC errors seem to
    > surface.


    Probably more like there is an expectation that a problem is a PEBKAC
    rather than a bug :)

    Maybe that's the downside of ease of use - the users don't go looking for
    ways of solving problems and just assume it's a bug.

    Cheers
    Anton
     
    AD., Jul 15, 2004
    #16
  17. In article <>,
    says...
    > On Fri, 16 Jul 2004 08:42:16 +1200, Dave - Dave.net.nz wrote:
    >
    > > Ryan Jacobs wrote:
    > >> The problem is clearly a PEBKAC error. No OS can safely account for the
    > >> PEBKAC error - not even the holy grail known as Linux.

    > >
    > > although because of the steeper learning curve, less PEBKAC errors seem to
    > > surface.

    >
    > Probably more like there is an expectation that a problem is a PEBKAC
    > rather than a bug :)
    >
    > Maybe that's the downside of ease of use - the users don't go looking for
    > ways of solving problems and just assume it's a bug.


    US-International or whatever is the DEFAULT installation option for XP,
    it's not like I tried to change the setting
     
    Patrick Dunford, Jul 16, 2004
    #17
  18. Patrick Dunford wrote:
    > US-International or whatever is the DEFAULT installation option for XP,
    > it's not like I tried to change the setting


    wow, odd, isnt on any of the machine I deal with...
    ~200 at work, and ~10 at home or friends.
     
    Dave - Dave.net.nz, Jul 16, 2004
    #18
  19. Patrick Dunford

    Ryan Jacobs Guest

    "Dave - Dave.net.nz" <dave@no_spam_here_dave.net.nz> wrote in message
    news:...
    > Patrick Dunford wrote:
    > > US-International or whatever is the DEFAULT installation option for XP,
    > > it's not like I tried to change the setting

    >
    > wow, odd, isnt on any of the machine I deal with...
    > ~200 at work, and ~10 at home or friends.



    Even odder......

    Of the 2500 that I support, it isn't either.

    I think this could actually be worse than a PEBKAC situation. It's time to
    upgrade the problem to a ID-ten-tee status.

    RJ out.
     
    Ryan Jacobs, Jul 16, 2004
    #19
  20. Ryan Jacobs wrote:
    > I think this could actually be worse than a PEBKAC situation. It's time to
    > upgrade the problem to a ID-ten-tee status.


    wow, havent heard that term in a while.
     
    Dave - Dave.net.nz, Jul 16, 2004
    #20
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Flea-bitten dog

    Deleting previously typed search entries

    Flea-bitten dog, Sep 18, 2005, in forum: Firefox
    Replies:
    4
    Views:
    4,229
    Jedi Fans
    Sep 18, 2005
  2. Bill

    Scan typed page into a file

    Bill, Dec 3, 2003, in forum: Computer Support
    Replies:
    4
    Views:
    656
    Flighty
    Dec 3, 2003
  3. Quean
    Replies:
    1
    Views:
    363
    Yddap
    May 11, 2004
  4. John C Williams
    Replies:
    7
    Views:
    635
    °Mike°
    May 27, 2004
  5. not dust marks - water marks!

    , Apr 14, 2005, in forum: Digital Photography
    Replies:
    0
    Views:
    406
Loading...

Share This Page