XP Pro problems with DEP

Discussion in 'Windows 64bit' started by =?Utf-8?B?cG91bHRlcjkw?=, Nov 22, 2006.

  1. Hi all , just a few details about my situation :

    1) Specifications of my PC listed by AIDA 32 v3.93
    Acer 5633WLMI version 2.80 XP service pack SP2 , Media Center Edition
    2005
    Multi CPU T5500 1.66 Ghz , 1662 MHZ
    Memory /M1
    SODIMM Synchronous 512 MO , size 32 bits
    Memory/M2
    SODIMM Synchronous 512 MO, size 32 bits

    Physical Memory
    Total 1022 MO
    Used 462 MO
    Available 559 MO
    Usage 45%

    Swap zone
    Total 923 MO
    Used 387 MO
    Available 535 MO
    Usage 42%

    Virtual memory
    Total 1945 MO
    Used 849 MO
    Available 1095 MO
    Usage 44%

    BIOS type Phoenix
    System BIOS date 09/01/06
    Video BIOS date 08/30/06

    2) I red in the documentation
    (http://msdn2.microsoft.com/en-us/library/ms791539(d=printer).aspx

    The /noexecute parameter is effective only on 32-bit-processes.It enables
    software enforced DEP and,if the processor supports DEP,it also enables
    hardware-enforced DEP.
    On 64-bit processes,DEP is enabled by default and cannot be disabled
    (equivalent to /noexecute=AlwaysOn).For these processes, the /noexecute
    parameter is ignored.On a 64-bit operating system,the /noexecute parameter
    affects only 32-bit processes running on the system .

    Question is :
    Having 2 memory SODIMM 32 bits each ,does it mean I am running 64-bit ?
    If yes , even if I want to turn off the DEP , I CANNOT as explained above !!!

    I tried to turn off DEP (/noexecute=AlwaysOff) but I am still receiving
    messages informing that whatever programs or applications . exe has problem
    and need to be closed . I think this PC is crap and I think I will never
    get rid of this bug , I have to send it back to reseller !

    Any genious ideas ????
    =?Utf-8?B?cG91bHRlcjkw?=, Nov 22, 2006
    #1
    1. Advertising

  2. =?Utf-8?B?cG91bHRlcjkw?=

    John Barnes Guest

    Hopefully your question will make sense to someone, but you turn DEP off or
    on in system properties / advanced / performance / Data Execution
    Prevention


    "poulter90" <> wrote in message
    news:...
    > Hi all , just a few details about my situation :
    >
    > 1) Specifications of my PC listed by AIDA 32 v3.93
    > Acer 5633WLMI version 2.80 XP service pack SP2 , Media Center Edition
    > 2005
    > Multi CPU T5500 1.66 Ghz , 1662 MHZ
    > Memory /M1
    > SODIMM Synchronous 512 MO , size 32 bits
    > Memory/M2
    > SODIMM Synchronous 512 MO, size 32 bits
    >
    > Physical Memory
    > Total 1022 MO
    > Used 462 MO
    > Available 559 MO
    > Usage 45%
    >
    > Swap zone
    > Total 923 MO
    > Used 387 MO
    > Available 535 MO
    > Usage 42%
    >
    > Virtual memory
    > Total 1945 MO
    > Used 849 MO
    > Available 1095 MO
    > Usage 44%
    >
    > BIOS type Phoenix
    > System BIOS date 09/01/06
    > Video BIOS date 08/30/06
    >
    > 2) I red in the documentation
    > (http://msdn2.microsoft.com/en-us/library/ms791539(d=printer).aspx
    >
    > The /noexecute parameter is effective only on 32-bit-processes.It enables
    > software enforced DEP and,if the processor supports DEP,it also enables
    > hardware-enforced DEP.
    > On 64-bit processes,DEP is enabled by default and cannot be disabled
    > (equivalent to /noexecute=AlwaysOn).For these processes, the /noexecute
    > parameter is ignored.On a 64-bit operating system,the /noexecute parameter
    > affects only 32-bit processes running on the system .
    >
    > Question is :
    > Having 2 memory SODIMM 32 bits each ,does it mean I am running 64-bit ?
    > If yes , even if I want to turn off the DEP , I CANNOT as explained above
    > !!!
    >
    > I tried to turn off DEP (/noexecute=AlwaysOff) but I am still receiving
    > messages informing that whatever programs or applications . exe has
    > problem
    > and need to be closed . I think this PC is crap and I think I will never
    > get rid of this bug , I have to send it back to reseller !
    >
    > Any genious ideas ????
    >
    >
    >
    >
    John Barnes, Nov 22, 2006
    #2
    1. Advertising

  3. I don't know, John - My HP Notebook is 64bit and I have had major head-aches
    about some processes refusing to pass on execution via some DLL or other, I
    am not allowed to disable DEP, (alternatively: have not found a way) which
    wrinkles my ass.

    Tony. . .
    Tony Sperling, Nov 22, 2006
    #3
  4. =?Utf-8?B?cG91bHRlcjkw?=

    John Barnes Guest

    Have you checked the alternate box and entered the program you are having a
    problem with. I have had to do it with some Roxio programs. Ultimately, it
    would be up to any restrictions of the system or os if there are any.


    "Tony Sperling" <> wrote in message
    news:...
    >I don't know, John - My HP Notebook is 64bit and I have had major
    >head-aches
    > about some processes refusing to pass on execution via some DLL or other,
    > I
    > am not allowed to disable DEP, (alternatively: have not found a way) which
    > wrinkles my ass.
    >
    > Tony. . .
    >
    >
    >
    John Barnes, Nov 22, 2006
    #4
  5. It's been a while, now. Don't remember all I've tried - I think I even had
    it ship off a message to MS about it, but I will check that!

    Thanks.

    Tony. . .


    "John Barnes" <> wrote in message
    news:...
    > Have you checked the alternate box and entered the program you are having

    a
    > problem with. I have had to do it with some Roxio programs. Ultimately,

    it
    > would be up to any restrictions of the system or os if there are any.
    >
    >
    > "Tony Sperling" <> wrote in message
    > news:...
    > >I don't know, John - My HP Notebook is 64bit and I have had major
    > >head-aches
    > > about some processes refusing to pass on execution via some DLL or

    other,
    > > I
    > > am not allowed to disable DEP, (alternatively: have not found a way)

    which
    > > wrinkles my ass.
    > >
    > > Tony. . .
    > >
    > >
    > >

    >
    Tony Sperling, Nov 22, 2006
    #5
  6. =?Utf-8?B?cG91bHRlcjkw?=

    John Barnes Guest

    I had to check the selection "turn on DEP for all programs and services
    except those I select" and then enter the appropriate program. I am in
    Vista now, where I can't install Roxio anyway. In fact since the drivers
    weren't signed, when it got to that point, when I selected to cancel, it
    made all my CD/DVD drives invisible and required a full install since no one
    proffered a less drastic solution. At least now I have it installed on two
    partitions and use one to make sure anything I try works, before installing
    it on the one I try to use regularly.

    "Tony Sperling" <> wrote in message
    news:...
    > It's been a while, now. Don't remember all I've tried - I think I even had
    > it ship off a message to MS about it, but I will check that!
    >
    > Thanks.
    >
    > Tony. . .
    >
    >
    > "John Barnes" <> wrote in message
    > news:...
    >> Have you checked the alternate box and entered the program you are having

    > a
    >> problem with. I have had to do it with some Roxio programs. Ultimately,

    > it
    >> would be up to any restrictions of the system or os if there are any.
    >>
    >>
    >> "Tony Sperling" <> wrote in message
    >> news:...
    >> >I don't know, John - My HP Notebook is 64bit and I have had major
    >> >head-aches
    >> > about some processes refusing to pass on execution via some DLL or

    > other,
    >> > I
    >> > am not allowed to disable DEP, (alternatively: have not found a way)

    > which
    >> > wrinkles my ass.
    >> >
    >> > Tony. . .
    >> >
    >> >
    >> >

    >>

    >
    >
    John Barnes, Nov 22, 2006
    #6
  7. Ah, well - that I could have missed. Turn'em off one-by-one!

    Yes, now that you're saying it, I could believe that.


    Tony. . .


    "John Barnes" <> wrote in message
    news:uyomz%...
    > I had to check the selection "turn on DEP for all programs and services
    > except those I select" and then enter the appropriate program. I am in
    > Vista now, where I can't install Roxio anyway. In fact since the drivers
    > weren't signed, when it got to that point, when I selected to cancel, it
    > made all my CD/DVD drives invisible and required a full install since no

    one
    > proffered a less drastic solution. At least now I have it installed on

    two
    > partitions and use one to make sure anything I try works, before

    installing
    > it on the one I try to use regularly.
    >
    > "Tony Sperling" <> wrote in message
    > news:...
    > > It's been a while, now. Don't remember all I've tried - I think I even

    had
    > > it ship off a message to MS about it, but I will check that!
    > >
    > > Thanks.
    > >
    > > Tony. . .
    > >
    > >
    > > "John Barnes" <> wrote in message
    > > news:...
    > >> Have you checked the alternate box and entered the program you are

    having
    > > a
    > >> problem with. I have had to do it with some Roxio programs.

    Ultimately,
    > > it
    > >> would be up to any restrictions of the system or os if there are any.
    > >>
    > >>
    > >> "Tony Sperling" <> wrote in message
    > >> news:...
    > >> >I don't know, John - My HP Notebook is 64bit and I have had major
    > >> >head-aches
    > >> > about some processes refusing to pass on execution via some DLL or

    > > other,
    > >> > I
    > >> > am not allowed to disable DEP, (alternatively: have not found a way)

    > > which
    > >> > wrinkles my ass.
    > >> >
    > >> > Tony. . .
    > >> >
    > >> >
    > >> >
    > >>

    > >
    > >

    >
    Tony Sperling, Nov 22, 2006
    #7
  8. Related to this documentation , it seems to be impossible to disable DEP !!!

    (http://msdn2.microsoft.com/en-us/library/ms791539(d=printer).aspx

    The /noexecute parameter is effective only on 32-bit-processes.It enables
    software enforced DEP and,if the processor supports DEP,it also enables
    hardware-enforced DEP.
    On 64-bit processes,DEP is enabled by default and cannot be disabled
    (equivalent to /noexecute=AlwaysOn).For these processes, the /noexecute
    parameter is ignored.On a 64-bit operating system,the /noexecute parameter
    affects only 32-bit processes running on the system .

    Unless someone has already tried following option in BOOT.IN file ???
    /noexecute=AlwaysOff /nopae or
    /noexecute=AlwaysOff / pae

    ???????????????




    "John Barnes" wrote:

    > Hopefully your question will make sense to someone, but you turn DEP off or
    > on in system properties / advanced / performance / Data Execution
    > Prevention
    >
    >
    > "poulter90" <> wrote in message
    > news:...
    > > Hi all , just a few details about my situation :
    > >
    > > 1) Specifications of my PC listed by AIDA 32 v3.93
    > > Acer 5633WLMI version 2.80 XP service pack SP2 , Media Center Edition
    > > 2005
    > > Multi CPU T5500 1.66 Ghz , 1662 MHZ
    > > Memory /M1
    > > SODIMM Synchronous 512 MO , size 32 bits
    > > Memory/M2
    > > SODIMM Synchronous 512 MO, size 32 bits
    > >
    > > Physical Memory
    > > Total 1022 MO
    > > Used 462 MO
    > > Available 559 MO
    > > Usage 45%
    > >
    > > Swap zone
    > > Total 923 MO
    > > Used 387 MO
    > > Available 535 MO
    > > Usage 42%
    > >
    > > Virtual memory
    > > Total 1945 MO
    > > Used 849 MO
    > > Available 1095 MO
    > > Usage 44%
    > >
    > > BIOS type Phoenix
    > > System BIOS date 09/01/06
    > > Video BIOS date 08/30/06
    > >
    > > 2) I red in the documentation
    > > (http://msdn2.microsoft.com/en-us/library/ms791539(d=printer).aspx
    > >
    > > The /noexecute parameter is effective only on 32-bit-processes.It enables
    > > software enforced DEP and,if the processor supports DEP,it also enables
    > > hardware-enforced DEP.
    > > On 64-bit processes,DEP is enabled by default and cannot be disabled
    > > (equivalent to /noexecute=AlwaysOn).For these processes, the /noexecute
    > > parameter is ignored.On a 64-bit operating system,the /noexecute parameter
    > > affects only 32-bit processes running on the system .
    > >
    > > Question is :
    > > Having 2 memory SODIMM 32 bits each ,does it mean I am running 64-bit ?
    > > If yes , even if I want to turn off the DEP , I CANNOT as explained above
    > > !!!
    > >
    > > I tried to turn off DEP (/noexecute=AlwaysOff) but I am still receiving
    > > messages informing that whatever programs or applications . exe has
    > > problem
    > > and need to be closed . I think this PC is crap and I think I will never
    > > get rid of this bug , I have to send it back to reseller !
    > >
    > > Any genious ideas ????
    > >
    > >
    > >
    > >

    >
    >
    =?Utf-8?B?cG91bHRlcjkw?=, Nov 23, 2006
    #8
  9. =?Utf-8?B?cG91bHRlcjkw?=

    Jane C Guest

    I wouldn't let this worry you. You are running a 32 bit operating system.
    All processes on your computer are 32 bit. Your 2 SODIMMS at 32 bits each
    do not make anything run at 64 bit.


    --
    Jane, not plain ;) 64 bit enabled :)
    Batteries not included. Braincell on vacation ;-)
    "poulter90" <> wrote in message
    news:...
    > Related to this documentation , it seems to be impossible to disable DEP
    > !!!
    >
    > (http://msdn2.microsoft.com/en-us/library/ms791539(d=printer).aspx
    >
    > The /noexecute parameter is effective only on 32-bit-processes.It enables
    > software enforced DEP and,if the processor supports DEP,it also enables
    > hardware-enforced DEP.
    > On 64-bit processes,DEP is enabled by default and cannot be disabled
    > (equivalent to /noexecute=AlwaysOn).For these processes, the /noexecute
    > parameter is ignored.On a 64-bit operating system,the /noexecute parameter
    > affects only 32-bit processes running on the system .
    >
    > Unless someone has already tried following option in BOOT.IN file ???
    > /noexecute=AlwaysOff /nopae or
    > /noexecute=AlwaysOff / pae
    >
    > ???????????????
    >
    >
    >
    >
    > "John Barnes" wrote:
    >
    >> Hopefully your question will make sense to someone, but you turn DEP off
    >> or
    >> on in system properties / advanced / performance / Data Execution
    >> Prevention
    >>
    >>
    >> "poulter90" <> wrote in message
    >> news:...
    >> > Hi all , just a few details about my situation :
    >> >
    >> > 1) Specifications of my PC listed by AIDA 32 v3.93
    >> > Acer 5633WLMI version 2.80 XP service pack SP2 , Media Center
    >> > Edition
    >> > 2005
    >> > Multi CPU T5500 1.66 Ghz , 1662 MHZ
    >> > Memory /M1
    >> > SODIMM Synchronous 512 MO , size 32 bits
    >> > Memory/M2
    >> > SODIMM Synchronous 512 MO, size 32 bits
    >> >
    >> > Physical Memory
    >> > Total 1022 MO
    >> > Used 462 MO
    >> > Available 559 MO
    >> > Usage 45%
    >> >
    >> > Swap zone
    >> > Total 923 MO
    >> > Used 387 MO
    >> > Available 535 MO
    >> > Usage 42%
    >> >
    >> > Virtual memory
    >> > Total 1945 MO
    >> > Used 849 MO
    >> > Available 1095 MO
    >> > Usage 44%
    >> >
    >> > BIOS type Phoenix
    >> > System BIOS date 09/01/06
    >> > Video BIOS date 08/30/06
    >> >
    >> > 2) I red in the documentation
    >> > (http://msdn2.microsoft.com/en-us/library/ms791539(d=printer).aspx
    >> >
    >> > The /noexecute parameter is effective only on 32-bit-processes.It
    >> > enables
    >> > software enforced DEP and,if the processor supports DEP,it also enables
    >> > hardware-enforced DEP.
    >> > On 64-bit processes,DEP is enabled by default and cannot be disabled
    >> > (equivalent to /noexecute=AlwaysOn).For these processes, the /noexecute
    >> > parameter is ignored.On a 64-bit operating system,the /noexecute
    >> > parameter
    >> > affects only 32-bit processes running on the system .
    >> >
    >> > Question is :
    >> > Having 2 memory SODIMM 32 bits each ,does it mean I am running 64-bit ?
    >> > If yes , even if I want to turn off the DEP , I CANNOT as explained
    >> > above
    >> > !!!
    >> >
    >> > I tried to turn off DEP (/noexecute=AlwaysOff) but I am still receiving
    >> > messages informing that whatever programs or applications . exe has
    >> > problem
    >> > and need to be closed . I think this PC is crap and I think I will
    >> > never
    >> > get rid of this bug , I have to send it back to reseller !
    >> >
    >> > Any genious ideas ????
    >> >
    >> >
    >> >
    >> >

    >>
    >>
    Jane C, Nov 23, 2006
    #9
  10. Thanks Jane , although I cannot get rid of this DEP problem , I am pleased I
    can try using several options in the BOOT.INI file to solve it .

    Could be a malware on my memory stick !



    "Jane C" wrote:

    > I wouldn't let this worry you. You are running a 32 bit operating system.
    > All processes on your computer are 32 bit. Your 2 SODIMMS at 32 bits each
    > do not make anything run at 64 bit.
    >
    >
    > --
    > Jane, not plain ;) 64 bit enabled :)
    > Batteries not included. Braincell on vacation ;-)
    > "poulter90" <> wrote in message
    > news:...
    > > Related to this documentation , it seems to be impossible to disable DEP
    > > !!!
    > >
    > > (http://msdn2.microsoft.com/en-us/library/ms791539(d=printer).aspx
    > >
    > > The /noexecute parameter is effective only on 32-bit-processes.It enables
    > > software enforced DEP and,if the processor supports DEP,it also enables
    > > hardware-enforced DEP.
    > > On 64-bit processes,DEP is enabled by default and cannot be disabled
    > > (equivalent to /noexecute=AlwaysOn).For these processes, the /noexecute
    > > parameter is ignored.On a 64-bit operating system,the /noexecute parameter
    > > affects only 32-bit processes running on the system .
    > >
    > > Unless someone has already tried following option in BOOT.IN file ???
    > > /noexecute=AlwaysOff /nopae or
    > > /noexecute=AlwaysOff / pae
    > >
    > > ???????????????
    > >
    > >
    > >
    > >
    > > "John Barnes" wrote:
    > >
    > >> Hopefully your question will make sense to someone, but you turn DEP off
    > >> or
    > >> on in system properties / advanced / performance / Data Execution
    > >> Prevention
    > >>
    > >>
    > >> "poulter90" <> wrote in message
    > >> news:...
    > >> > Hi all , just a few details about my situation :
    > >> >
    > >> > 1) Specifications of my PC listed by AIDA 32 v3.93
    > >> > Acer 5633WLMI version 2.80 XP service pack SP2 , Media Center
    > >> > Edition
    > >> > 2005
    > >> > Multi CPU T5500 1.66 Ghz , 1662 MHZ
    > >> > Memory /M1
    > >> > SODIMM Synchronous 512 MO , size 32 bits
    > >> > Memory/M2
    > >> > SODIMM Synchronous 512 MO, size 32 bits
    > >> >
    > >> > Physical Memory
    > >> > Total 1022 MO
    > >> > Used 462 MO
    > >> > Available 559 MO
    > >> > Usage 45%
    > >> >
    > >> > Swap zone
    > >> > Total 923 MO
    > >> > Used 387 MO
    > >> > Available 535 MO
    > >> > Usage 42%
    > >> >
    > >> > Virtual memory
    > >> > Total 1945 MO
    > >> > Used 849 MO
    > >> > Available 1095 MO
    > >> > Usage 44%
    > >> >
    > >> > BIOS type Phoenix
    > >> > System BIOS date 09/01/06
    > >> > Video BIOS date 08/30/06
    > >> >
    > >> > 2) I red in the documentation
    > >> > (http://msdn2.microsoft.com/en-us/library/ms791539(d=printer).aspx
    > >> >
    > >> > The /noexecute parameter is effective only on 32-bit-processes.It
    > >> > enables
    > >> > software enforced DEP and,if the processor supports DEP,it also enables
    > >> > hardware-enforced DEP.
    > >> > On 64-bit processes,DEP is enabled by default and cannot be disabled
    > >> > (equivalent to /noexecute=AlwaysOn).For these processes, the /noexecute
    > >> > parameter is ignored.On a 64-bit operating system,the /noexecute
    > >> > parameter
    > >> > affects only 32-bit processes running on the system .
    > >> >
    > >> > Question is :
    > >> > Having 2 memory SODIMM 32 bits each ,does it mean I am running 64-bit ?
    > >> > If yes , even if I want to turn off the DEP , I CANNOT as explained
    > >> > above
    > >> > !!!
    > >> >
    > >> > I tried to turn off DEP (/noexecute=AlwaysOff) but I am still receiving
    > >> > messages informing that whatever programs or applications . exe has
    > >> > problem
    > >> > and need to be closed . I think this PC is crap and I think I will
    > >> > never
    > >> > get rid of this bug , I have to send it back to reseller !
    > >> >
    > >> > Any genious ideas ????
    > >> >
    > >> >
    > >> >
    > >> >
    > >>
    > >>

    >
    =?Utf-8?B?cG91bHRlcjkw?=, Nov 23, 2006
    #10
  11. Do note what John said back there - you may not be able to turn DEP off, but
    you should be able to disable it for specific applications if you provide a
    name for it to deal with!

    Tony. . .


    "poulter90" <> wrote in message
    news:D...
    > Thanks Jane , although I cannot get rid of this DEP problem , I am pleased

    I
    > can try using several options in the BOOT.INI file to solve it .
    >
    > Could be a malware on my memory stick !
    >
    >
    >
    > "Jane C" wrote:
    >
    > > I wouldn't let this worry you. You are running a 32 bit operating

    system.
    > > All processes on your computer are 32 bit. Your 2 SODIMMS at 32 bits

    each
    > > do not make anything run at 64 bit.
    > >
    > >
    > > --
    > > Jane, not plain ;) 64 bit enabled :)
    > > Batteries not included. Braincell on vacation ;-)
    > > "poulter90" <> wrote in message
    > > news:...
    > > > Related to this documentation , it seems to be impossible to disable

    DEP
    > > > !!!
    > > >
    > > > (http://msdn2.microsoft.com/en-us/library/ms791539(d=printer).aspx
    > > >
    > > > The /noexecute parameter is effective only on 32-bit-processes.It

    enables
    > > > software enforced DEP and,if the processor supports DEP,it also

    enables
    > > > hardware-enforced DEP.
    > > > On 64-bit processes,DEP is enabled by default and cannot be disabled
    > > > (equivalent to /noexecute=AlwaysOn).For these processes, the

    /noexecute
    > > > parameter is ignored.On a 64-bit operating system,the /noexecute

    parameter
    > > > affects only 32-bit processes running on the system .
    > > >
    > > > Unless someone has already tried following option in BOOT.IN file ???
    > > > /noexecute=AlwaysOff /nopae or
    > > > /noexecute=AlwaysOff / pae
    > > >
    > > > ???????????????
    > > >
    > > >
    > > >
    > > >
    > > > "John Barnes" wrote:
    > > >
    > > >> Hopefully your question will make sense to someone, but you turn DEP

    off
    > > >> or
    > > >> on in system properties / advanced / performance / Data Execution
    > > >> Prevention
    > > >>
    > > >>
    > > >> "poulter90" <> wrote in message
    > > >> news:...
    > > >> > Hi all , just a few details about my situation :
    > > >> >
    > > >> > 1) Specifications of my PC listed by AIDA 32 v3.93
    > > >> > Acer 5633WLMI version 2.80 XP service pack SP2 , Media Center
    > > >> > Edition
    > > >> > 2005
    > > >> > Multi CPU T5500 1.66 Ghz , 1662 MHZ
    > > >> > Memory /M1
    > > >> > SODIMM Synchronous 512 MO , size 32 bits
    > > >> > Memory/M2
    > > >> > SODIMM Synchronous 512 MO, size 32 bits
    > > >> >
    > > >> > Physical Memory
    > > >> > Total 1022 MO
    > > >> > Used 462 MO
    > > >> > Available 559 MO
    > > >> > Usage 45%
    > > >> >
    > > >> > Swap zone
    > > >> > Total 923 MO
    > > >> > Used 387 MO
    > > >> > Available 535 MO
    > > >> > Usage 42%
    > > >> >
    > > >> > Virtual memory
    > > >> > Total 1945 MO
    > > >> > Used 849 MO
    > > >> > Available 1095 MO
    > > >> > Usage 44%
    > > >> >
    > > >> > BIOS type Phoenix
    > > >> > System BIOS date 09/01/06
    > > >> > Video BIOS date 08/30/06
    > > >> >
    > > >> > 2) I red in the documentation
    > > >> > (http://msdn2.microsoft.com/en-us/library/ms791539(d=printer).aspx
    > > >> >
    > > >> > The /noexecute parameter is effective only on 32-bit-processes.It
    > > >> > enables
    > > >> > software enforced DEP and,if the processor supports DEP,it also

    enables
    > > >> > hardware-enforced DEP.
    > > >> > On 64-bit processes,DEP is enabled by default and cannot be

    disabled
    > > >> > (equivalent to /noexecute=AlwaysOn).For these processes, the

    /noexecute
    > > >> > parameter is ignored.On a 64-bit operating system,the /noexecute
    > > >> > parameter
    > > >> > affects only 32-bit processes running on the system .
    > > >> >
    > > >> > Question is :
    > > >> > Having 2 memory SODIMM 32 bits each ,does it mean I am running

    64-bit ?
    > > >> > If yes , even if I want to turn off the DEP , I CANNOT as

    explained
    > > >> > above
    > > >> > !!!
    > > >> >
    > > >> > I tried to turn off DEP (/noexecute=AlwaysOff) but I am still

    receiving
    > > >> > messages informing that whatever programs or applications . exe

    has
    > > >> > problem
    > > >> > and need to be closed . I think this PC is crap and I think I will
    > > >> > never
    > > >> > get rid of this bug , I have to send it back to reseller !
    > > >> >
    > > >> > Any genious ideas ????
    > > >> >
    > > >> >
    > > >> >
    > > >> >
    > > >>
    > > >>

    > >
    Tony Sperling, Nov 23, 2006
    #11
  12. =?Utf-8?B?cG91bHRlcjkw?=

    John Barnes Guest

    Thanks Tony. I'm in X-64 and you follow the instructions I gave above,
    click on add and browse to the problem executable. Click okay when you find
    it and the problem is over for that one.


    "Tony Sperling" <> wrote in message
    news:...
    > Do note what John said back there - you may not be able to turn DEP off,
    > but
    > you should be able to disable it for specific applications if you provide
    > a
    > name for it to deal with!
    >
    > Tony. . .
    >
    >
    > "poulter90" <> wrote in message
    > news:D...
    >> Thanks Jane , although I cannot get rid of this DEP problem , I am
    >> pleased

    > I
    >> can try using several options in the BOOT.INI file to solve it .
    >>
    >> Could be a malware on my memory stick !
    >>
    >>
    >>
    >> "Jane C" wrote:
    >>
    >> > I wouldn't let this worry you. You are running a 32 bit operating

    > system.
    >> > All processes on your computer are 32 bit. Your 2 SODIMMS at 32 bits

    > each
    >> > do not make anything run at 64 bit.
    >> >
    >> >
    >> > --
    >> > Jane, not plain ;) 64 bit enabled :)
    >> > Batteries not included. Braincell on vacation ;-)
    >> > "poulter90" <> wrote in message
    >> > news:...
    >> > > Related to this documentation , it seems to be impossible to disable

    > DEP
    >> > > !!!
    >> > >
    >> > > (http://msdn2.microsoft.com/en-us/library/ms791539(d=printer).aspx
    >> > >
    >> > > The /noexecute parameter is effective only on 32-bit-processes.It

    > enables
    >> > > software enforced DEP and,if the processor supports DEP,it also

    > enables
    >> > > hardware-enforced DEP.
    >> > > On 64-bit processes,DEP is enabled by default and cannot be disabled
    >> > > (equivalent to /noexecute=AlwaysOn).For these processes, the

    > /noexecute
    >> > > parameter is ignored.On a 64-bit operating system,the /noexecute

    > parameter
    >> > > affects only 32-bit processes running on the system .
    >> > >
    >> > > Unless someone has already tried following option in BOOT.IN file
    >> > > ???
    >> > > /noexecute=AlwaysOff /nopae or
    >> > > /noexecute=AlwaysOff / pae
    >> > >
    >> > > ???????????????
    >> > >
    >> > >
    >> > >
    >> > >
    >> > > "John Barnes" wrote:
    >> > >
    >> > >> Hopefully your question will make sense to someone, but you turn DEP

    > off
    >> > >> or
    >> > >> on in system properties / advanced / performance / Data Execution
    >> > >> Prevention
    >> > >>
    >> > >>
    >> > >> "poulter90" <> wrote in message
    >> > >> news:...
    >> > >> > Hi all , just a few details about my situation :
    >> > >> >
    >> > >> > 1) Specifications of my PC listed by AIDA 32 v3.93
    >> > >> > Acer 5633WLMI version 2.80 XP service pack SP2 , Media Center
    >> > >> > Edition
    >> > >> > 2005
    >> > >> > Multi CPU T5500 1.66 Ghz , 1662 MHZ
    >> > >> > Memory /M1
    >> > >> > SODIMM Synchronous 512 MO , size 32 bits
    >> > >> > Memory/M2
    >> > >> > SODIMM Synchronous 512 MO, size 32 bits
    >> > >> >
    >> > >> > Physical Memory
    >> > >> > Total 1022 MO
    >> > >> > Used 462 MO
    >> > >> > Available 559 MO
    >> > >> > Usage 45%
    >> > >> >
    >> > >> > Swap zone
    >> > >> > Total 923 MO
    >> > >> > Used 387 MO
    >> > >> > Available 535 MO
    >> > >> > Usage 42%
    >> > >> >
    >> > >> > Virtual memory
    >> > >> > Total 1945 MO
    >> > >> > Used 849 MO
    >> > >> > Available 1095 MO
    >> > >> > Usage 44%
    >> > >> >
    >> > >> > BIOS type Phoenix
    >> > >> > System BIOS date 09/01/06
    >> > >> > Video BIOS date 08/30/06
    >> > >> >
    >> > >> > 2) I red in the documentation
    >> > >> > (http://msdn2.microsoft.com/en-us/library/ms791539(d=printer).aspx
    >> > >> >
    >> > >> > The /noexecute parameter is effective only on 32-bit-processes.It
    >> > >> > enables
    >> > >> > software enforced DEP and,if the processor supports DEP,it also

    > enables
    >> > >> > hardware-enforced DEP.
    >> > >> > On 64-bit processes,DEP is enabled by default and cannot be

    > disabled
    >> > >> > (equivalent to /noexecute=AlwaysOn).For these processes, the

    > /noexecute
    >> > >> > parameter is ignored.On a 64-bit operating system,the /noexecute
    >> > >> > parameter
    >> > >> > affects only 32-bit processes running on the system .
    >> > >> >
    >> > >> > Question is :
    >> > >> > Having 2 memory SODIMM 32 bits each ,does it mean I am running

    > 64-bit ?
    >> > >> > If yes , even if I want to turn off the DEP , I CANNOT as

    > explained
    >> > >> > above
    >> > >> > !!!
    >> > >> >
    >> > >> > I tried to turn off DEP (/noexecute=AlwaysOff) but I am still

    > receiving
    >> > >> > messages informing that whatever programs or applications . exe

    > has
    >> > >> > problem
    >> > >> > and need to be closed . I think this PC is crap and I think I
    >> > >> > will
    >> > >> > never
    >> > >> > get rid of this bug , I have to send it back to reseller !
    >> > >> >
    >> > >> > Any genious ideas ????
    >> > >> >
    >> > >> >
    >> > >> >
    >> > >> >
    >> > >>
    >> > >>
    >> >

    >
    >
    John Barnes, Nov 23, 2006
    #12
  13. Thank YOU! I can see my self thoroughly enjoying getting rid of these little
    'buggers'!


    Tony. . .


    "John Barnes" <> wrote in message
    news:...
    > Thanks Tony. I'm in X-64 and you follow the instructions I gave above,
    > click on add and browse to the problem executable. Click okay when you

    find
    > it and the problem is over for that one.
    >
    >
    > "Tony Sperling" <> wrote in message
    > news:...
    > > Do note what John said back there - you may not be able to turn DEP off,
    > > but
    > > you should be able to disable it for specific applications if you

    provide
    > > a
    > > name for it to deal with!
    > >
    > > Tony. . .
    > >
    > >
    > > "poulter90" <> wrote in message
    > > news:D...
    > >> Thanks Jane , although I cannot get rid of this DEP problem , I am
    > >> pleased

    > > I
    > >> can try using several options in the BOOT.INI file to solve it .
    > >>
    > >> Could be a malware on my memory stick !
    > >>
    > >>
    > >>
    > >> "Jane C" wrote:
    > >>
    > >> > I wouldn't let this worry you. You are running a 32 bit operating

    > > system.
    > >> > All processes on your computer are 32 bit. Your 2 SODIMMS at 32 bits

    > > each
    > >> > do not make anything run at 64 bit.
    > >> >
    > >> >
    > >> > --
    > >> > Jane, not plain ;) 64 bit enabled :)
    > >> > Batteries not included. Braincell on vacation ;-)
    > >> > "poulter90" <> wrote in message
    > >> > news:...
    > >> > > Related to this documentation , it seems to be impossible to

    disable
    > > DEP
    > >> > > !!!
    > >> > >
    > >> > > (http://msdn2.microsoft.com/en-us/library/ms791539(d=printer).aspx
    > >> > >
    > >> > > The /noexecute parameter is effective only on 32-bit-processes.It

    > > enables
    > >> > > software enforced DEP and,if the processor supports DEP,it also

    > > enables
    > >> > > hardware-enforced DEP.
    > >> > > On 64-bit processes,DEP is enabled by default and cannot be

    disabled
    > >> > > (equivalent to /noexecute=AlwaysOn).For these processes, the

    > > /noexecute
    > >> > > parameter is ignored.On a 64-bit operating system,the /noexecute

    > > parameter
    > >> > > affects only 32-bit processes running on the system .
    > >> > >
    > >> > > Unless someone has already tried following option in BOOT.IN file
    > >> > > ???
    > >> > > /noexecute=AlwaysOff /nopae or
    > >> > > /noexecute=AlwaysOff / pae
    > >> > >
    > >> > > ???????????????
    > >> > >
    > >> > >
    > >> > >
    > >> > >
    > >> > > "John Barnes" wrote:
    > >> > >
    > >> > >> Hopefully your question will make sense to someone, but you turn

    DEP
    > > off
    > >> > >> or
    > >> > >> on in system properties / advanced / performance / Data Execution
    > >> > >> Prevention
    > >> > >>
    > >> > >>
    > >> > >> "poulter90" <> wrote in message
    > >> > >> news:...
    > >> > >> > Hi all , just a few details about my situation :
    > >> > >> >
    > >> > >> > 1) Specifications of my PC listed by AIDA 32 v3.93
    > >> > >> > Acer 5633WLMI version 2.80 XP service pack SP2 , Media

    Center
    > >> > >> > Edition
    > >> > >> > 2005
    > >> > >> > Multi CPU T5500 1.66 Ghz , 1662 MHZ
    > >> > >> > Memory /M1
    > >> > >> > SODIMM Synchronous 512 MO , size 32 bits
    > >> > >> > Memory/M2
    > >> > >> > SODIMM Synchronous 512 MO, size 32 bits
    > >> > >> >
    > >> > >> > Physical Memory
    > >> > >> > Total 1022 MO
    > >> > >> > Used 462 MO
    > >> > >> > Available 559 MO
    > >> > >> > Usage 45%
    > >> > >> >
    > >> > >> > Swap zone
    > >> > >> > Total 923 MO
    > >> > >> > Used 387 MO
    > >> > >> > Available 535 MO
    > >> > >> > Usage 42%
    > >> > >> >
    > >> > >> > Virtual memory
    > >> > >> > Total 1945 MO
    > >> > >> > Used 849 MO
    > >> > >> > Available 1095 MO
    > >> > >> > Usage 44%
    > >> > >> >
    > >> > >> > BIOS type Phoenix
    > >> > >> > System BIOS date 09/01/06
    > >> > >> > Video BIOS date 08/30/06
    > >> > >> >
    > >> > >> > 2) I red in the documentation
    > >> > >> >

    (http://msdn2.microsoft.com/en-us/library/ms791539(d=printer).aspx
    > >> > >> >
    > >> > >> > The /noexecute parameter is effective only on

    32-bit-processes.It
    > >> > >> > enables
    > >> > >> > software enforced DEP and,if the processor supports DEP,it also

    > > enables
    > >> > >> > hardware-enforced DEP.
    > >> > >> > On 64-bit processes,DEP is enabled by default and cannot be

    > > disabled
    > >> > >> > (equivalent to /noexecute=AlwaysOn).For these processes, the

    > > /noexecute
    > >> > >> > parameter is ignored.On a 64-bit operating system,the /noexecute
    > >> > >> > parameter
    > >> > >> > affects only 32-bit processes running on the system .
    > >> > >> >
    > >> > >> > Question is :
    > >> > >> > Having 2 memory SODIMM 32 bits each ,does it mean I am running

    > > 64-bit ?
    > >> > >> > If yes , even if I want to turn off the DEP , I CANNOT as

    > > explained
    > >> > >> > above
    > >> > >> > !!!
    > >> > >> >
    > >> > >> > I tried to turn off DEP (/noexecute=AlwaysOff) but I am still

    > > receiving
    > >> > >> > messages informing that whatever programs or applications . exe

    > > has
    > >> > >> > problem
    > >> > >> > and need to be closed . I think this PC is crap and I think I
    > >> > >> > will
    > >> > >> > never
    > >> > >> > get rid of this bug , I have to send it back to reseller !
    > >> > >> >
    > >> > >> > Any genious ideas ????
    > >> > >> >
    > >> > >> >
    > >> > >> >
    > >> > >> >
    > >> > >>
    > >> > >>
    > >> >

    > >
    > >

    >
    >
    Tony Sperling, Nov 23, 2006
    #13
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. jp10558
    Replies:
    6
    Views:
    1,391
    Gonig the snotling-scratcher
    Jan 28, 2005
  2. tonysroom
    Replies:
    2
    Views:
    1,789
  3. Andrew Watiker

    DEP with Pentium 4

    Andrew Watiker, Nov 24, 2004, in forum: Computer Information
    Replies:
    3
    Views:
    616
  4. Andrew Watiker

    DEP with Pentium 4

    Andrew Watiker, Nov 24, 2004, in forum: Computer Information
    Replies:
    0
    Views:
    363
    Andrew Watiker
    Nov 24, 2004
  5. alex

    A-DEP mode on Canon EOS

    alex, Nov 6, 2005, in forum: Digital Photography
    Replies:
    7
    Views:
    5,961
    Brian
    Nov 7, 2005
Loading...

Share This Page