X help please

Discussion in 'NZ Computing' started by Dave - Dave.net.nz, Nov 2, 2004.

  1. Ok, so it all runs lovely as root, but if I try as me, I just get the
    following.

    "(EE) Screen(s) found, but none have a usable configuration."

    There is more if it needed, but do I(the user) need to be part of some
    group to have access to x?

    Gentoo 2.6.9
    Nvidia TI4400
    AMD, via mobo, plenty of ram.

    --
    Dave Hall
    http://www.dave.net.nz
    http://www.karyn.net.nz
    Dave - Dave.net.nz, Nov 2, 2004
    #1
    1. Advertising

  2. Dave - Dave.net.nz wrote:
    > Ok, so it all runs lovely as root, but if I try as me, I just get the
    > following.
    > "(EE) Screen(s) found, but none have a usable configuration."
    > There is more if it needed, but do I(the user) need to be part of some
    > group to have access to x?


    > Gentoo 2.6.9
    > Nvidia TI4400
    > AMD, via mobo, plenty of ram.


    yes I've googled, but nothing seems to work as a user, but as root all
    is fine.

    using KDE 3.3.0 I think, can find out if someone tells me how :)

    --
    Dave Hall
    http://www.dave.net.nz
    http://www.karyn.net.nz
    Dave - Dave.net.nz, Nov 2, 2004
    #2
    1. Advertising

  3. Dave - Dave.net.nz

    AD. Guest

    On Tue, 02 Nov 2004 15:35:45 +1300, Dave - Dave.net.nz wrote:

    > Ok, so it all runs lovely as root, but if I try as me, I just get the
    > following.
    >
    > "(EE) Screen(s) found, but none have a usable configuration."
    >
    > There is more if it needed, but do I(the user) need to be part of some
    > group to have access to x?


    That's a strange error to get if it still runs as root. I'd imagine that
    error would affect everyone.

    One thing to check is that you're not (yet) relying on specialised configs
    in home directories. What happens if you force both users to use the same
    config file? eg /etc/X11/xorg.conf

    Cheers
    Anton
    AD., Nov 2, 2004
    #3
  4. AD. wrote:
    >>Ok, so it all runs lovely as root, but if I try as me, I just get the
    >>following.
    >>"(EE) Screen(s) found, but none have a usable configuration."
    >>There is more if it needed, but do I(the user) need to be part of some
    >>group to have access to x?


    > That's a strange error to get if it still runs as root. I'd imagine that
    > error would affect everyone.


    I know... typical me, it does something strange.

    > One thing to check is that you're not (yet) relying on specialised configs
    > in home directories. What happens if you force both users to use the same
    > config file? eg /etc/X11/xorg.conf


    care to tell me how to do that? Im just new you know.
    just "startx /etc/X11/xorg.conf"

    --
    Dave Hall
    http://www.dave.net.nz
    http://www.karyn.net.nz
    Dave - Dave.net.nz, Nov 2, 2004
    #4
  5. Dave - Dave.net.nz

    Chris Hope Guest

    Dave - Dave.net.nz wrote:

    > AD. wrote:
    >>>Ok, so it all runs lovely as root, but if I try as me, I just get the
    >>>following.
    >>>"(EE) Screen(s) found, but none have a usable configuration."
    >>>There is more if it needed, but do I(the user) need to be part of some
    >>>group to have access to x?

    >
    >> That's a strange error to get if it still runs as root. I'd imagine that
    >> error would affect everyone.

    >
    > I know... typical me, it does something strange.
    >
    >> One thing to check is that you're not (yet) relying on specialised
    >> configs in home directories. What happens if you force both users to use
    >> the same config file? eg /etc/X11/xorg.conf

    >
    > care to tell me how to do that? Im just new you know.
    > just "startx /etc/X11/xorg.conf"


    I'm using Gentoo as well. I just run "startx". I have a file in my home
    directory called ".xinitrc" which simply contains "exec startkde"

    To see what's in this file do "cat ~/.xinitrc"

    If it doesn't exist you can create it like so:
    echo "exec startkde" > ~/.xinitrc

    Then do
    startx

    --
    Chris Hope - The Electric Toolbox - http://www.electrictoolbox.com/
    Chris Hope, Nov 2, 2004
    #5
  6. Dave - Dave.net.nz

    AD. Guest

    On Tue, 02 Nov 2004 16:25:14 +1300, Dave - Dave.net.nz wrote:

    > AD. wrote:
    >>>Ok, so it all runs lovely as root, but if I try as me, I just get the
    >>>following.
    >>>"(EE) Screen(s) found, but none have a usable configuration." There is
    >>>more if it needed, but do I(the user) need to be part of some group to
    >>>have access to x?

    >
    >> That's a strange error to get if it still runs as root. I'd imagine that
    >> error would affect everyone.

    >
    > I know... typical me, it does something strange.


    The reason I thought it was weird is that that message indicates a
    misconfiguration not a permissions problem. One reason could be that root
    is using a valid config file and the user somehow isn't.

    >
    >> One thing to check is that you're not (yet) relying on specialised
    >> configs in home directories. What happens if you force both users to use
    >> the same config file? eg /etc/X11/xorg.conf

    >
    > care to tell me how to do that? Im just new you know. just "startx
    > /etc/X11/xorg.conf"


    I'm a little Gentoo ignorant, but I did do an install a few weeks ago.
    After reading this doc...

    http://www.gentoo.org/doc/en/xorg-config.xml

    .... and assuming /etc/X11/xorg.conf is your system wide config file, I'd
    try:

    X -config /etc/X11/xorg.conf

    as both users, and check whether they still get different results.

    Also check for differences in ~/.xinitrc for both users. You could try
    backing up /home/$USER/.xinitrc and overwriting it with /root/.xinitrc
    maybe. Don't forget to change the ownership of the copy to $USER.

    Just some ideas to hopefully narrow down stuff.

    Cheers
    Anton
    AD., Nov 2, 2004
    #6
  7. Dave - Dave.net.nz

    Allistar Guest

    Dave - Dave.net.nz wrote:

    > Ok, so it all runs lovely as root, but if I try as me, I just get the
    > following.
    >
    > "(EE) Screen(s) found, but none have a usable configuration."
    >
    > There is more if it needed, but do I(the user) need to be part of some
    > group to have access to x?
    >
    > Gentoo 2.6.9
    > Nvidia TI4400
    > AMD, via mobo, plenty of ram.


    Have you done an:

    emerge nvidia-kernel
    emerge nvidia-glx

    (Doesn't answer your question, but I foiund the only way I could play UT2004
    under Gentoo was to use the Gentoo nvidia sources rather tan the nvidia
    ones).

    Also does "dmesg" give any clues?

    Allistar.
    Allistar, Nov 2, 2004
    #7
  8. Dave - Dave.net.nz

    AD. Guest

    On Fri, 29 Oct 2004 17:11:22 +1300, Dave - Dave.net.nz wrote:

    > AD. wrote:
    >> I'm a little Gentoo ignorant, but I did do an install a few weeks ago.
    >> After reading this doc...
    >> http://www.gentoo.org/doc/en/xorg-config.xml

    >
    > read it, and alot of it has to be done by root, as in "X -config
    > /etc/X11/xorg.conf"
    > it says I cant find it if Im me, but as root works fine.
    >
    > The exact message is.
    > Invalid arguement for -config
    > For non-root users, the file specified with -config must be a reletive
    > path and must not contain any ".." elements. Using default xorg.conf
    > search path


    Does this change the above error message:

    cd /etc
    X -config X11/xorg.conf

    Have you also checked that the config file can be read by your user?

    >> Also check for differences in ~/.xinitrc for both users. You could try
    >> backing up /home/$USER/.xinitrc and overwriting it with /root/.xinitrc
    >> maybe. Don't forget to change the ownership of the copy to $USER.

    >
    > how?(yes I need hand holding)


    as root, something like (substitute your username for $USER):

    cp /root/.xinitrc /home/$USER/
    chown $USER /home/$USER/.xinitrc


    Although thinking about it some more, it could be a path or
    environment type problem.

    My install used a Matrox card so didn't need any special modules installed
    or anything. It might be possible that whatever nVidia modules you need
    don't have the right permissions?

    Have you tried a using display manager?

    Cheers
    Anton
    AD., Nov 2, 2004
    #8
  9. In article <>, "AD." <> wrote:
    (snip)
    >My install used a Matrox card so didn't need any special modules installed
    >or anything. It might be possible that whatever nVidia modules you need
    >don't have the right permissions?


    As an aside, I have heard mutterings about Nvidia and rehat. There were
    supposed to be drivers on the Nvidia web site ... maybe it's worth a look
    if you are still having no success ?




    Bruce

    ------------------------------
    Health nuts are going to feel stupid someday, lying in hospitals
    dying of nothing.

    -Redd Foxx


    Caution ===== followups may have been changed to relevant groups
    (if there were any)
    Bruce Sinclair, Nov 2, 2004
    #9
  10. AD. wrote:
    >>The exact message is.
    >>Invalid arguement for -config
    >>For non-root users, the file specified with -config must be a reletive
    >>path and must not contain any ".." elements. Using default xorg.conf
    >>search path


    > Does this change the above error message:
    > cd /etc
    > X -config X11/xorg.conf


    nope, exact same message.

    > Have you also checked that the config file can be read by your user?


    nope, not sure how to.

    >>>Also check for differences in ~/.xinitrc for both users. You could try
    >>>backing up /home/$USER/.xinitrc and overwriting it with /root/.xinitrc
    >>>maybe. Don't forget to change the ownership of the copy to $USER.

    >>how?(yes I need hand holding)


    > as root, something like (substitute your username for $USER):


    > cp /root/.xinitrc /home/$USER/
    > chown $USER /home/$USER/.xinitrc


    I copied it, but when I try chown, I get this.
    "chown: too few arguments"
    "Try `chown --help' for more information."

    > Although thinking about it some more, it could be a path or
    > environment type problem.


    > My install used a Matrox card so didn't need any special modules installed
    > or anything. It might be possible that whatever nVidia modules you need
    > don't have the right permissions?


    > Have you tried a using display manager?


    shit... whats a display manager?
    you're making me feel rather in over my head.

    --
    Dave Hall
    http://www.dave.net.nz
    http://www.karyn.net.nz
    Dave - Dave.net.nz, Nov 2, 2004
    #10
  11. Dave - Dave.net.nz wrote:

    > AD. wrote:
    >
    >>> The exact message is.
    >>> Invalid arguement for -config
    >>> For non-root users, the file specified with -config must be a reletive
    >>> path and must not contain any ".." elements. Using default xorg.conf
    >>> search path

    >
    >
    >> Does this change the above error message:
    >> cd /etc
    >> X -config X11/xorg.conf

    >
    >
    > nope, exact same message.
    >
    >> Have you also checked that the config file can be read by your user?

    >
    >
    > nope, not sure how to.


    I have discovered that root can nolonger do it either... so now it just
    isnt working, which may or may not be a good thing.

    I also discovered that I can get a good readout of the errors, if I just
    launch x from an ssh session..

    so here it is.


    ***************************************************************************************************
    2ndgen root # startx
    hostname: Host name lookup failure

    X Window System Version 6.8.0
    Release Date: 8 September 2004
    X Protocol Version 11, Revision 0, Release 6.8
    Build Operating System: Linux 2.6.9-gentoo-r1 i686 [ELF]
    Current Operating System: Linux 2ndgen 2.6.9-gentoo-r1 #1 Mon Nov 1
    22:41:07 NZDT 2004 i686
    Build Date: 02 November 2004
    Before reporting problems, check http://wiki.X.Org
    to make sure that you have the latest version.
    Module Loader present
    Markers: (--) probed, (**) from config file, (==) default setting,
    (++) from command line, (!!) notice, (II) informational,
    (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
    (==) Log file: "/var/log/Xorg.0.log", Time: Wed Nov 3 08:53:04 2004
    (==) Using config file: "/etc/X11/xorg.conf"

    Using vt 7
    (WW) NV(0): Failed to set up write-combining range (0xd0000000,0x8000000)
    Symbol __glXgetActiveScreen from module
    /usr/X11R6/lib/modules/extensions/libdri.a is unresolved!
    Symbol __glXgetActiveScreen from module
    /usr/X11R6/lib/modules/extensions/libdri.a is unresolved!
    (EE) Failed to initialize GLX extension (NVIDIA XFree86 driver not found)
    **************************************************************************************************

    I hope that this can help someone find out what I've done wrong/done to
    break it.

    --
    Dave Hall
    http://www.dave.net.nz
    http://www.karyn.net.nz
    Dave - Dave.net.nz, Nov 2, 2004
    #11
  12. Dave - Dave.net.nz

    Allistar Guest

    Dave - Dave.net.nz wrote:

    > Dave - Dave.net.nz wrote:
    >
    >> AD. wrote:
    >>
    >>>> The exact message is.
    >>>> Invalid arguement for -config
    >>>> For non-root users, the file specified with -config must be a reletive
    >>>> path and must not contain any ".." elements. Using default xorg.conf
    >>>> search path

    >>
    >>
    >>> Does this change the above error message:
    >>> cd /etc
    >>> X -config X11/xorg.conf

    >>
    >>
    >> nope, exact same message.
    >>
    >>> Have you also checked that the config file can be read by your user?

    >>
    >>
    >> nope, not sure how to.

    >
    > I have discovered that root can nolonger do it either... so now it just
    > isnt working, which may or may not be a good thing.
    >
    > I also discovered that I can get a good readout of the errors, if I just
    > launch x from an ssh session..
    >
    > so here it is.
    >
    >
    >

    ***************************************************************************************************
    > 2ndgen root # startx
    > hostname: Host name lookup failure
    >
    > X Window System Version 6.8.0
    > Release Date: 8 September 2004
    > X Protocol Version 11, Revision 0, Release 6.8
    > Build Operating System: Linux 2.6.9-gentoo-r1 i686 [ELF]
    > Current Operating System: Linux 2ndgen 2.6.9-gentoo-r1 #1 Mon Nov 1
    > 22:41:07 NZDT 2004 i686
    > Build Date: 02 November 2004
    > Before reporting problems, check http://wiki.X.Org
    > to make sure that you have the latest version.
    > Module Loader present
    > Markers: (--) probed, (**) from config file, (==) default setting,
    > (++) from command line, (!!) notice, (II) informational,
    > (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
    > (==) Log file: "/var/log/Xorg.0.log", Time: Wed Nov 3 08:53:04 2004
    > (==) Using config file: "/etc/X11/xorg.conf"
    >
    > Using vt 7
    > (WW) NV(0): Failed to set up write-combining range (0xd0000000,0x8000000)
    > Symbol __glXgetActiveScreen from module
    > /usr/X11R6/lib/modules/extensions/libdri.a is unresolved!
    > Symbol __glXgetActiveScreen from module
    > /usr/X11R6/lib/modules/extensions/libdri.a is unresolved!
    > (EE) Failed to initialize GLX extension (NVIDIA XFree86 driver not found)
    >

    **************************************************************************************************
    >
    > I hope that this can help someone find out what I've done wrong/done to
    > break it.


    As root do this:

    emerge nvidia-kernel
    emerge nvidia-glx
    opengl-update nvidia

    edit the /etc/X11/xorg.conf file by typing in this command (make sure you're
    root first):

    nano /etc/X11/xorg.conf

    make sure the "Device" section says:

    Driver "nvidia"

    and not

    Driver "nv"

    Make the "Module" section look like this:

    Section "Module"
    Load "dbe" # Double buffer extension

    SubSection "extmod"
    Option "omit xfree86-dga" # don't initialise the DGA extension
    EndSubSection

    Load "type1"
    Load "speedo"
    # Load "dri"
    Load "glx"
    EndSection

    If you are running a 2.6 series kernel then you should
    edit /etc/modules.autoload.d/kernel-2.6 and make sure it caontains a line
    that says "nvidia" (without the quotes). This will make sure the nvidia
    module is loaded automatically. You can manualy load this module by typing
    "modprobe nvidia" as root, and you can see what modules are loaded by
    typing "lsmod" as root.

    Hope this helps,
    Allistar.
    Allistar, Nov 2, 2004
    #12
  13. Allistar wrote:

    > Dave - Dave.net.nz wrote:
    >
    >
    >>Dave - Dave.net.nz wrote:
    >>
    >>
    >>>AD. wrote:
    >>>
    >>>
    >>>>>The exact message is.
    >>>>>Invalid arguement for -config
    >>>>>For non-root users, the file specified with -config must be a reletive
    >>>>>path and must not contain any ".." elements. Using default xorg.conf
    >>>>>search path
    >>>
    >>>
    >>>>Does this change the above error message:
    >>>>cd /etc
    >>>>X -config X11/xorg.conf
    >>>
    >>>
    >>>nope, exact same message.
    >>>
    >>>
    >>>>Have you also checked that the config file can be read by your user?
    >>>
    >>>
    >>>nope, not sure how to.

    >>
    >>I have discovered that root can nolonger do it either... so now it just
    >>isnt working, which may or may not be a good thing.
    >>
    >>I also discovered that I can get a good readout of the errors, if I just
    >>launch x from an ssh session..
    >>
    >>so here it is.
    >>
    >>
    >>

    >
    > ***************************************************************************************************
    >
    >>2ndgen root # startx
    >>hostname: Host name lookup failure
    >>
    >>X Window System Version 6.8.0
    >>Release Date: 8 September 2004
    >>X Protocol Version 11, Revision 0, Release 6.8
    >>Build Operating System: Linux 2.6.9-gentoo-r1 i686 [ELF]
    >>Current Operating System: Linux 2ndgen 2.6.9-gentoo-r1 #1 Mon Nov 1
    >>22:41:07 NZDT 2004 i686
    >>Build Date: 02 November 2004
    >> Before reporting problems, check http://wiki.X.Org
    >> to make sure that you have the latest version.
    >>Module Loader present
    >>Markers: (--) probed, (**) from config file, (==) default setting,
    >> (++) from command line, (!!) notice, (II) informational,
    >> (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
    >>(==) Log file: "/var/log/Xorg.0.log", Time: Wed Nov 3 08:53:04 2004
    >>(==) Using config file: "/etc/X11/xorg.conf"
    >>
    >>Using vt 7
    >>(WW) NV(0): Failed to set up write-combining range (0xd0000000,0x8000000)
    >>Symbol __glXgetActiveScreen from module
    >>/usr/X11R6/lib/modules/extensions/libdri.a is unresolved!
    >>Symbol __glXgetActiveScreen from module
    >>/usr/X11R6/lib/modules/extensions/libdri.a is unresolved!
    >>(EE) Failed to initialize GLX extension (NVIDIA XFree86 driver not found)
    >>

    >
    > **************************************************************************************************
    >
    >>I hope that this can help someone find out what I've done wrong/done to
    >>break it.

    >
    >
    > As root do this:
    >
    > emerge nvidia-kernel
    > emerge nvidia-glx
    > opengl-update nvidia
    >
    > edit the /etc/X11/xorg.conf file by typing in this command (make sure you're
    > root first):
    >
    > nano /etc/X11/xorg.conf
    >
    > make sure the "Device" section says:
    >
    > Driver "nvidia"
    >
    > and not
    >
    > Driver "nv"
    >
    > Make the "Module" section look like this:
    >
    > Section "Module"
    > Load "dbe" # Double buffer extension
    >
    > SubSection "extmod"
    > Option "omit xfree86-dga" # don't initialise the DGA extension
    > EndSubSection
    >
    > Load "type1"
    > Load "speedo"
    > # Load "dri"
    > Load "glx"
    > EndSection
    >
    > If you are running a 2.6 series kernel then you should
    > edit /etc/modules.autoload.d/kernel-2.6 and make sure it caontains a line
    > that says "nvidia" (without the quotes). This will make sure the nvidia
    > module is loaded automatically. You can manualy load this module by typing
    > "modprobe nvidia" as root, and you can see what modules are loaded by
    > typing "lsmod" as root.
    >
    > Hope this helps,


    doing the emerge bits now, thanks, will keep you updated.

    --
    Dave Hall
    http://www.dave.net.nz
    http://www.karyn.net.nz
    Dave - Dave.net.nz, Nov 2, 2004
    #13
  14. Dave - Dave.net.nz wrote:
    > doing the emerge bits now, thanks, will keep you updated.


    failed to load nvidia
    failed to load speedo

    *************************************************************************************
    hostname: Host name lookup failure

    X Window System Version 6.8.0
    Release Date: 8 September 2004
    X Protocol Version 11, Revision 0, Release 6.8
    Build Operating System: Linux 2.6.9-gentoo-r1 i686 [ELF]
    Current Operating System: Linux 2ndgen 2.6.9-gentoo-r1 #1 Mon Nov 1
    22:41:07 NZDT 2004 i686
    Build Date: 03 November 2004
    Before reporting problems, check http://wiki.X.Org
    to make sure that you have the latest version.
    Module Loader present
    Markers: (--) probed, (**) from config file, (==) default setting,
    (++) from command line, (!!) notice, (II) informational,
    (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
    (==) Log file: "/var/log/Xorg.0.log", Time: Wed Nov 3 21:20:59 2004
    (==) Using config file: "/etc/X11/xorg.conf"

    Using vt 7
    (EE) Failed to load module "speedo" (module does not exist, 0)
    (EE) NVIDIA(0): Failed to initialize the NVIDIA kernel module!
    (EE) NVIDIA(0): *** Aborting ***
    (EE) Screen(s) found, but none have a usable configuration.

    Fatal server error:
    no screens found
    *************************************************************************************

    --
    Dave Hall
    http://www.dave.net.nz
    http://www.karyn.net.nz
    Dave - Dave.net.nz, Nov 2, 2004
    #14
  15. Dave - Dave.net.nz

    AD. Guest

    On Tue, 02 Nov 2004 19:54:27 +1300, Dave - Dave.net.nz wrote:

    > Using vt 7
    > (WW) NV(0): Failed to set up write-combining range (0xd0000000,0x8000000)
    > Symbol __glXgetActiveScreen from module
    > /usr/X11R6/lib/modules/extensions/libdri.a is unresolved! Symbol
    > __glXgetActiveScreen from module
    > /usr/X11R6/lib/modules/extensions/libdri.a is unresolved! (EE) Failed to
    > initialize GLX extension (NVIDIA XFree86 driver not found)
    > **************************************************************************************************
    >
    > I hope that this can help someone find out what I've done wrong/done to
    > break it.


    That's definitely a problem loading the nVidia drivers, and I don't really
    know much about using new nVidia or ATI cards under X. Things are
    apparently a bit trickier with these new fangled not-quite-free-software
    drivers you get from vendors.

    Use a Matrox card ;)

    Cheers
    Anton
    AD., Nov 2, 2004
    #15
  16. AD. wrote:
    >>I hope that this can help someone find out what I've done wrong/done to
    >>break it.


    > That's definitely a problem loading the nVidia drivers, and I don't really
    > know much about using new nVidia or ATI cards under X. Things are
    > apparently a bit trickier with these new fangled not-quite-free-software
    > drivers you get from vendors.


    I dont really care for playing games under linux, so all I need is "a
    desktop" no fandangled features needed.

    > Use a Matrox card ;)


    got one at home, will do. :)

    --
    Dave Hall
    http://www.dave.net.nz
    http://www.karyn.net.nz
    Dave - Dave.net.nz, Nov 2, 2004
    #16
  17. Dave - Dave.net.nz

    AD. Guest

    On Wed, 03 Nov 2004 09:15:59 +1300, Dave - Dave.net.nz wrote:

    > I dont really care for playing games under linux, so all I need is "a
    > desktop" no fandangled features needed.


    I've never used GLX, and I've turned out OK ;)

    >
    >> Use a Matrox card ;)

    >
    > got one at home, will do. :)


    I admit it was a bit of a Lennier/Steve style solution to a problem, and
    had my tongue in my cheek when I said it. After all plenty of people have
    got nVidia stuff working, I just have no experience with it.

    I even found the Matrox dualhead/xinerama stuff pretty easy to setup with
    X.org and the man pages. I wasn't much of an XFree86 config whiz before
    that either. I think the X.org fork is a very good thing - progress is
    being made again and X should get much easier to config in the future.
    XFree86 was going nowhere.

    Cheers
    Anton
    AD., Nov 2, 2004
    #17
  18. Dave - Dave.net.nz

    AD. Guest

    On Wed, 03 Nov 2004 08:20:43 +1300, Dave - Dave.net.nz wrote:

    > Dave - Dave.net.nz wrote:
    >> doing the emerge bits now, thanks, will keep you updated.

    >
    > failed to load nvidia
    > failed to load speedo
    >
    > *************************************************************************************
    > hostname: Host name lookup failure
    >
    > X Window System Version 6.8.0
    > Release Date: 8 September 2004
    > X Protocol Version 11, Revision 0, Release 6.8 Build Operating System:
    > Linux 2.6.9-gentoo-r1 i686 [ELF] Current Operating System: Linux 2ndgen
    > 2.6.9-gentoo-r1 #1 Mon Nov 1 22:41:07 NZDT 2004 i686
    > Build Date: 03 November 2004
    > Before reporting problems, check http://wiki.X.Org to make sure
    > that you have the latest version.
    > Module Loader present
    > Markers: (--) probed, (**) from config file, (==) default setting,
    > (++) from command line, (!!) notice, (II) informational, (WW)
    > warning, (EE) error, (NI) not implemented, (??) unknown.
    > (==) Log file: "/var/log/Xorg.0.log", Time: Wed Nov 3 21:20:59 2004 (==)
    > Using config file: "/etc/X11/xorg.conf"
    >
    > Using vt 7
    > (EE) Failed to load module "speedo" (module does not exist, 0) (EE)
    > NVIDIA(0): Failed to initialize the NVIDIA kernel module! (EE) NVIDIA(0):
    > *** Aborting ***
    > (EE) Screen(s) found, but none have a usable configuration.
    >
    > Fatal server error:
    > no screens found
    > *************************************


    What did the output of Allistars 'modprobe nvidia' and 'lsmod' suggestions
    say?

    Cheers
    Anton
    AD., Nov 2, 2004
    #18
  19. Dave - Dave.net.nz

    AD. Guest

    On Wed, 03 Nov 2004 08:20:43 +1300, Dave - Dave.net.nz wrote:

    > Dave - Dave.net.nz wrote:
    >> doing the emerge bits now, thanks, will keep you updated.

    >
    > failed to load nvidia
    > failed to load speedo
    >
    > *************************************************************************************
    > hostname: Host name lookup failure


    That sounds strange. Is your hosts file correct? What does the hostname
    command say? Can you ping localhost and/or your hostname?

    Have you tried the Gentoo forums? They are pretty good for this kind of
    thing.

    Cheers
    Anton
    AD., Nov 2, 2004
    #19
  20. Dave - Dave.net.nz

    Enkidu Guest

    On Wed, 03 Nov 2004 09:15:59 +1300, "Dave - Dave.net.nz"
    <> wrote:

    >AD. wrote:
    >>>I hope that this can help someone find out what I've done wrong/done to
    >>>break it.

    >
    >> That's definitely a problem loading the nVidia drivers, and I don't really
    >> know much about using new nVidia or ATI cards under X. Things are
    >> apparently a bit trickier with these new fangled not-quite-free-software
    >> drivers you get from vendors.

    >
    >I dont really care for playing games under linux, so all I need is "a
    >desktop" no fandangled features needed.
    >

    Then use the default SVGA server. That will at least get it going.

    Cheers,

    Cliff
    Enkidu, Nov 2, 2004
    #20
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. tpg comcntr

    HELP! HELP! PLEASE, PLEASE, PLEASE

    tpg comcntr, Feb 14, 2004, in forum: Computer Support
    Replies:
    11
    Views:
    868
    michael turner
    Feb 15, 2004
  2. Nick

    Computer problems please please please help

    Nick, Jun 4, 2004, in forum: Computer Support
    Replies:
    0
    Views:
    453
  3. Replies:
    2
    Views:
    533
    David Hemingsley
    Oct 31, 2004
  4. The Martian

    Help Help Help Please Pentax S5i info needed

    The Martian, May 19, 2008, in forum: Digital Photography
    Replies:
    2
    Views:
    484
    The Martian
    May 20, 2008
  5. The Martian

    Help Help Help Pentax S5i Help needed (Please)

    The Martian, Jun 4, 2008, in forum: Digital Photography
    Replies:
    14
    Views:
    1,527
    ASAAR
    Jun 20, 2008
Loading...

Share This Page