Wireless on WinXP, LAN connection to PC won't allow sharing - IP already in use.

Discussion in 'Wireless Networking' started by Jamie Furlong, Feb 18, 2006.

  1. Wireless adaptor is 192.168.0.10
    XP (connected to wireless) is 192.168.0.10

    Trying to share a lan connection to a Win98 via a crossover cable, which
    worked OK when I shared a Win 2000 machine.

    Now getting:

    "An error occurred while Internet Connection Sharing was being enabled.
    Internet Connection Sharin cannot be enabled. A LAN connection is already
    configured with the IP address that is required for automatic IP
    addressing." Sounds like 192.168.0.1 is somewhere on my system. But
    where? Why can't I ping it? When I enter ipconfig I get only 192.168.0.2
    and 192.168.0.10. How can I find the problem?

    If I manually config the LAN to be 192.168.0.1, then I lose DNS from my XP
    machine!

    It's weird as hell, taken loads of reboots and hours of time out of my life!

    Help appreciated :)
     
    Jamie Furlong, Feb 18, 2006
    #1
    1. Advertising

  2. In article <#>, "Jamie Furlong"
    <> wrote:
    >Wireless adaptor is 192.168.0.10
    >XP (connected to wireless) is 192.168.0.10
    >
    >Trying to share a lan connection to a Win98 via a crossover cable, which
    >worked OK when I shared a Win 2000 machine.
    >
    >Now getting:
    >
    > "An error occurred while Internet Connection Sharing was being enabled.
    >Internet Connection Sharin cannot be enabled. A LAN connection is already
    >configured with the IP address that is required for automatic IP
    >addressing." Sounds like 192.168.0.1 is somewhere on my system. But
    >where? Why can't I ping it? When I enter ipconfig I get only 192.168.0.2
    >and 192.168.0.10. How can I find the problem?
    >
    >If I manually config the LAN to be 192.168.0.1, then I lose DNS from my XP
    >machine!
    >
    >It's weird as hell, taken loads of reboots and hours of time out of my life!
    >
    >Help appreciated :)


    ICS wants to assign 192.168.0.1 to the LAN connection. It can't do
    that, because the wireless network is already using the 192.168.0.x IP
    address range. The Internet connection and the LAN must use different
    ranges.

    To use ICS, change the wireless network to a different address range,
    such as 192.168.1.x.
    --
    Best Wishes,
    Steve Winograd, MS-MVP (Windows Networking)

    Please post any reply as a follow-up message in the news group
    for everyone to see. I'm sorry, but I don't answer questions
    addressed directly to me in E-mail or news groups.

    Microsoft Most Valuable Professional - Windows Networking
    http://mvp.support.microsoft.com

    Steve Winograd's Networking FAQ
    http://www.bcmaven.com/networking/faq.htm
     
    Steve Winograd [MVP], Feb 18, 2006
    #2
    1. Advertising

  3. "Steve Winograd [MVP]" <> wrote in message
    news:...

    > ICS wants to assign 192.168.0.1 to the LAN connection. It can't do
    > that, because the wireless network is already using the 192.168.0.x IP
    > address range. The Internet connection and the LAN must use different
    > ranges.
    >
    > To use ICS, change the wireless network to a different address range,
    > such as 192.168.1.x.


    Thanks Steve - *sigh* of course, that's the thing I DIDN'T try!

    I'd changed the wireless adaptor to be 0.10, I'd set all other machines to
    be 0.11 and above.
    I'd made sure there was nothing running on the local machine with a port.

    What I didn't realise was that it had to change from 192.168.0.x to
    192.168.x.x - does this mean a subnet mask will have to change somewhere?
    Cos I can JUST handle normal stuff, but when subnet masks come into play,
    anything other than 255.255.255.0 has me in a spin!

    I guess I'll have to google for a tutorial and understand one day!

    Thanks again for the help - mentally noted in my reserved area!
     
    Jamie Furlong, Feb 19, 2006
    #3
  4. In article <>, "Jamie Furlong"
    <> wrote:
    >"Steve Winograd [MVP]" <> wrote in message
    >news:...
    >> ICS wants to assign 192.168.0.1 to the LAN connection. It can't do
    >> that, because the wireless network is already using the 192.168.0.x IP
    >> address range. The Internet connection and the LAN must use different
    >> ranges.
    >>
    >> To use ICS, change the wireless network to a different address range,
    >> such as 192.168.1.x.

    >
    >Thanks Steve - *sigh* of course, that's the thing I DIDN'T try!
    >
    >I'd changed the wireless adaptor to be 0.10, I'd set all other machines to
    >be 0.11 and above.
    >I'd made sure there was nothing running on the local machine with a port.
    >
    >What I didn't realise was that it had to change from 192.168.0.x to
    >192.168.x.x - does this mean a subnet mask will have to change somewhere?
    >Cos I can JUST handle normal stuff, but when subnet masks come into play,
    >anything other than 255.255.255.0 has me in a spin!
    >
    >I guess I'll have to google for a tutorial and understand one day!
    >
    >Thanks again for the help - mentally noted in my reserved area!


    You're welcome, Jamie. Use a subnet mask of 255.255.255.0 on the
    wireless network and the LAN. That mask simply means that IP
    addresses that are the same in the first three numbers are in the same
    subnet. For example:

    192.168.0.1 and 192.168.0.10 are in the same subnet
    192.168.0.1 and 192.168.1.1 are in different subnets
    --
    Best Wishes,
    Steve Winograd, MS-MVP (Windows Networking)

    Please post any reply as a follow-up message in the news group
    for everyone to see. I'm sorry, but I don't answer questions
    addressed directly to me in E-mail or news groups.

    Microsoft Most Valuable Professional - Windows Networking
    http://mvp.support.microsoft.com

    Steve Winograd's Networking FAQ
    http://www.bcmaven.com/networking/faq.htm
     
    Steve Winograd [MVP], Feb 19, 2006
    #4
  5. Jamie Furlong

    kornfanjoe

    Joined:
    Jan 16, 2009
    Messages:
    1
    An error occurred while Internet Connection Sharing was being enabled

    Internet Connection Sharing cannot be enabled.
    A LAN connection is already configured with the IP address
    that is required for automatic IP addressing.

    i tried advice of turning off the adapter and it allowed me to enable sharing but for some reason that
    blocked my internet i was still connected but not able to use anything needing internet
    i really need help here and am lost i have windows xp...when i bring my xbox to friends houses it connects
    instantly no problems but mine wont work no matter what i try
    i have a trendnet usb adapter and i dont know what the router is because it is hidden
    any help will be appreciated
     
    kornfanjoe, Jan 16, 2009
    #5
  6. Jamie Furlong

    mamadjahad

    Joined:
    Aug 27, 2011
    Messages:
    1
    Same problem

    I have the same warning showing up while i'm trying to share my internet for wireless ad hoc network in windows 7, the same warning shows as: a Lan connection is already configured with the IP address that is required for automatic IP addressing, what should i do?
     
    mamadjahad, Aug 27, 2011
    #6
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Sens Fan Happy In Ohio

    WinXP SP2 Won't Allow Macromedia Flash Player Download

    Sens Fan Happy In Ohio, Oct 27, 2004, in forum: Computer Support
    Replies:
    1
    Views:
    688
    PuppyKatt
    Oct 28, 2004
  2. Franz Schenk

    deactivate wireless connection when LAN connection?

    Franz Schenk, Dec 22, 2006, in forum: Wireless Networking
    Replies:
    2
    Views:
    483
    =?Utf-8?B?UGF2ZWwgQS4=?=
    Dec 24, 2006
  3. spoon2001
    Replies:
    2
    Views:
    396
    Bruce Lewis
    May 29, 2006
  4. Philip
    Replies:
    4
    Views:
    402
    James West
    Feb 25, 2006
  5. Resi
    Replies:
    2
    Views:
    2,463
Loading...

Share This Page